diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-08-25 00:14:20 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-28 11:06:06 +0200 |
commit | 2b1e724cbbb2260f41466a295aa01215164ec8b4 (patch) | |
tree | e89be71f171eee658cfa28f601bf85f42e74fab2 /meta-oe | |
parent | 59d3cd68b824b19b9675a9c5965cd86c871eeef5 (diff) | |
download | meta-openembedded-2b1e724cbbb2260f41466a295aa01215164ec8b4.tar.gz |
wvstreams: Fix parallel build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
3 files changed, 107 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/0001-build-fix-parallel-make.patch b/meta-oe/recipes-connectivity/wvdial/wvstreams/0001-build-fix-parallel-make.patch new file mode 100644 index 000000000..6bc34331d --- /dev/null +++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/0001-build-fix-parallel-make.patch | |||
@@ -0,0 +1,76 @@ | |||
1 | From 90de630f21ac744a37b3adac1bd84654471744ff Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 24 Aug 2017 22:30:01 -0700 | ||
4 | Subject: [PATCH 1/2] build: fix parallel make | ||
5 | |||
6 | Imported from Gentoo | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | Makefile | 15 +++++++++++++-- | ||
11 | wvrules-posix.mk | 7 +++++-- | ||
12 | 2 files changed, 18 insertions(+), 4 deletions(-) | ||
13 | |||
14 | diff --git a/Makefile b/Makefile | ||
15 | index 72c8bef..5a4cfb2 100644 | ||
16 | --- a/Makefile | ||
17 | +++ b/Makefile | ||
18 | @@ -131,12 +131,19 @@ utils/tests/%: PRELIBS+=$(LIBWVSTREAMS) | ||
19 | # libwvstreams: stream/event handling library | ||
20 | # | ||
21 | TARGETS += libwvstreams.so | ||
22 | -TARGETS += crypto/tests/ssltest ipstreams/tests/unixtest | ||
23 | +TARGETS += crypto/tests/ssltest | ||
24 | +crypto/tests/ssltest: $(LIBWVSTREAMS) | ||
25 | + | ||
26 | +TARGETS += ipstreams/tests/unixtest | ||
27 | +ipstreams/tests/unixtest: $(LIBWVSTREAMS) | ||
28 | + | ||
29 | TARGETS += crypto/tests/printcert | ||
30 | +crypto/tests/printcert: $(LIBWVSTREAMS) | ||
31 | |||
32 | ifndef _MACOS | ||
33 | ifneq ("$(with_readline)", "no") | ||
34 | TARGETS += ipstreams/tests/wsd | ||
35 | + ipstreams/tests/wsd: $(LIBWVSTREAMS) | ||
36 | ipstreams/tests/wsd-LIBS += -lreadline | ||
37 | else | ||
38 | TEST_SKIP_OBJS += ipstreams/tests/wsd | ||
39 | @@ -179,7 +186,11 @@ uniconf/tests/%: PRELIBS+=$(LIBUNICONF) | ||
40 | # | ||
41 | ifneq ("$(with_dbus)", "no") | ||
42 | TARGETS += libwvdbus.so | ||
43 | - TARGETS += dbus/tests/wvdbus dbus/tests/wvdbusd | ||
44 | + TARGETS += dbus/tests/wvdbus | ||
45 | + dbus/tests/wvdbus: $(LIBWVDBUS) | ||
46 | + | ||
47 | + TARGETS += dbus/tests/wvdbusd | ||
48 | + dbus/tests/wvdbusd: $(LIBWVDBUS) | ||
49 | TESTS += $(call tests_cc,dbus/tests) | ||
50 | libwvdbus_OBJS += $(call objects,dbus) | ||
51 | libwvdbus.so: $(libwvdbus_OBJS) $(LIBWVSTREAMS) | ||
52 | diff --git a/wvrules-posix.mk b/wvrules-posix.mk | ||
53 | index f94d2cd..2e99f36 100644 | ||
54 | --- a/wvrules-posix.mk | ||
55 | +++ b/wvrules-posix.mk | ||
56 | @@ -80,12 +80,15 @@ define wvlink_ar | ||
57 | $(AR) s $1 | ||
58 | endef | ||
59 | |||
60 | -CC: FORCE | ||
61 | +CC: | ||
62 | @CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \ | ||
63 | $(WVSTREAMS)/gen-cc CC c | ||
64 | |||
65 | -CXX: FORCE | ||
66 | +CXX: | ||
67 | @CC="$(CXX)" CFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" \ | ||
68 | $(WVSTREAMS)/gen-cc CXX cc | ||
69 | |||
70 | +#All files must depend on the above two rules. This is a godawful hack. | ||
71 | +$(shell find -type f '(' -name '*.c' -o -name '*.cc' ')' ): CC CXX | ||
72 | + | ||
73 | wvlink=$(LINK_MSG)$(WVLINK_CC) $(LDFLAGS) $($1-LDFLAGS) -o $1 $(filter %.o %.a %.so, $2) $($1-LIBS) $(XX_LIBS) $(LDLIBS) $(PRELIBS) $(LIBS) | ||
74 | -- | ||
75 | 2.14.1 | ||
76 | |||
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/0002-wvrules.mk-Use-_DEFAULT_SOURCE.patch b/meta-oe/recipes-connectivity/wvdial/wvstreams/0002-wvrules.mk-Use-_DEFAULT_SOURCE.patch new file mode 100644 index 000000000..59f70e380 --- /dev/null +++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/0002-wvrules.mk-Use-_DEFAULT_SOURCE.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 4afff42714a15cb796d3589d87c6fac4558b2c95 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 24 Aug 2017 22:33:32 -0700 | ||
4 | Subject: [PATCH 2/2] wvrules.mk: Use _DEFAULT_SOURCE | ||
5 | |||
6 | Fixes warnings with newer glibc | ||
7 | warning: "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | wvrules.mk | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/wvrules.mk b/wvrules.mk | ||
15 | index 877f700..124bffd 100644 | ||
16 | --- a/wvrules.mk | ||
17 | +++ b/wvrules.mk | ||
18 | @@ -83,7 +83,7 @@ runtests: | ||
19 | |||
20 | INCFLAGS=$(addprefix -I,$(WVSTREAMS_INC) $(XPATH)) | ||
21 | CPPFLAGS+=$(INCFLAGS) \ | ||
22 | - -D_BSD_SOURCE -D_GNU_SOURCE $(OSDEFINE) \ | ||
23 | + -D_DEFAULT_SOURCE $(OSDEFINE) \ | ||
24 | -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 \ | ||
25 | -DUNSTABLE | ||
26 | |||
27 | -- | ||
28 | 2.14.1 | ||
29 | |||
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb index 0ac175251..e3d5e7d20 100644 --- a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb +++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb | |||
@@ -19,6 +19,8 @@ SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.gz \ | |||
19 | file://0003-wvtask-Check-for-HAVE_LIBC_STACK_END-only-on-glibc-s.patch \ | 19 | file://0003-wvtask-Check-for-HAVE_LIBC_STACK_END-only-on-glibc-s.patch \ |
20 | file://0004-wvcrash-Replace-use-of-basename-API.patch \ | 20 | file://0004-wvcrash-Replace-use-of-basename-API.patch \ |
21 | file://0005-check-for-libexecinfo-during-configure.patch \ | 21 | file://0005-check-for-libexecinfo-during-configure.patch \ |
22 | file://0001-build-fix-parallel-make.patch \ | ||
23 | file://0002-wvrules.mk-Use-_DEFAULT_SOURCE.patch \ | ||
22 | " | 24 | " |
23 | 25 | ||
24 | SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c" | 26 | SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c" |
@@ -26,8 +28,6 @@ SRC_URI[sha256sum] = "8403f5fbf83aa9ac0c6ce15d97fd85607488152aa84e007b7d0621b8eb | |||
26 | 28 | ||
27 | inherit autotools-brokensep pkgconfig | 29 | inherit autotools-brokensep pkgconfig |
28 | 30 | ||
29 | PARALLEL_MAKE = "" | ||
30 | |||
31 | TARGET_CFLAGS_append = " -fno-tree-dce -fno-optimize-sibling-calls" | 31 | TARGET_CFLAGS_append = " -fno-tree-dce -fno-optimize-sibling-calls" |
32 | 32 | ||
33 | LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib" | 33 | LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib" |