diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2019-04-24 19:00:38 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-04-29 10:13:56 -0700 |
commit | 09a124785f67003f0ea9ef46cf80dee9fa7d7696 (patch) | |
tree | e8573fa7eb0228326aaa4d9f358c9e026f931d09 /meta-oe | |
parent | 67b5700da78c60326f2c02dfe9c99eef3096810a (diff) | |
download | meta-openembedded-09a124785f67003f0ea9ef46cf80dee9fa7d7696.tar.gz |
ne10: set NE10_TARGET_ARCH with an override instead of anonymous python
* set COMPATIBLE_MACHINE to (^$) to prevent building it for any other
architectures than armv7a and aarch64
* with new arm tune files it's easy to have armv7a in OVERRIDES even
when there isn't armv7a in TUNE_FEATURES:
meta/conf/machine/include/tune-cortexa9.inc:7
"${@bb.utils.contains('TUNE_FEATURES', 'cortexa9', 'armv7a:', '',d)}"
in cases like this COMPATIBLE_MACHINE was satisfied thanks to the
armv7a OVERRIDE, but then the anonymous python was failing with:
ne10 was skipped: Incompatible with archs other than armv7 and aarch64
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/ne10/ne10_1.2.1.bb | 19 |
1 files changed, 6 insertions, 13 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb index 3afdff778..4e8986de1 100644 --- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb +++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb | |||
@@ -15,22 +15,15 @@ PV .= "gitr+${SRCPV}" | |||
15 | 15 | ||
16 | inherit cmake | 16 | inherit cmake |
17 | 17 | ||
18 | NE10_TARGET_ARCH = "" | 18 | # Incompatible with archs other than armv7 and aarch64 |
19 | EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"' | 19 | COMPATIBLE_MACHINE = "(^$)" |
20 | |||
21 | COMPATIBLE_MACHINE_aarch64 = "(.*)" | 20 | COMPATIBLE_MACHINE_aarch64 = "(.*)" |
22 | COMPATIBLE_MACHINE_armv7a = "(.*)" | 21 | COMPATIBLE_MACHINE_armv7a = "(.*)" |
22 | NE10_TARGET_ARCH = "" | ||
23 | NE10_TARGET_ARCH_aarch64 = "aarch64" | ||
24 | NE10_TARGET_ARCH_armv7a = "armv7" | ||
23 | 25 | ||
24 | python () { | 26 | EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"' |
25 | if any(t.startswith('armv7') for t in d.getVar('TUNE_FEATURES').split()): | ||
26 | d.setVar('NE10_TARGET_ARCH', 'armv7') | ||
27 | bb.debug(2, 'Building Ne10 for armv7') | ||
28 | elif any(t.startswith('aarch64') for t in d.getVar('TUNE_FEATURES').split()): | ||
29 | d.setVar('NE10_TARGET_ARCH', 'aarch64') | ||
30 | bb.debug(2, 'Building Ne10 for aarch64') | ||
31 | else: | ||
32 | raise bb.parse.SkipRecipe("Incompatible with archs other than armv7 and aarch64") | ||
33 | } | ||
34 | 27 | ||
35 | do_install() { | 28 | do_install() { |
36 | install -d ${D}${libdir} | 29 | install -d ${D}${libdir} |