diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-02 16:46:30 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 09:51:55 +0100 |
commit | 0996da43b20d16a4375746a932bac1a5834aca4b (patch) | |
tree | 2e5daafca8df897bcd1e79c75d2aa1342aa1f3b7 /meta-oe | |
parent | 6d0fe0de240207e3a72a0d2cb3f755f8949f9b35 (diff) | |
download | meta-openembedded-0996da43b20d16a4375746a932bac1a5834aca4b.tar.gz |
lemon 3.5.4: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/lemon/files/lemon.1 | 63 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/lemon/lemon.inc | 26 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/lemon/lemon_3.5.4.bb | 7 |
3 files changed, 96 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/lemon/files/lemon.1 b/meta-oe/recipes-devtools/lemon/files/lemon.1 new file mode 100644 index 000000000..914ee0701 --- /dev/null +++ b/meta-oe/recipes-devtools/lemon/files/lemon.1 | |||
@@ -0,0 +1,63 @@ | |||
1 | .Dd 2002-10-04 | ||
2 | .Dt LEMON 1 | ||
3 | .Os "Debian GNU/Linux" | ||
4 | .\" Manual page created by Guus Sliepen <guus@debian.org> | ||
5 | .Sh NAME | ||
6 | .Nm lemon | ||
7 | .Nd The Lemon Parser Generator | ||
8 | .Sh SYNOPSIS | ||
9 | .Nm | ||
10 | .Op Fl bcgmqsx | ||
11 | .Ar input | ||
12 | .Sh DESCRIPTION | ||
13 | .Nm | ||
14 | is an LALR(1) parser generator for C or C++. | ||
15 | It does the same job as bison and yacc. | ||
16 | But | ||
17 | .Nm | ||
18 | is not another bison or yacc clone. | ||
19 | It uses a different grammar syntax which is designed to reduce the number of coding errors. | ||
20 | .Nm | ||
21 | also uses a more sophisticated parsing engine that is faster than yacc and bison | ||
22 | and which is both reentrant and thread-safe. | ||
23 | Furthermore, | ||
24 | .Nm | ||
25 | implements features that can be used to eliminate resource leaks, | ||
26 | making is suitable for use in long-running programs such as graphical user interfaces or embedded controllers. | ||
27 | .Pp | ||
28 | .Nm | ||
29 | will read the grammer from | ||
30 | .Ar input | ||
31 | and write out a parser for that grammar in the C language. | ||
32 | .Sh OPTIONS | ||
33 | .Bl -tag -width indent | ||
34 | .It Fl b | ||
35 | Print only the basis in report. | ||
36 | .It Fl c | ||
37 | Don't compress the action table. | ||
38 | .It Fl g | ||
39 | Print grammar without actions. | ||
40 | .It Fl m | ||
41 | Output a makeheaders compatible file. | ||
42 | .It Fl q | ||
43 | (Quiet) Don't print the report file. | ||
44 | .It Fl s | ||
45 | Print parser stats to standard output. | ||
46 | .It Fl x | ||
47 | Print the version number. | ||
48 | .El | ||
49 | .Sh FILES | ||
50 | .Bl -tag -width indent | ||
51 | .It Pa /usr/share/lemon/lempar.c | ||
52 | Driver template for the | ||
53 | .Nm | ||
54 | parser generator. | ||
55 | .El | ||
56 | .Sh AUTHOR | ||
57 | .Nm | ||
58 | has been written by | ||
59 | .An D. Richard Hipp Aq drh@hwaci.com . | ||
60 | .Pp | ||
61 | This manual page was written by | ||
62 | .An Guus Sliepen Aq guus@debian.org | ||
63 | for the Debian GNU/Linux system. | ||
diff --git a/meta-oe/recipes-devtools/lemon/lemon.inc b/meta-oe/recipes-devtools/lemon/lemon.inc new file mode 100644 index 000000000..48d93ee83 --- /dev/null +++ b/meta-oe/recipes-devtools/lemon/lemon.inc | |||
@@ -0,0 +1,26 @@ | |||
1 | DESCRIPTION = "The Lemon Parser Generator" | ||
2 | HOMEPAGE = "http://www.hwaci.com/sw/lemon/" | ||
3 | LICENSE = "PD" | ||
4 | SECTION = "devel" | ||
5 | |||
6 | SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \ | ||
7 | file://lemon.1" | ||
8 | |||
9 | S = "${WORKDIR}/sqlite-${PV}/tool" | ||
10 | |||
11 | do_compile() { | ||
12 | ${CC} ${CFLAGS} lemon.c -c -o lemon.o | ||
13 | ${CCLD} ${LDFLAGS} lemon.o -o lemon | ||
14 | } | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${bindir} | ||
18 | install -m 0755 lemon ${D}${bindir} | ||
19 | install -m 0644 lempar.c ${D}${bindir} | ||
20 | install -d ${D}${mandir}/man1 | ||
21 | install -m 0644 ${WORKDIR}/lemon.1 ${D}${mandir}/man1/ | ||
22 | } | ||
23 | |||
24 | BBCLASSEXTEND = "native" | ||
25 | |||
26 | NATIVE_INSTALL_WORKS = "1" | ||
diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.5.4.bb b/meta-oe/recipes-devtools/lemon/lemon_3.5.4.bb new file mode 100644 index 000000000..7df47d41f --- /dev/null +++ b/meta-oe/recipes-devtools/lemon/lemon_3.5.4.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require lemon.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee" | ||
4 | |||
5 | SRC_URI[md5sum] = "f17da840eed792e896c3408d0ce97718" | ||
6 | SRC_URI[sha256sum] = "47daba209bd3bcffa1c5fcd5fdfc4f524eae619b4fa855aeeb1bbbc8bd2bb04f" | ||
7 | |||