summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorleimaohui <leimaohui@fujitsu.com>2022-01-08 01:24:56 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-11 17:51:55 -0800
commit00034b34f599bd98578da06ab11a93f1e37c48cd (patch)
tree80d8165a50ab92d1cf9d0aa111d438e090707f9f /meta-oe
parent866715fa40b0c5f867add526dbe1d27ec2c1b66e (diff)
downloadmeta-openembedded-00034b34f599bd98578da06ab11a93f1e37c48cd.tar.gz
dool: Added a new OSS that forked from dstat project.
Please referece to https://github.com/dstat-real/dstat. Signed-off-by: Lei Maohui <leimaohui@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/dool/dool/0001-Fix-build-error-as-following.patch39
-rw-r--r--meta-oe/recipes-support/dool/dool_1.0.0.bb24
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/dool/dool/0001-Fix-build-error-as-following.patch b/meta-oe/recipes-support/dool/dool/0001-Fix-build-error-as-following.patch
new file mode 100644
index 000000000..2324af499
--- /dev/null
+++ b/meta-oe/recipes-support/dool/dool/0001-Fix-build-error-as-following.patch
@@ -0,0 +1,39 @@
1From e81feec1ebbc676220cd8759d83f46335602d079 Mon Sep 17 00:00:00 2001
2From: Lei Maohui <leimaohui@fujitsu.com>
3Date: Fri, 7 Jan 2022 14:37:36 +0900
4Subject: [PATCH] Fix build error as following:
5
6*** No rule to make target 'dstat.1', needed by 'docs'. Stop.
7
8Upstream-Status: Pending
9
10Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
11---
12 docs/Makefile | 8 ++++----
13 1 file changed, 4 insertions(+), 4 deletions(-)
14
15diff --git a/docs/Makefile b/docs/Makefile
16index c031e82..1a85e61 100644
17--- a/docs/Makefile
18+++ b/docs/Makefile
19@@ -11,13 +11,13 @@ all:
20
21 dist: docs
22
23-docs: dstat.1 $(htmltargets)
24+docs: dool.1 $(htmltargets)
25
26-install: dstat.1
27- install -Dp -m0644 dstat.1 $(DESTDIR)$(mandir)/man1/dstat.1
28+install: dool.1
29+ install -Dp -m0644 dool.1 $(DESTDIR)$(mandir)/man1/dool.1
30
31 clean:
32- rm -f dstat.1 *.html *.xml
33+ rm -f dool.1 *.html *.xml
34
35 %.1.html: %.1.adoc
36 asciidoc -d manpage $<
37--
382.25.1
39
diff --git a/meta-oe/recipes-support/dool/dool_1.0.0.bb b/meta-oe/recipes-support/dool/dool_1.0.0.bb
new file mode 100644
index 000000000..0cbc32ff3
--- /dev/null
+++ b/meta-oe/recipes-support/dool/dool_1.0.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "versatile resource statics tool"
2DESCRIPTION = "Dstat is a versatile replacement for vmstat, iostat, netstat and ifstat. \
3Dstat overcomes some of their limitations and adds some extra features, more counters \
4and flexibility. Dstat is handy for monitoring systems during performance tuning tests, \
5benchmarks or troubleshooting."
6HOMEPAGE = "http://dag.wiee.rs/home-made/dstat"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9
10DEPENDS += "asciidoc-native xmlto-native"
11
12SRC_URI = "git://github.com/scottchiefbaker/dool.git;branch=master;protocol=https \
13 file://0001-Fix-build-error-as-following.patch \
14 "
15
16SRCREV = "34a3244b46aa70a31f871a7ca8ffa8d3a7b950d2"
17
18S = "${WORKDIR}/git"
19
20do_install() {
21 oe_runmake 'DESTDIR=${D}' install
22}
23
24RDEPENDS:${PN} += "python3-core python3-misc python3-resource python3-shell python3-six python3-unixadmin"