summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJohan Hovold <johan.hovold@lundinova.se>2012-04-18 11:27:01 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-18 19:19:26 +0200
commitd96d51e1eb4c086db781eb89b17d3b4ddbac7d13 (patch)
treeb4176ac149b400626c5efa4aaf60f42aaf9a2c7f /meta-oe
parent41f8ee83ffa3b6e4dae2148894c25df112ae028c (diff)
downloadmeta-openembedded-d96d51e1eb4c086db781eb89b17d3b4ddbac7d13.tar.gz
gpsd: fix gpsd init script
Replace return with exit where appropriate. Current init script uses return outside of functions resulting in warnings such as the following when using bash as interpreter: /etc/init.d/gpsd: line 98: return: can only `return' from a function or sourced script Signed-off-by: Johan Hovold <johan.hovold@lundinova.se> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rwxr-xr-xmeta-oe/recipes-navigation/gpsd/gpsd-2.96/gpsd10
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_2.96.bb2
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-2.96/gpsd b/meta-oe/recipes-navigation/gpsd/gpsd-2.96/gpsd
index 3687d2400..ba73dafb2 100755
--- a/meta-oe/recipes-navigation/gpsd/gpsd-2.96/gpsd
+++ b/meta-oe/recipes-navigation/gpsd/gpsd-2.96/gpsd
@@ -95,19 +95,19 @@ case "$1" in
95 start) 95 start)
96 echo "Starting $DESC" "$NAME" 96 echo "Starting $DESC" "$NAME"
97 do_start 97 do_start
98 return $? 98 exit $?
99 ;; 99 ;;
100 stop) 100 stop)
101 echo "Stopping $DESC" "$NAME" 101 echo "Stopping $DESC" "$NAME"
102 do_stop 102 do_stop
103 return $? 103 exit $?
104 ;; 104 ;;
105 status) 105 status)
106 ;; 106 ;;
107 reload|force-reload) 107 reload|force-reload)
108 echo "Reloading $DESC" "$NAME" 108 echo "Reloading $DESC" "$NAME"
109 do_reload 109 do_reload
110 return $? 110 exit $?
111 ;; 111 ;;
112 restart) 112 restart)
113 # 113 #
@@ -119,11 +119,11 @@ case "$1" in
119 case "$?" in 119 case "$?" in
120 0|1) 120 0|1)
121 do_start 121 do_start
122 return $? 122 exit $?
123 ;; 123 ;;
124 *) 124 *)
125 # Failed to stop 125 # Failed to stop
126 return 1 126 exit 1
127 ;; 127 ;;
128 esac 128 esac
129 ;; 129 ;;
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_2.96.bb b/meta-oe/recipes-navigation/gpsd/gpsd_2.96.bb
index 927107a84..7e2a96cb1 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_2.96.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_2.96.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
5DEPENDS = "dbus-glib ncurses python libusb1" 5DEPENDS = "dbus-glib ncurses python libusb1"
6PROVIDES = "virtual/gpsd" 6PROVIDES = "virtual/gpsd"
7 7
8PR = "r2" 8PR = "r3"
9 9
10EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \ 10EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
11 --x-libraries=${STAGING_LIBDIR} \ 11 --x-libraries=${STAGING_LIBDIR} \