diff options
author | Ross Burton <ross.burton@intel.com> | 2013-11-18 15:40:20 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-11-18 23:20:03 +0100 |
commit | c13c5f40160d289bb62538a16900fed30621cb22 (patch) | |
tree | 5b808b50c7e0840fe25b7f729d3ba52d8a803fb9 /meta-oe | |
parent | 63dda30632b7fcceead0223129c5e3960b1d8667 (diff) | |
download | meta-openembedded-c13c5f40160d289bb62538a16900fed30621cb22.tar.gz |
python-numpy: add native support
The compile hack to use a correct config.h isn't needed for native builds, so
mark it as target-specific.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb index e6d328f94..04cb2f183 100644 --- a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb +++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb | |||
@@ -40,7 +40,7 @@ inherit distutils | |||
40 | 40 | ||
41 | # Make the build fail and replace *config.h with proper one | 41 | # Make the build fail and replace *config.h with proper one |
42 | # This is a ugly, ugly hack - Koen | 42 | # This is a ugly, ugly hack - Koen |
43 | do_compile_prepend() { | 43 | do_compile_prepend_class-target() { |
44 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | 44 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ |
45 | ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ | 45 | ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ |
46 | true | 46 | true |
@@ -72,3 +72,7 @@ RDEPENDS_${PN} = "python-unittest \ | |||
72 | python-subprocess \ | 72 | python-subprocess \ |
73 | python-compression \ | 73 | python-compression \ |
74 | " | 74 | " |
75 | |||
76 | RDEPENDS_${PN}_class-native = "" | ||
77 | |||
78 | BBCLASSEXTEND = "native nativesdk" | ||