summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-12-02 03:14:27 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-09 11:34:42 +0100
commite2d07c8646d25a473dd66ab2f76954f1103470f7 (patch)
treef2e522e8669576113f6c398da3676e690d97870d /meta-oe
parent1bc5ab1737371a023256b1771819e0ec6aee1e31 (diff)
downloadmeta-openembedded-e2d07c8646d25a473dd66ab2f76954f1103470f7.tar.gz
ltrace: add PACKAGECONFIG for selinux
Add PACKAGECONFIG for 'selinux', otherwise there would be warnings like below: WARN: ltrace: ltrace rdepends on libselinux, but it isn't a build dependency? Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/ltrace/ltrace/configure-allow-to-disable-selinux-support.patch36
-rw-r--r--meta-oe/recipes-devtools/ltrace/ltrace_git.bb3
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace/configure-allow-to-disable-selinux-support.patch b/meta-oe/recipes-devtools/ltrace/ltrace/configure-allow-to-disable-selinux-support.patch
new file mode 100644
index 000000000..4f89d8f2e
--- /dev/null
+++ b/meta-oe/recipes-devtools/ltrace/ltrace/configure-allow-to-disable-selinux-support.patch
@@ -0,0 +1,36 @@
1From 887a403e38f590ebf1d04ce600d94cb7a351744c Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Mon, 1 Dec 2014 00:57:42 -0500
4Subject: [PATCH] ltrace: allow to enable/disable selinux support
5
6Upstream-Status: Pending
7
8Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
9---
10 configure.ac | 10 ++++++++--
11 1 file changed, 8 insertions(+), 2 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index 6fe5e3b..189885a 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -125,8 +125,14 @@ AC_SUBST(libstdcxx_LIBS)
18
19
20 dnl Check security_get_boolean_active availability.
21-AC_CHECK_HEADERS(selinux/selinux.h)
22-AC_CHECK_LIB(selinux, security_get_boolean_active)
23+AC_ARG_ENABLE([selinux],
24+ AS_HELP_STRING([--enable-selinux],[enable SELinux support [default=auto]]),
25+ [], [enable_selinux=auto])
26+
27+if test x$enable_selinux != xno; then
28+ AC_CHECK_HEADERS(selinux/selinux.h)
29+ AC_CHECK_LIB(selinux, security_get_boolean_active)
30+fi
31
32 dnl Whether (and which) elfutils libdw.so to use for unwinding.
33 AC_ARG_WITH(elfutils,
34--
351.7.9.5
36
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
index 507747ae1..69848483d 100644
--- a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
+++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
@@ -17,12 +17,15 @@ DEPENDS = "elfutils"
17RDEPENDS_${PN} = "elfutils" 17RDEPENDS_${PN} = "elfutils"
18SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git \ 18SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git \
19 file://ltrace-0.7.2-unused-typedef.patch \ 19 file://ltrace-0.7.2-unused-typedef.patch \
20 file://configure-allow-to-disable-selinux-support.patch \
20 " 21 "
21S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
22 23
23inherit autotools 24inherit autotools
24 25
26PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
25PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind" 27PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
28PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
26 29
27do_configure_prepend () { 30do_configure_prepend () {
28 ( cd ${S}; ./autogen.sh ) 31 ( cd ${S}; ./autogen.sh )