summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-08-17 16:22:17 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-08-18 10:52:05 +0200
commitd9565d90d98a3a25533209393cb1f6ae8c89c9d1 (patch)
treef12e9c593947451bf0d60e912f622c93c924b166 /meta-oe
parent0c6d03335c117d24096598a3415ba22f74ec4f6e (diff)
downloadmeta-openembedded-d9565d90d98a3a25533209393cb1f6ae8c89c9d1.tar.gz
bluez-hcidump: remove older 2.0
* there is 2.1 now in oe-core Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch42
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb20
2 files changed, 0 insertions, 62 deletions
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch b/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch
deleted file mode 100644
index 994326514..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1Upstream-Status: Accepted, already in git, expected to be included in next version after 2.0
2From 95ea4ff5c9c7dbda2f3faaef4e5cd46d542a48c8 Mon Sep 17 00:00:00 2001
3From: Anderson Lizardo <anderson.lizardo@openbossa.org>
4Date: Fri, 18 Mar 2011 15:10:19 -0400
5Subject: [PATCH] Fix compilation against latest BlueZ
6
7BlueZ now has ntoh64()/hton64() functions in bluetooth.h, therefore the
8hcidump local copy is not necessary.
9---
10 src/hcidump.c | 16 ----------------
11 1 files changed, 0 insertions(+), 16 deletions(-)
12
13diff --git a/src/hcidump.c b/src/hcidump.c
14index af086c7..2023130 100644
15--- a/src/hcidump.c
16+++ b/src/hcidump.c
17@@ -50,22 +50,6 @@
18 #include "parser/parser.h"
19 #include "parser/sdp.h"
20
21-#if __BYTE_ORDER == __LITTLE_ENDIAN
22-static inline uint64_t ntoh64(uint64_t n)
23-{
24- uint64_t h;
25- uint64_t tmp = ntohl(n & 0x00000000ffffffff);
26- h = ntohl(n >> 32);
27- h |= tmp << 32;
28- return h;
29-}
30-#elif __BYTE_ORDER == __BIG_ENDIAN
31-#define ntoh64(x) (x)
32-#else
33-#error "Unknown byte order"
34-#endif
35-#define hton64(x) ntoh64(x)
36-
37 #define SNAP_LEN HCI_MAX_FRAME_SIZE
38 #define DEFAULT_PORT "10839";
39
40--
411.7.4.4
42
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb b/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb
deleted file mode 100644
index f26904515..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "Linux Bluetooth Stack HCI Debugger Tool."
2DESCRIPTION = "The hcidump tool reads raw HCI data coming from and going to a Bluetooth device \
3and displays the commands, events and data in a human-readable form."
4
5SECTION = "console"
6DEPENDS = "bluez4"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
9 file://src/hcidump.c;beginline=1;endline=23;md5=3bee3a162dff43a5be7470710b99fbcf"
10PR = "r0"
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/bluetooth/${P}.tar.gz \
13 file://remove.ntoh64.definition.patch"
14
15SRC_URI[md5sum] = "5c2e3ef0a68b2845047867ba51ff8ac9"
16SRC_URI[sha256sum] = "b3b64fd0b18301df07d3aaf34c037c1e4808b4aaf702294822d62b5424f617fd"
17
18EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR}"
19
20inherit autotools