diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-08-17 16:22:17 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-08-18 10:52:05 +0200 |
commit | d9565d90d98a3a25533209393cb1f6ae8c89c9d1 (patch) | |
tree | f12e9c593947451bf0d60e912f622c93c924b166 /meta-oe | |
parent | 0c6d03335c117d24096598a3415ba22f74ec4f6e (diff) | |
download | meta-openembedded-d9565d90d98a3a25533209393cb1f6ae8c89c9d1.tar.gz |
bluez-hcidump: remove older 2.0
* there is 2.1 now in oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb | 20 |
2 files changed, 0 insertions, 62 deletions
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch b/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch deleted file mode 100644 index 994326514..000000000 --- a/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | Upstream-Status: Accepted, already in git, expected to be included in next version after 2.0 | ||
2 | From 95ea4ff5c9c7dbda2f3faaef4e5cd46d542a48c8 Mon Sep 17 00:00:00 2001 | ||
3 | From: Anderson Lizardo <anderson.lizardo@openbossa.org> | ||
4 | Date: Fri, 18 Mar 2011 15:10:19 -0400 | ||
5 | Subject: [PATCH] Fix compilation against latest BlueZ | ||
6 | |||
7 | BlueZ now has ntoh64()/hton64() functions in bluetooth.h, therefore the | ||
8 | hcidump local copy is not necessary. | ||
9 | --- | ||
10 | src/hcidump.c | 16 ---------------- | ||
11 | 1 files changed, 0 insertions(+), 16 deletions(-) | ||
12 | |||
13 | diff --git a/src/hcidump.c b/src/hcidump.c | ||
14 | index af086c7..2023130 100644 | ||
15 | --- a/src/hcidump.c | ||
16 | +++ b/src/hcidump.c | ||
17 | @@ -50,22 +50,6 @@ | ||
18 | #include "parser/parser.h" | ||
19 | #include "parser/sdp.h" | ||
20 | |||
21 | -#if __BYTE_ORDER == __LITTLE_ENDIAN | ||
22 | -static inline uint64_t ntoh64(uint64_t n) | ||
23 | -{ | ||
24 | - uint64_t h; | ||
25 | - uint64_t tmp = ntohl(n & 0x00000000ffffffff); | ||
26 | - h = ntohl(n >> 32); | ||
27 | - h |= tmp << 32; | ||
28 | - return h; | ||
29 | -} | ||
30 | -#elif __BYTE_ORDER == __BIG_ENDIAN | ||
31 | -#define ntoh64(x) (x) | ||
32 | -#else | ||
33 | -#error "Unknown byte order" | ||
34 | -#endif | ||
35 | -#define hton64(x) ntoh64(x) | ||
36 | - | ||
37 | #define SNAP_LEN HCI_MAX_FRAME_SIZE | ||
38 | #define DEFAULT_PORT "10839"; | ||
39 | |||
40 | -- | ||
41 | 1.7.4.4 | ||
42 | |||
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb b/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb deleted file mode 100644 index f26904515..000000000 --- a/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | SUMMARY = "Linux Bluetooth Stack HCI Debugger Tool." | ||
2 | DESCRIPTION = "The hcidump tool reads raw HCI data coming from and going to a Bluetooth device \ | ||
3 | and displays the commands, events and data in a human-readable form." | ||
4 | |||
5 | SECTION = "console" | ||
6 | DEPENDS = "bluez4" | ||
7 | LICENSE = "GPLv2+" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \ | ||
9 | file://src/hcidump.c;beginline=1;endline=23;md5=3bee3a162dff43a5be7470710b99fbcf" | ||
10 | PR = "r0" | ||
11 | |||
12 | SRC_URI = "${KERNELORG_MIRROR}/linux/bluetooth/${P}.tar.gz \ | ||
13 | file://remove.ntoh64.definition.patch" | ||
14 | |||
15 | SRC_URI[md5sum] = "5c2e3ef0a68b2845047867ba51ff8ac9" | ||
16 | SRC_URI[sha256sum] = "b3b64fd0b18301df07d3aaf34c037c1e4808b4aaf702294822d62b5424f617fd" | ||
17 | |||
18 | EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR}" | ||
19 | |||
20 | inherit autotools | ||