summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-12-17 11:32:13 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:57 +0100
commita30ee70d8dbbec811a580f65af1adbaf1f1276af (patch)
tree5fcb3a6cfeb5ef9d462b6f93765a877af262c790 /meta-oe
parent9fb32353e45f357e15c7326b78cb90ba3b7e3f96 (diff)
downloadmeta-openembedded-a30ee70d8dbbec811a580f65af1adbaf1f1276af.tar.gz
engine-pkcs11: Add new recipe
Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be loaded using code, config file or command line and will pass any function call by openssl to a PKCS cards and software for using smart cards in PKCS Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.1.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.1.8.bb b/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.1.8.bb
new file mode 100644
index 000000000..d665242bb
--- /dev/null
+++ b/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.1.8.bb
@@ -0,0 +1,29 @@
1SUMMARY = "A PKCS"
2DESCRIPTION = "\
3Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be \
4loaded using code, config file or command line and will pass any function \
5call by openssl to a PKCS cards and software for using smart cards in PKCS"
6HOMEPAGE = "https://github.com/OpenSC/engine_pkcs11"
7SECTION = "Development/Libraries"
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://doc/README;md5=d2ab6bf8854463fa6bf98f5bb6dfc47c"
10DEPENDS = "openssl libp11"
11
12SRC_URI = "git://github.com/OpenSC/engine_pkcs11.git"
13SRCREV = "bb775c32dba8cc4b4381a53da7ab5d7b22b7921d"
14
15S = "${WORKDIR}/git"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF = "\
20 --disable-static \
21 --libdir ${libdir}/openssl \
22"
23
24do_install_append () {
25 rm -f ${D}${libdir}/openssl/engines/engine_pkcs11.la
26}
27
28FILES_${PN} += "/usr/lib/openssl/engines/engine_pkcs11.so*"
29FILES_${PN}-dbg += "/usr/lib/openssl/engines/.debug/*"