summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-09-26 09:05:55 -0700
committerKhem Raj <raj.khem@gmail.com>2011-09-27 17:40:01 -0700
commit2ec214472d5b6734973314e1aca28fc101e8835c (patch)
tree03ef900a6569c7b6ef0a1357e50c601094e6fbd1 /meta-oe
parent92edaa1967d6478683f06c4fcc438a94228a6c9e (diff)
downloadmeta-openembedded-2ec214472d5b6734973314e1aca28fc101e8835c.tar.gz
fuse: Upgrade recipe to version 2.8.6
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch12
-rw-r--r--meta-oe/recipes-support/fuse/fuse_2.8.6.bb36
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch b/meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch
new file mode 100644
index 000000000..c673a4c63
--- /dev/null
+++ b/meta-oe/recipes-support/fuse/fuse-2.8.6/define_GNU_SOURCE.patch
@@ -0,0 +1,12 @@
1Index: fuse-2.8.6/util/fusermount.c
2===================================================================
3--- fuse-2.8.6.orig/util/fusermount.c 2011-09-13 00:23:14.000000000 -0700
4+++ fuse-2.8.6/util/fusermount.c 2011-09-25 00:23:53.051019038 -0700
5@@ -7,6 +7,7 @@
6 */
7 /* This program does the mounting and unmounting of FUSE filesystems */
8
9+#define _GNU_SOURCE
10 #include <config.h>
11
12 #include "mount_util.h"
diff --git a/meta-oe/recipes-support/fuse/fuse_2.8.6.bb b/meta-oe/recipes-support/fuse/fuse_2.8.6.bb
new file mode 100644
index 000000000..ec81a9833
--- /dev/null
+++ b/meta-oe/recipes-support/fuse/fuse_2.8.6.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
2HOMEPAGE = "http://fuse.sf.net"
3SECTION = "libs"
4LICENSE = "GPLv2&LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
6 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
7
8PR = "r0"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz \
11 file://define_GNU_SOURCE.patch \
12 "
13
14SRC_URI[md5sum] = "eaa32c8cef56a981656a786f258a002a"
15SRC_URI[sha256sum] = "1ec1913e38f09b2a9ec1579e1800805b5e2c747d1dce515e316dbb665ca139d6"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF = "--disable-kernel-module"
20
21PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
22
23RRECOMMENDS_${PN} = "kernel-module-fuse""
24
25FILES_${PN} += "${libdir}/libfuse.so.*"
26FILES_${PN}-dev += "${libdir}/libfuse*.la"
27
28FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
29FILES_libulockmgr-dev += "${libdir}/libulock*.la"
30FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*"
31
32# Forbid auto-renaming to libfuse-utils
33FILES_fuse-utils = "${bindir} ${base_sbindir}"
34FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug"
35DEBIAN_NOAUTONAME_fuse-utils = "1"
36DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"