diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2017-09-05 15:38:01 -0500 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-09-12 10:55:08 -0400 |
commit | fe8db5950175f734468f3256e000843ee81cf430 (patch) | |
tree | 3f500c96cd94e916f4f5dba4fff6cf6f2e16e2ad /meta-oe | |
parent | fbaf35875867ba88f25529f45ab1739722f601c5 (diff) | |
download | meta-openembedded-fe8db5950175f734468f3256e000843ee81cf430.tar.gz |
corosync: Requires net-snmp from meta-networking
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-extended/corosync/corosync_2.4.2.bb | 80 |
2 files changed, 0 insertions, 108 deletions
diff --git a/meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch b/meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch deleted file mode 100644 index fe4b0793f..000000000 --- a/meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 85ea47fedbc96ed9180e08b0d371d9966e3a88da Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 30 Aug 2017 17:28:55 -0700 | ||
4 | Subject: [PATCH] Include fcntl.h for F_* and O_* defines | ||
5 | |||
6 | Fixes errors like | ||
7 | utils.c:95:22: error: use of undeclared identifier 'O_WRONLY' | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | qdevices/utils.c | 1 + | ||
12 | 1 file changed, 1 insertion(+) | ||
13 | |||
14 | diff --git a/qdevices/utils.c b/qdevices/utils.c | ||
15 | index 41850b8c..87090853 100644 | ||
16 | --- a/qdevices/utils.c | ||
17 | +++ b/qdevices/utils.c | ||
18 | @@ -39,6 +39,7 @@ | ||
19 | |||
20 | #include <err.h> | ||
21 | #include <errno.h> | ||
22 | +#include <fcntl.h> | ||
23 | #include <inttypes.h> | ||
24 | #include <libgen.h> | ||
25 | #include <stdio.h> | ||
26 | -- | ||
27 | 2.14.1 | ||
28 | |||
diff --git a/meta-oe/recipes-extended/corosync/corosync_2.4.2.bb b/meta-oe/recipes-extended/corosync/corosync_2.4.2.bb deleted file mode 100644 index 33e74e2ff..000000000 --- a/meta-oe/recipes-extended/corosync/corosync_2.4.2.bb +++ /dev/null | |||
@@ -1,80 +0,0 @@ | |||
1 | SUMMARY = "The Corosync Cluster Engine and Application Programming Interfaces" | ||
2 | DESCRIPTION = "This package contains the Corosync Cluster Engine Executive, several default \ | ||
3 | APIs and libraries, default configuration files, and an init script." | ||
4 | HOMEPAGE = "http://corosync.github.io/corosync/" | ||
5 | |||
6 | SECTION = "base" | ||
7 | |||
8 | inherit autotools pkgconfig systemd useradd | ||
9 | |||
10 | SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \ | ||
11 | file://0001-Include-fcntl.h-for-F_-and-O_-defines.patch \ | ||
12 | " | ||
13 | SRC_URI[md5sum] = "547fa78704da53aa35912be58d31035f" | ||
14 | SRC_URI[sha256sum] = "f26e3011309fe4bcce94b1dc20ea8c462f19483a73f3ca62f13b925d011a4ba9" | ||
15 | |||
16 | LICENSE = "BSD" | ||
17 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d" | ||
18 | |||
19 | DEPENDS = "groff-native nss libqb" | ||
20 | |||
21 | SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service \ | ||
22 | ${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \ | ||
23 | ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'corosync-qnetd.service', '', d)} \ | ||
24 | " | ||
25 | SYSTEMD_AUTO_ENABLE = "enable" | ||
26 | |||
27 | INITSCRIPT_NAME = "corosync-daemon" | ||
28 | |||
29 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ | ||
30 | dbus qdevice qnetd snmp \ | ||
31 | " | ||
32 | |||
33 | PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus" | ||
34 | PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices" | ||
35 | PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd" | ||
36 | PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma" | ||
37 | PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp" | ||
38 | PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd" | ||
39 | |||
40 | EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash" | ||
41 | EXTRA_OEMAKE = "tmpfilesdir_DATA=" | ||
42 | |||
43 | do_configure_prepend() { | ||
44 | ( cd ${S} | ||
45 | ${S}/autogen.sh ) | ||
46 | } | ||
47 | |||
48 | do_install_append() { | ||
49 | install -d ${D}${sysconfdir}/sysconfig/ | ||
50 | install -m 0644 ${S}/init/corosync.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync | ||
51 | install -m 0644 ${S}/tools/corosync-notifyd.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync-notifyd | ||
52 | |||
53 | rm -rf "${D}${localstatedir}/run" | ||
54 | |||
55 | install -d ${D}${sysconfdir}/default/volatiles | ||
56 | echo "d root root 0755 ${localstatedir}/log/cluster none" > ${D}${sysconfdir}/default/volatiles/05_corosync | ||
57 | |||
58 | if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then | ||
59 | chown -R coroqnetd:coroqnetd ${D}${sysconfdir}/${BPN}/qnetd | ||
60 | echo "d coroqnetd coroqnetd 0770 /var/run/corosync-qnetd none" >> ${D}${sysconfdir}/default/volatiles/05_corosync | ||
61 | fi | ||
62 | |||
63 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
64 | install -d ${D}${sysconfdir}/tmpfiles.d | ||
65 | echo "d ${localstatedir}/log/cluster - - - -" > ${D}${sysconfdir}/tmpfiles.d/corosync.conf | ||
66 | |||
67 | if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then | ||
68 | install -m 0644 ${S}/conf/tmpfiles.d/corosync-qnetd.conf ${D}${sysconfdir}/tmpfiles.d | ||
69 | fi | ||
70 | fi | ||
71 | } | ||
72 | |||
73 | RDEPENDS_${PN} += "bash" | ||
74 | |||
75 | FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug" | ||
76 | FILES_${PN}-doc += "${datadir}/snmp/mibs/COROSYNC-MIB.txt" | ||
77 | |||
78 | USERADD_PACKAGES = "${PN}" | ||
79 | GROUPADD_PARAM_${PN} = "--system coroqnetd" | ||
80 | USERADD_PARAM_${PN} = "--system -d / -M -s /bin/nologin -c 'User for corosync-qnetd' -g coroqnetd coroqnetd" | ||