diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2018-07-20 03:02:28 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-20 16:14:22 -0700 |
commit | be7cdd94fd089d525f9741b35ae5350023de14de (patch) | |
tree | 623d5a48418aaa08bc2e5c794cfc33fd825e31bb /meta-oe | |
parent | af574eed885a42146458e3a5e3fd83a172b69fa9 (diff) | |
download | meta-openembedded-be7cdd94fd089d525f9741b35ae5350023de14de.tar.gz |
fio: Upgrade to 3.7
* Licence-Update:
Address update in COPYING
* Add patch 0001-update-the-interpreter-paths.patch
and add python and bash to RDEPENDS_${PN} to fix
below QA issues:
ERROR: fio-3.7-r0 do_package_qa: QA Issue: /usr/bin/fiologparser.py contained in package fio requires /usr/bin/python2.7, but no providers found in RDEPENDS_fio? [file-rdeps]
ERROR: fio-3.7-r0 do_package_qa: QA Issue: /usr/bin/genfio contained in package fio requires /usr/bin/bash, but no providers found in RDEPENDS_fio? [file-rdeps]
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-benchmark/fio/files/0001-update-the-interpreter-paths.patch | 94 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/fio/fio_3.7.bb (renamed from meta-oe/recipes-benchmark/fio/fio_2.9.bb) | 11 |
2 files changed, 101 insertions, 4 deletions
diff --git a/meta-oe/recipes-benchmark/fio/files/0001-update-the-interpreter-paths.patch b/meta-oe/recipes-benchmark/fio/files/0001-update-the-interpreter-paths.patch new file mode 100644 index 000000000..276a24d89 --- /dev/null +++ b/meta-oe/recipes-benchmark/fio/files/0001-update-the-interpreter-paths.patch | |||
@@ -0,0 +1,94 @@ | |||
1 | From 55078e494bdf7da7dd9cb76077fa7ac2a66b6dd6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Fri, 20 Jul 2018 02:33:25 -0700 | ||
4 | Subject: [PATCH] update the interpreter paths | ||
5 | |||
6 | Update the interpreter path to make it more | ||
7 | compatible | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
12 | --- | ||
13 | tools/fio_jsonplus_clat2csv | 2 +- | ||
14 | tools/fiologparser.py | 2 +- | ||
15 | tools/genfio | 2 +- | ||
16 | tools/hist/fiologparser_hist.py | 2 +- | ||
17 | tools/hist/half-bins.py | 2 +- | ||
18 | tools/plot/fio2gnuplot | 2 +- | ||
19 | unit_tests/steadystate_tests.py | 2 +- | ||
20 | 7 files changed, 7 insertions(+), 7 deletions(-) | ||
21 | |||
22 | diff --git a/tools/fio_jsonplus_clat2csv b/tools/fio_jsonplus_clat2csv | ||
23 | index 78a007e5..0524b6e6 100755 | ||
24 | --- a/tools/fio_jsonplus_clat2csv | ||
25 | +++ b/tools/fio_jsonplus_clat2csv | ||
26 | @@ -1,4 +1,4 @@ | ||
27 | -#!/usr/bin/python2.7 | ||
28 | +#!/usr/bin/env python | ||
29 | # Note: this script is python2 and python3 compatible. | ||
30 | # | ||
31 | # fio_jsonplus_clat2csv | ||
32 | diff --git a/tools/fiologparser.py b/tools/fiologparser.py | ||
33 | index cc29f1c7..ea60e783 100755 | ||
34 | --- a/tools/fiologparser.py | ||
35 | +++ b/tools/fiologparser.py | ||
36 | @@ -1,4 +1,4 @@ | ||
37 | -#!/usr/bin/python2.7 | ||
38 | +#!/usr/bin/env python | ||
39 | # Note: this script is python2 and python 3 compatible. | ||
40 | # | ||
41 | # fiologparser.py | ||
42 | diff --git a/tools/genfio b/tools/genfio | ||
43 | index 286d814d..8518bbcc 100755 | ||
44 | --- a/tools/genfio | ||
45 | +++ b/tools/genfio | ||
46 | @@ -1,4 +1,4 @@ | ||
47 | -#!/usr/bin/bash | ||
48 | +#!/bin/bash | ||
49 | # | ||
50 | # Copyright (C) 2013 eNovance SAS <licensing@enovance.com> | ||
51 | # Author: Erwan Velu <erwan@enovance.com> | ||
52 | diff --git a/tools/hist/fiologparser_hist.py b/tools/hist/fiologparser_hist.py | ||
53 | index 8910d5fa..b77c2933 100755 | ||
54 | --- a/tools/hist/fiologparser_hist.py | ||
55 | +++ b/tools/hist/fiologparser_hist.py | ||
56 | @@ -1,4 +1,4 @@ | ||
57 | -#!/usr/bin/python2.7 | ||
58 | +#!/usr/bin/env python | ||
59 | """ | ||
60 | Utility for converting *_clat_hist* files generated by fio into latency statistics. | ||
61 | |||
62 | diff --git a/tools/hist/half-bins.py b/tools/hist/half-bins.py | ||
63 | index 1bba8ff7..58d53e36 100755 | ||
64 | --- a/tools/hist/half-bins.py | ||
65 | +++ b/tools/hist/half-bins.py | ||
66 | @@ -1,4 +1,4 @@ | ||
67 | -#!/usr/bin/python2.7 | ||
68 | +#!/usr/bin/env python | ||
69 | """ Cut the number bins in half in fio histogram output. Example usage: | ||
70 | |||
71 | $ half-bins.py -c 2 output_clat_hist.1.log > smaller_clat_hist.1.log | ||
72 | diff --git a/tools/plot/fio2gnuplot b/tools/plot/fio2gnuplot | ||
73 | index 4d1815cf..509141af 100755 | ||
74 | --- a/tools/plot/fio2gnuplot | ||
75 | +++ b/tools/plot/fio2gnuplot | ||
76 | @@ -1,4 +1,4 @@ | ||
77 | -#!/usr/bin/python2.7 | ||
78 | +#!/usr/bin/env python | ||
79 | # Note: this script is python2 and python3 compatible. | ||
80 | # | ||
81 | # Copyright (C) 2013 eNovance SAS <licensing@enovance.com> | ||
82 | diff --git a/unit_tests/steadystate_tests.py b/unit_tests/steadystate_tests.py | ||
83 | index 50254dcc..95e7dfde 100755 | ||
84 | --- a/unit_tests/steadystate_tests.py | ||
85 | +++ b/unit_tests/steadystate_tests.py | ||
86 | @@ -1,4 +1,4 @@ | ||
87 | -#!/usr/bin/python2.7 | ||
88 | +#!/usr/bin/env python | ||
89 | # Note: this script is python2 and python 3 compatible. | ||
90 | # | ||
91 | # steadystate_tests.py | ||
92 | -- | ||
93 | 2.17.1 | ||
94 | |||
diff --git a/meta-oe/recipes-benchmark/fio/fio_2.9.bb b/meta-oe/recipes-benchmark/fio/fio_3.7.bb index 67b513fa0..410e27b93 100644 --- a/meta-oe/recipes-benchmark/fio/fio_2.9.bb +++ b/meta-oe/recipes-benchmark/fio/fio_3.7.bb | |||
@@ -8,9 +8,10 @@ files are included. fio displays all sorts of I/O performance information." | |||
8 | HOMEPAGE = "http://freecode.com/projects/fio" | 8 | HOMEPAGE = "http://freecode.com/projects/fio" |
9 | SECTION = "console/tests" | 9 | SECTION = "console/tests" |
10 | LICENSE = "GPLv2" | 10 | LICENSE = "GPLv2" |
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
12 | 12 | ||
13 | DEPENDS = "libaio zlib" | 13 | DEPENDS = "libaio zlib" |
14 | RDEPENDS_${PN} = "python bash" | ||
14 | 15 | ||
15 | PACKAGECONFIG_NUMA = "numa" | 16 | PACKAGECONFIG_NUMA = "numa" |
16 | # ARM does not currently support NUMA | 17 | # ARM does not currently support NUMA |
@@ -19,9 +20,11 @@ PACKAGECONFIG_NUMA_arm = "" | |||
19 | PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" | 20 | PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" |
20 | PACKAGECONFIG[numa] = ",--disable-numa,numactl" | 21 | PACKAGECONFIG[numa] = ",--disable-numa,numactl" |
21 | 22 | ||
22 | # rev for v2.9 | 23 | # rev for v3.7 |
23 | SRCREV = "fe8d0f4c54f0c308c9a02a4e3c2f5084e8bf5461" | 24 | SRCREV = "c397ab3aac3d4ed1660d9cd4d820f31a4375306e" |
24 | SRC_URI = "git://git.kernel.dk/fio.git" | 25 | SRC_URI = "git://git.kernel.dk/fio.git \ |
26 | file://0001-update-the-interpreter-paths.patch \ | ||
27 | " | ||
25 | 28 | ||
26 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
27 | 30 | ||