summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2020-02-05 00:11:42 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-05 07:46:42 -0800
commit924fff467bfd120e14ab22d855923aaab41a2b12 (patch)
treef8add12881f3f0892ea7c38805d4432cf2590dc6 /meta-oe
parent68aa2eab38a0cf9d5eca58ba95ff4ffec7f1457b (diff)
downloadmeta-openembedded-924fff467bfd120e14ab22d855923aaab41a2b12.tar.gz
xmlsec1: fix for multilib
With previous change of nss/nspr in this recipe, multilib build failure at do_configure. Fix it by not using hardcoded /lib/. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/xmlsec1/xmlsec1/0001-nss-nspr-fix-for-multilib.patch52
-rw-r--r--meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb3
2 files changed, 54 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/xmlsec1/xmlsec1/0001-nss-nspr-fix-for-multilib.patch b/meta-oe/recipes-support/xmlsec1/xmlsec1/0001-nss-nspr-fix-for-multilib.patch
new file mode 100644
index 000000000..53c119765
--- /dev/null
+++ b/meta-oe/recipes-support/xmlsec1/xmlsec1/0001-nss-nspr-fix-for-multilib.patch
@@ -0,0 +1,52 @@
1From 9ed3b4e628f9254d5c86006fe63c33a1eb02aee5 Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com>
3Date: Tue, 4 Feb 2020 23:39:49 -0800
4Subject: [PATCH] nss/nspr: fix for multilib
5
6Upstream-Status: Pending
7
8Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
9---
10 configure.ac | 16 ++++++++--------
11 1 file changed, 8 insertions(+), 8 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index b46d97d..39f4318 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -920,24 +920,24 @@ fi
18 dnl Priority 1: User specifies the path to installation
19 if test "z$NSPR_FOUND" = "zno" -a "z$with_nspr" != "z" -a "z$with_nspr" != "zyes" ; then
20 AC_MSG_CHECKING(for nspr library installation in "$with_nspr" folder)
21- if test -f "$with_nspr/include/$NSPR_INCLUDE_MARKER" -a -f "$with_nspr/lib/$NSPR_LIB_MARKER" ; then
22- NSPR_INCLUDE_PATH="$with_nspr/include"
23- NSPR_LIB_PATH="$with_nspr/lib"
24+ if test -f "$with_nspr/${includedir}/$NSPR_INCLUDE_MARKER" -a -f "$with_nspr/${libdir}/$NSPR_LIB_MARKER" ; then
25+ NSPR_INCLUDE_PATH="$with_nspr/${includedir}"
26+ NSPR_LIB_PATH="$with_nspr/${libdir}"
27 NSPR_FOUND="yes"
28 AC_MSG_RESULT([yes])
29 else
30- AC_MSG_ERROR([not found: "$with_nspr/include/$NSPR_INCLUDE_MARKER" and/or "$with_nspr/lib/$NSPR_LIB_MARKER" files don't exist), typo?])
31+ AC_MSG_ERROR([not found: "$with_nspr/${includedir}/$NSPR_INCLUDE_MARKER" and/or "$with_nspr/${libdir}/$NSPR_LIB_MARKER" files don't exist), typo?])
32 fi
33 fi
34 if test "z$NSS_FOUND" = "zno" -a "z$with_nss" != "z" -a "z$with_nss" != "zyes" ; then
35 AC_MSG_CHECKING(for nss library installation in "$with_nss" folder)
36- if test -f "$with_nss/include/$NSS_INCLUDE_MARKER" -a -f "$with_nss/lib/$NSS_LIB_MARKER" ; then
37- NSS_INCLUDE_PATH="$with_nss/include"
38- NSS_LIB_PATH="$with_nss/lib"
39+ if test -f "$with_nss/${includedir}/$NSS_INCLUDE_MARKER" -a -f "$with_nss/${libdir}/$NSS_LIB_MARKER" ; then
40+ NSS_INCLUDE_PATH="$with_nss/${includedir}"
41+ NSS_LIB_PATH="$with_nss/${libdir}"
42 NSS_FOUND="yes"
43 AC_MSG_RESULT([yes])
44 else
45- AC_MSG_ERROR([not found: "$with_nss/include/$NSS_INCLUDE_MARKER" and/or "$with_nss/lib/$NSS_LIB_MARKER" files don't exist), typo?])
46+ AC_MSG_ERROR([not found: "$with_nss/${includedir}/$NSS_INCLUDE_MARKER" and/or "$with_nss/${libdir}/$NSS_LIB_MARKER" files don't exist), typo?])
47 fi
48 fi
49
50--
512.21.0
52
diff --git a/meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb b/meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb
index 3e25e8d35..8fc611a27 100644
--- a/meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb
+++ b/meta-oe/recipes-support/xmlsec1/xmlsec1_1.2.29.bb
@@ -17,6 +17,7 @@ SRC_URI = "http://www.aleksey.com/xmlsec/download/${BP}.tar.gz \
17 file://change-finding-path-of-nss.patch \ 17 file://change-finding-path-of-nss.patch \
18 file://makefile-ptest.patch \ 18 file://makefile-ptest.patch \
19 file://xmlsec1-examples-allow-build-in-separate-dir.patch \ 19 file://xmlsec1-examples-allow-build-in-separate-dir.patch \
20 file://0001-nss-nspr-fix-for-multilib.patch \
20 file://run-ptest \ 21 file://run-ptest \
21 " 22 "
22 23
@@ -31,7 +32,7 @@ inherit autotools-brokensep ptest pkgconfig
31PACKAGECONFIG ??= "gnutls libgcrypt nss openssl des" 32PACKAGECONFIG ??= "gnutls libgcrypt nss openssl des"
32PACKAGECONFIG[gnutls] = ",,gnutls" 33PACKAGECONFIG[gnutls] = ",,gnutls"
33PACKAGECONFIG[libgcrypt] = ",,libgcrypt" 34PACKAGECONFIG[libgcrypt] = ",,libgcrypt"
34PACKAGECONFIG[nss] = "--with-nss=${STAGING_LIBDIR}/.. --with-nspr=${STAGING_LIBDIR}/..,,nss nspr" 35PACKAGECONFIG[nss] = "--with-nss=${STAGING_DIR_HOST} --with-nspr=${STAGING_DIR_HOST},,nss nspr"
35PACKAGECONFIG[openssl] = ",,openssl" 36PACKAGECONFIG[openssl] = ",,openssl"
36PACKAGECONFIG[des] = ",--disable-des,," 37PACKAGECONFIG[des] = ",--disable-des,,"
37 38