summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-08-02 13:05:38 +0800
committerKhem Raj <raj.khem@gmail.com>2018-08-02 11:23:03 -0700
commit6d8982b61e991d014a3cd5e4653ecd2603faa2ce (patch)
tree696a7bba336c03839a21c10c4ddc297ac3dd63a5 /meta-oe
parentf7ed3cfdf80ecd5e35201e74650a794f90ba981b (diff)
downloadmeta-openembedded-6d8982b61e991d014a3cd5e4653ecd2603faa2ce.tar.gz
mozjs: fix coredump caused by wrong use of getenv
getenv need include header stdlib.h, or an assumed int return for getenv to char * pointer will tripping up the code Signed-off-by: Changqing Li <changqing.li@windriver.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs/0001-mozjs-fix-coredump-caused-by-getenv.patch27
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/0001-mozjs-fix-coredump-caused-by-getenv.patch b/meta-oe/recipes-extended/mozjs/mozjs/0001-mozjs-fix-coredump-caused-by-getenv.patch
new file mode 100644
index 000000000..477f73a2f
--- /dev/null
+++ b/meta-oe/recipes-extended/mozjs/mozjs/0001-mozjs-fix-coredump-caused-by-getenv.patch
@@ -0,0 +1,27 @@
1From 20b639b7364f9953fdacb058f9ba800bcbf029b4 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Thu, 2 Aug 2018 09:40:48 +0800
4Subject: [PATCH] mozjs: fix coredump caused by getenv
5
6Upstream-Status: Submitted [https://bugzilla.mozilla.org/show_bug.cgi?id=1480315]
7
8Signed-off-by: Changqing Li <changqing.li@windriver.com>
9---
10 mozglue/misc/TimeStamp.cpp | 1 +
11 1 file changed, 1 insertion(+)
12
13diff --git a/mozglue/misc/TimeStamp.cpp b/mozglue/misc/TimeStamp.cpp
14index 932b75c..7a4d71b 100644
15--- a/mozglue/misc/TimeStamp.cpp
16+++ b/mozglue/misc/TimeStamp.cpp
17@@ -11,6 +11,7 @@
18 #include "mozilla/TimeStamp.h"
19 #include <stdio.h>
20 #include <string.h>
21+#include <stdlib.h>
22
23 namespace mozilla {
24
25--
262.7.4
27
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb b/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb
index 289177182..29156e578 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_52.8.1.bb
@@ -13,6 +13,7 @@ SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/m/mozjs52/mozjs52_52.8.1.o
13 file://0005-fix-do_compile-failed-on-mips.patch \ 13 file://0005-fix-do_compile-failed-on-mips.patch \
14 file://disable-mozglue-in-stand-alone-builds.patch \ 14 file://disable-mozglue-in-stand-alone-builds.patch \
15 file://add-riscv-support.patch \ 15 file://add-riscv-support.patch \
16 file://0001-mozjs-fix-coredump-caused-by-getenv.patch \
16 " 17 "
17SRC_URI_append_libc-musl = " \ 18SRC_URI_append_libc-musl = " \
18 file://0006-support-musl.patch \ 19 file://0006-support-musl.patch \