diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-09-20 13:17:59 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-26 08:29:14 +0200 |
commit | 4703a3d41f594c4d295fae9be28031c9b637ede4 (patch) | |
tree | 16f9c01cf3c360fea6bab963d249a72355a607f9 /meta-oe | |
parent | b18ac6dbbd7be1719b07adeb4224385057039e00 (diff) | |
download | meta-openembedded-4703a3d41f594c4d295fae9be28031c9b637ede4.tar.gz |
lirc: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch | 49 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb | 1 |
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch b/meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch new file mode 100644 index 000000000..e19d27671 --- /dev/null +++ b/meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From c2be4543e4777c9e3d74b30326ba37b01917b0a9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 25 Aug 2016 03:02:37 +0000 | ||
4 | Subject: [PATCH] lircrcd: Mark local inline funtions as static | ||
5 | |||
6 | These functions are not used anywhere outside | ||
7 | this file, so they should be converted into static | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Upstream-Status: Pending | ||
12 | |||
13 | daemons/lircrcd.c | 6 +++--- | ||
14 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/daemons/lircrcd.c b/daemons/lircrcd.c | ||
17 | index 55777cd..5ddc94d 100644 | ||
18 | --- a/daemons/lircrcd.c | ||
19 | +++ b/daemons/lircrcd.c | ||
20 | @@ -153,7 +153,7 @@ char *s; | ||
21 | /* A safer write(), since sockets might not write all but only some of the | ||
22 | bytes requested */ | ||
23 | |||
24 | -inline int write_socket(int fd, char *buf, int len) | ||
25 | +static inline int write_socket(int fd, char *buf, int len) | ||
26 | { | ||
27 | int done, todo = len; | ||
28 | |||
29 | @@ -167,7 +167,7 @@ inline int write_socket(int fd, char *buf, int len) | ||
30 | return (len); | ||
31 | } | ||
32 | |||
33 | -inline int write_socket_len(int fd, char *buf) | ||
34 | +static inline int write_socket_len(int fd, char *buf) | ||
35 | { | ||
36 | int len; | ||
37 | |||
38 | @@ -177,7 +177,7 @@ inline int write_socket_len(int fd, char *buf) | ||
39 | return (1); | ||
40 | } | ||
41 | |||
42 | -inline int read_timeout(int fd, char *buf, int len, int timeout) | ||
43 | +static inline int read_timeout(int fd, char *buf, int len, int timeout) | ||
44 | { | ||
45 | fd_set fds; | ||
46 | struct timeval tv; | ||
47 | -- | ||
48 | 1.9.1 | ||
49 | |||
diff --git a/meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb b/meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb index 7162fcd85..17261921f 100644 --- a/meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb +++ b/meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb | |||
@@ -1,6 +1,7 @@ | |||
1 | require lirc.inc | 1 | require lirc.inc |
2 | 2 | ||
3 | SRC_URI += " \ | 3 | SRC_URI += " \ |
4 | file://0001-lircrcd-Mark-local-inline-funtions-as-static.patch \ | ||
4 | file://lircd.service \ | 5 | file://lircd.service \ |
5 | file://lircd.init \ | 6 | file://lircd.init \ |
6 | file://lircexec.init \ | 7 | file://lircexec.init \ |