summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorBen Brown <ben.brown@codethink.co.uk>2021-08-02 17:23:27 +0100
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:53:04 -0700
commit3f36657af2a203ef77acbff7b0c5be4098c67f25 (patch)
tree05e57a9c1107985cd652dbcf0a0a90a548caebe5 /meta-oe
parentf0b8ee3702ab8632fc4710c76a6643357ae9185f (diff)
downloadmeta-openembedded-3f36657af2a203ef77acbff7b0c5be4098c67f25.tar.gz
android-tools: fix install of adb client when TOOLS is overridden
Overriding TOOLS with 'adb' as the only entry, or with 'adb' as the final entry in the list fails to match the grep pattern. The current pattern includes trailing whitespace, likely to distinguish it from 'adbd'. However since `${TOOLS}` is then passed to grep unquoted, any trailing whitespace would be dropped by the shell. Fixed by replacing the trailing whitespace with '\>' to mark the end of the word, which continues to ensure we don't match against 'adbd'. Signed-off-by: Ben Brown <ben.brown@codethink.co.uk> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index e8992346b..fc91e13a5 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -133,7 +133,7 @@ do_install() {
133 install -m0755 ${B}/ext4_utils/simg2simg ${D}${bindir} 133 install -m0755 ${B}/ext4_utils/simg2simg ${D}${bindir}
134 fi 134 fi
135 135
136 if echo ${TOOLS} | grep -q "adb " ; then 136 if echo ${TOOLS} | grep -q "adb\>" ; then
137 install -d ${D}${bindir} 137 install -d ${D}${bindir}
138 install -m0755 ${B}/adb/adb ${D}${bindir} 138 install -m0755 ${B}/adb/adb ${D}${bindir}
139 fi 139 fi