summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-11-07 17:51:22 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 11:58:31 +0100
commitddd15ecef260e4338a0bad985ba9a8abe21169f8 (patch)
tree689cd964f833af945f8ebea28455b8e3dedd43f7 /meta-oe
parentd4af902af7be7fb7568eb8fd73f34c431b78e7a6 (diff)
downloadmeta-openembedded-ddd15ecef260e4338a0bad985ba9a8abe21169f8.tar.gz
tomoyo-tools: Add new recipes
TOMOYO Linux is a Mandatory Access Control (MAC) implementation for Linux that can be used to increase the security of a system, while also being useful purely as a system analysis tool. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb b/meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb
new file mode 100644
index 0000000000..bb2676b0a5
--- /dev/null
+++ b/meta-oe/recipes-support/tomoyo-tools/tomoyo-tools_2.5.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "TOMOYO Linux tools"
2DESCRIPTION = "TOMOYO Linux is a Mandatory Access Control (MAC) implementation \
3for Linux that can be used to increase the security of a system, while also \
4being useful purely as a system analysis tool."
5HOMEPAGE = "http://tomoyo.sourceforge.jp/"
6SECTION = "System Environment/Kernel"
7
8SRC_URI = "http://jaist.dl.sourceforge.jp/tomoyo/53357/${PN}-${PV}-20140601.tar.gz"
9SRC_URI[md5sum] = "888869b793127f00d6439a3246598b83"
10SRC_URI[sha256sum] = "118ef6ba1fbf7c0b83018c3a0d4d5485dfb9b5b7f647f37ce9f63841a3133c2a"
11
12S = "${WORKDIR}/${PN}"
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://COPYING.tomoyo;md5=751419260aa954499f7abaabaa882bbe"
16
17FILES_${PN} += "${libdir}/tomoyo"
18FILES_${PN}-dbg += "${libdir}/tomoyo/.debug"
19
20DEPENDS = "linux-libc-headers ncurses"
21CFLAGS_append += "-D_GNU_SOURCE"
22
23do_compile () {
24 oe_runmake 'CC=${CC}'
25}
26
27do_install() {
28 oe_runmake install INSTALLDIR=${D}
29}