summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-22 21:52:04 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-22 21:52:04 +0200
commitce68029c623d625705644f984a54ecbacd694595 (patch)
tree438766dae85e70e04ee8df2efddcb810e7f2d1fc /meta-oe
parent30fb538629c6a307b0e574028a11ae196e8a791f (diff)
parent3ee3add90dcc705c6afb28d5fa9e4d535a305c6e (diff)
downloadmeta-openembedded-ce68029c623d625705644f984a54ecbacd694595.tar.gz
Merge remote branch 'meta-oe-contrib/jansa/meta-oe'
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch42
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb20
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf16
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch20
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb69
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/elf.patch94
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/errno.patch13
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch97
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/string.patch11
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/syscall.patch46
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb26
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools_2.0.2.bbappend4
12 files changed, 291 insertions, 167 deletions
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch b/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch
deleted file mode 100644
index 994326514..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1Upstream-Status: Accepted, already in git, expected to be included in next version after 2.0
2From 95ea4ff5c9c7dbda2f3faaef4e5cd46d542a48c8 Mon Sep 17 00:00:00 2001
3From: Anderson Lizardo <anderson.lizardo@openbossa.org>
4Date: Fri, 18 Mar 2011 15:10:19 -0400
5Subject: [PATCH] Fix compilation against latest BlueZ
6
7BlueZ now has ntoh64()/hton64() functions in bluetooth.h, therefore the
8hcidump local copy is not necessary.
9---
10 src/hcidump.c | 16 ----------------
11 1 files changed, 0 insertions(+), 16 deletions(-)
12
13diff --git a/src/hcidump.c b/src/hcidump.c
14index af086c7..2023130 100644
15--- a/src/hcidump.c
16+++ b/src/hcidump.c
17@@ -50,22 +50,6 @@
18 #include "parser/parser.h"
19 #include "parser/sdp.h"
20
21-#if __BYTE_ORDER == __LITTLE_ENDIAN
22-static inline uint64_t ntoh64(uint64_t n)
23-{
24- uint64_t h;
25- uint64_t tmp = ntohl(n & 0x00000000ffffffff);
26- h = ntohl(n >> 32);
27- h |= tmp << 32;
28- return h;
29-}
30-#elif __BYTE_ORDER == __BIG_ENDIAN
31-#define ntoh64(x) (x)
32-#else
33-#error "Unknown byte order"
34-#endif
35-#define hton64(x) ntoh64(x)
36-
37 #define SNAP_LEN HCI_MAX_FRAME_SIZE
38 #define DEFAULT_PORT "10839";
39
40--
411.7.4.4
42
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb b/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb
deleted file mode 100644
index f26904515..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "Linux Bluetooth Stack HCI Debugger Tool."
2DESCRIPTION = "The hcidump tool reads raw HCI data coming from and going to a Bluetooth device \
3and displays the commands, events and data in a human-readable form."
4
5SECTION = "console"
6DEPENDS = "bluez4"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
9 file://src/hcidump.c;beginline=1;endline=23;md5=3bee3a162dff43a5be7470710b99fbcf"
10PR = "r0"
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/bluetooth/${P}.tar.gz \
13 file://remove.ntoh64.definition.patch"
14
15SRC_URI[md5sum] = "5c2e3ef0a68b2845047867ba51ff8ac9"
16SRC_URI[sha256sum] = "b3b64fd0b18301df07d3aaf34c037c1e4808b4aaf702294822d62b5424f617fd"
17
18EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR}"
19
20inherit autotools
diff --git a/meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf b/meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf
deleted file mode 100644
index ca5e9e4f2..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez4/bluetooth.conf
+++ /dev/null
@@ -1,16 +0,0 @@
1<!-- This configuration file specifies the required security policies
2 for Bluetooth core daemon to work. -->
3
4<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
5 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
6<busconfig>
7
8 <!-- ../system.conf have denied everything, so we just punch some holes -->
9
10 <policy context="default">
11 <allow own="org.bluez"/>
12 <allow send_destination="org.bluez"/>
13 <allow send_interface="org.bluez.Agent"/>
14 </policy>
15
16</busconfig>
diff --git a/meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch b/meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch
deleted file mode 100644
index 27dead092..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez4/fix-dfutool-usb-declaration-mismatch.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1# bluez4: add compile patch fixing some usb declaration mismatch
2# Author: Michael 'Mickey' Lauer <mickey@vanille-media.de>
3# Date: Thu Jan 29 16:52:21 2009 +0000
4#
5# Acquired from OpenEmbedded
6Upstream-Status: Pending
7
8Index: bluez-4.27/tools/dfutool.c
9===================================================================
10--- bluez-4.27.orig/tools/dfutool.c
11+++ bluez-4.27/tools/dfutool.c
12@@ -59,7 +59,7 @@
13 #endif
14
15 #ifdef NEED_USB_GET_BUSSES
16-static inline struct usb_bus *usb_get_busses(void)
17+inline struct usb_bus *usb_get_busses(void)
18 {
19 return usb_busses;
20 }
diff --git a/meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb b/meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb
deleted file mode 100644
index 211e91065..000000000
--- a/meta-oe/recipes-connectivity/bluez/bluez4_4.96.bb
+++ /dev/null
@@ -1,69 +0,0 @@
1SUMMARY = "Linux Bluetooth Stack Userland V4"
2DESCRIPTION = "Linux Bluetooth stack V4 userland components. These include a system configurations, daemons, tools and system libraries."
3HOMEPAGE = "http://www.bluez.org"
4SECTION = "libs"
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
7 file://COPYING.LIB;md5=fb504b67c50331fc78734fed90fb0e09 \
8 file://src/main.c;beginline=1;endline=24;md5=9bc54b93cd7e17bf03f52513f39f926e \
9 file://sbc/sbc.c;beginline=1;endline=25;md5=1a40781ed30d50d8639323a184aeb191"
10DEPENDS = "udev gst-plugins-base alsa-lib libusb dbus-glib usbpath"
11RDEPENDS_${PN}-dev = "bluez-hcidump"
12
13ASNEEDED = ""
14
15PR = "r0"
16
17SRC_URI = "\
18 ${KERNELORG_MIRROR}/linux/bluetooth/bluez-${PV}.tar.gz \
19 file://fix-dfutool-usb-declaration-mismatch.patch \
20 file://bluetooth.conf \
21"
22
23SRC_URI[md5sum] = "296111afac49e3f9035085ac14daf518"
24SRC_URI[sha256sum] = "c06fd50fd77909cad55e3181a42c6bce7cfcf7abb8cd87871c13d0d70f87fa99"
25
26S = "${WORKDIR}/bluez-${PV}"
27
28inherit autotools
29
30EXTRA_OECONF = "\
31 --enable-gstreamer \
32 --enable-alsa \
33 --enable-usb \
34 --enable-tools \
35 --enable-bccmd \
36 --enable-hid2hci \
37 --enable-dfutool \
38 --enable-hidd \
39 --enable-pand \
40 --enable-dund \
41 --disable-cups \
42 --enable-test \
43 --enable-configfiles \
44"
45
46do_install_append() {
47 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
48 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
49 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
50 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
51 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
52}
53
54PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
55
56FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
57FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
58FILES_${PN} += "${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${base_libdir}/systemd/"
59FILES_${PN}-dev += "\
60 ${libdir}/bluetooth/plugins/*.la \
61 ${libdir}/alsa-lib/*.la \
62 ${libdir}/gstreamer-0.10/*.la \
63"
64
65FILES_${PN}-dbg += "\
66 ${libdir}/bluetooth/plugins/.debug \
67 ${libdir}/*/.debug \
68 ${base_libdir}/udev/.debug \
69"
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/elf.patch b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/elf.patch
new file mode 100644
index 000000000..0eef4b4f5
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/elf.patch
@@ -0,0 +1,94 @@
1Index: kexec-tools-2.0.2/kexec/kexec-elf-rel.c
2===================================================================
3--- kexec-tools-2.0.2.orig/kexec/kexec-elf-rel.c 2009-09-24 14:15:34.025828340 +0100
4+++ kexec-tools-2.0.2/kexec/kexec-elf-rel.c 2009-09-24 14:15:47.030825302 +0100
5@@ -4,7 +4,7 @@
6 #include <stdio.h>
7 #include <errno.h>
8 #include <stdlib.h>
9-#include "elf.h"
10+#include "../include/elf.h"
11 #include <boot/elf_boot.h>
12 #include "kexec.h"
13 #include "kexec-elf.h"
14Index: kexec-tools-2.0.2/kexec/crashdump.c
15===================================================================
16--- kexec-tools-2.0.2.orig/kexec/crashdump.c 2008-10-31 03:00:38.000000000 +0100
17+++ kexec-tools-2.0.2/kexec/crashdump.c 2009-09-26 11:16:27.000000000 +0200
18@@ -26,7 +26,7 @@
19 #include <sys/types.h>
20 #include <sys/stat.h>
21 #include <unistd.h>
22-#include <elf.h>
23+#include "../../../include/elf.h"
24 #include "kexec.h"
25 #include "crashdump.h"
26 #include "kexec-syscall.h"
27
28Index: kexec-tools-2.0.2/kexec/crashdump-xen.c
29===================================================================
30--- kexec-tools-2.0.2.orig/kexec/crashdump-xen.c 2008-07-15 02:46:43.000000000 +0200
31+++ kexec-tools-2.0.2/kexec/crashdump-xen.c 2009-09-26 11:16:41.000000000 +0200
32@@ -3,7 +3,7 @@
33 #include <stdarg.h>
34 #include <string.h>
35 #include <stdlib.h>
36-#include <elf.h>
37+#include "../../../include/elf.h"
38 #include <errno.h>
39 #include <limits.h>
40 #include <sys/types.h>
41
42Index: kexec-tools-2.0.2/kexec/arch/arm/kexec-elf-rel-arm.c
43===================================================================
44--- kexec-tools-2.0.2.orig/kexec/arch/arm/kexec-elf-rel-arm.c 2009-04-24 14:15:46.934825202 +0100
45+++ kexec-tools-2.0.2/kexec/arch/arm/kexec-elf-rel-arm.c 2009-09-24 14:15:47.014827381 +0100
46@@ -1,5 +1,5 @@
47 #include <stdio.h>
48-#include <elf.h>
49+#include "../../../include/elf.h"
50 #include "../../kexec.h"
51 #include "../../kexec-elf.h"
52
53Index: kexec-tools-2.0.2/kexec/kexec-elf-boot.c
54===================================================================
55--- kexec-tools-2.0.2.orig/kexec/kexec-elf-boot.c 2009-05-16 13:28:19.000000000 +0200
56+++ kexec-tools-2.0.2/kexec/kexec-elf-boot.c 2009-09-16 11:13:28.000000000 +0200
57@@ -22,7 +22,7 @@
58 #include <string.h>
59 #include <stdlib.h>
60 #include <errno.h>
61-#include <elf.h>
62+#include "../include/elf.h"
63 #include <boot/elf_boot.h>
64 #include <ip_checksum.h>
65 #include <x86/x86-linux.h>
66
67Index: kexec-tools-2.0.2/kdump/kdump.c
68===================================================================
69--- kexec-tools-2.0.2.orig/kdump/kdump.c 2009-05-16 13:28:19.000000000 +0200
70+++ kexec-tools-2.0.2/kdump/kdump.c 2009-09-16 11:13:08.000000000 +0200
71@@ -8,7 +8,7 @@
72 #include <sys/stat.h>
73 #include <fcntl.h>
74 #include <endian.h>
75-#include <elf.h>
76+#include "../include/elf.h"
77
78 #if !defined(__BYTE_ORDER) || !defined(__LITTLE_ENDIAN) || !defined(__BIG_ENDIAN)
79 #error Endian defines missing
80
81Index: kexec-tools-2.0.2/kexec/arch/arm/crashdump-arm.c
82===================================================================
83--- kexec-tools-2.0.2.old/kexec/arch/arm/crashdump-arm.c 2010-08-01 15:07:47.000000000 +0200
84+++ kexec-tools-2.0.2/kexec/arch/arm/crashdump-arm.c 2010-07-29 06:19:59.000000000 +0200
85@@ -20,7 +20,7 @@
86 * along with this program; if not, write to the Free Software
87 * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
88 */
89-#include <elf.h>
90+#include "../../../include/elf.h"
91 #include <errno.h>
92 #include <stdio.h>
93 #include <stdlib.h>
94
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/errno.patch b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/errno.patch
new file mode 100644
index 000000000..c56b5a980
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/errno.patch
@@ -0,0 +1,13 @@
1Index: kexec-tools-2.0.2/kexec/ifdown.c
2===================================================================
3--- kexec-tools-2.0.2.orig/kexec/ifdown.c 2009-09-24 14:15:34.025828340 +0100
4+++ kexec-tools-2.0.2/kexec/ifdown.c 2009-09-24 14:15:47.014827381 +0100
5@@ -14,7 +14,7 @@
6 #include <sys/ioctl.h>
7 #include <sys/socket.h>
8 #include <sys/time.h>
9-#include <sys/errno.h>
10+#include <errno.h>
11
12 #include <net/if.h>
13 #include <netinet/in.h> \ No newline at end of file
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch
new file mode 100644
index 000000000..f6efaebc4
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch
@@ -0,0 +1,97 @@
1Index: kexec-tools-2.0.2/kexec/crashdump-elf.c
2===================================================================
3--- kexec-tools-2.0.2.orig/kexec/crashdump-elf.c 2008-10-31 03:00:38.000000000 +0100
4+++ kexec-tools-2.0.2/kexec/crashdump-elf.c 2009-09-26 11:17:57.000000000 +0200
5@@ -47,7 +47,8 @@
6 if (xen_present())
7 nr_cpus = xen_get_nr_phys_cpus();
8 else
9- nr_cpus = sysconf(_SC_NPROCESSORS_CONF);
10+ /*nr_cpus = sysconf(_SC_NPROCESSORS_CONF);*/
11+ nr_cpus = 1;
12
13 if (nr_cpus < 0) {
14 return -1;
15
16Index: kexec-tools-2.0.2/kexec/arch/arm/kexec-zImage-arm.c
17===================================================================
18--- kexec-tools-2.0.2.orig/kexec/arch/arm/kexec-zImage-arm.c 2009-04-24 14:15:46.982825391 +0100
19+++ kexec-tools-2.0.2/kexec/arch/arm/kexec-zImage-arm.c 2009-09-26 01:58:20.838624318 +0200
20@@ -2,6 +2,10 @@
21 * - 08/21/2007 ATAG support added by Uli Luckas <u.luckas@road.de>
22 *
23 */
24+
25+/* work around for linux header files */
26+#define __deprecated
27+
28 #define _GNU_SOURCE
29 #define _XOPEN_SOURCE
30 #include <stdio.h>
31
32Index: kexec-tools-2.0.2/kexec/kexec.h
33===================================================================
34--- kexec-tools-2.0.2.orig/kexec/kexec.h 2008-05-16 13:28:19.000000000 +0200
35+++ kexec-tools-2.0.2/kexec/kexec.h 2009-09-16 17:32:15.000000000 +0200
36@@ -204,7 +204,7 @@
37 extern char *slurp_file(const char *filename, off_t *r_size);
38 extern char *slurp_file_len(const char *filename, off_t size);
39 extern char *slurp_decompress_file(const char *filename, off_t *r_size);
40-extern unsigned long virt_to_phys(unsigned long addr);
41+/* extern unsigned long virt_to_phys(unsigned long addr); */
42 extern void add_segment(struct kexec_info *info,
43 const void *buf, size_t bufsz, unsigned long base, size_t memsz);
44 extern void add_segment_phys_virt(struct kexec_info *info,
45
46Index: kexec-tools-2.0.2/Makefile.in
47===================================================================
48--- kexec-tools-2.0.2.orig/Makefile.in 2009-09-29 23:49:47.000000000 +0200
49+++ kexec-tools-2.0.2/Makefile.in 2009-09-29 23:49:09.000000000 +0200
50@@ -46,7 +46,7 @@
51 # where necessary.
52 CPPFLAGS = @CPPFLAGS@ -I$(srcdir)/include -I$(srcdir)/util_lib/include \
53 -Iinclude/
54-CFLAGS = @CFLAGS@ -fno-strict-aliasing -Wall -Wstrict-prototypes
55+CFLAGS = @CFLAGS@ -static -fno-strict-aliasing -Wall -Wstrict-prototypes
56 PURGATORY_EXTRA_CFLAGS = @PURGATORY_EXTRA_CFLAGS@
57 ASFLAGS = @ASFLAGS@
58 LDFLAGS = @LDFLAGS@
59
60Index: kexec-tools-2.0.2/util_lib/include/sha256.h
61===================================================================
62--- kexec-tools-2.0.2.orig/util_lib/include/sha256.h 2008-07-15 02:46:43.000000000 +0200
63+++ kexec-tools-2.0.2/util_lib/include/sha256.h 2009-10-02 18:28:45.000000000 +0200
64@@ -1,7 +1,8 @@
65 #ifndef SHA256_H
66 #define SHA256_H
67
68-#include <sys/types.h>
69+//#include <sys/types.h>
70+#include <stddef.h>
71 #include <stdint.h>
72
73 typedef struct
74
75Index: kexec-tools-2.0.2/purgatory/Makefile
76===================================================================
77--- kexec-tools-2.0.2.orig/purgatory/Makefile 2008-10-09 00:32:14.000000000 +0200
78+++ kexec-tools-2.0.2.orig/purgatory/Makefile 2009-10-03 00:28:45.000000000 +0200
79@@ -47,7 +47,7 @@
80 $(PURGATORY): CC=$(TARGET_CC)
81 $(PURGATORY): CFLAGS+=$(PURGATORY_EXTRA_CFLAGS) \
82 $($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
83- -Os -fno-builtin -ffreestanding
84+ -Os -fno-builtin -ffreestanding -nostdinc
85
86 $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
87 -I$(srcdir)/purgatory/include \
88@@ -61,7 +61,8 @@
89
90 $(PURGATORY): $(PURGATORY_OBJS)
91 $(MKDIR) -p $(@D)
92- $(CC) $(LDFLAGS) -o $@ $^
93+# $(CC) $(LDFLAGS) -o $@ $^
94+ $(LD) $(LDFLAGS) -o $@ $^
95
96 # $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
97
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/string.patch b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/string.patch
new file mode 100644
index 000000000..7d27e3998
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/string.patch
@@ -0,0 +1,11 @@
1Index: kexec-tools-2.0.2/purgatory/string.c
2===================================================================
3--- kexec-tools-2.0.2.orig/purgatory/string.c 2008-05-16 13:28:19.000000000 +0200
4+++ kexec-tools-2.0.2/purgatory/string.c 2009-09-16 17:49:04.000000000 +0200
5@@ -1,5 +1,5 @@
6 #include <stddef.h>
7-#include <string.h>
8+/* #include <string.h> */
9
10 size_t strnlen(const char *s, size_t max)
11 {
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/syscall.patch b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/syscall.patch
new file mode 100644
index 000000000..ae2e3f6a6
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/syscall.patch
@@ -0,0 +1,46 @@
1Index: kexec-tools-2.0.2/kexec/kexec-syscall.h
2===================================================================
3--- kexec-tools-2.0.2.orig/kexec/kexec-syscall.h 2010-07-29 06:19:59.000000000 +0200
4+++ kexec-tools-2.0.2/kexec/kexec-syscall.h 2010-08-02 00:13:39.000000000 +0200
5@@ -2,7 +2,7 @@
6 #define KEXEC_SYSCALL_H
7
8 #define __LIBRARY__
9-#include <syscall.h>
10+/*#include <syscall.h>*/
11 #include <sys/syscall.h>
12 #include <unistd.h>
13
14@@ -23,6 +23,7 @@
15 #define LINUX_REBOOT_CMD_KEXEC 0x45584543
16
17 #ifndef __NR_kexec_load
18+/*
19 #ifdef __i386__
20 #define __NR_kexec_load 283
21 #endif
22@@ -61,19 +62,21 @@
23 #ifndef __NR_kexec_load
24 #error Unknown processor architecture. Needs a kexec_load syscall number.
25 #endif
26+*/
27 #endif /*ifndef __NR_kexec_load*/
28
29 struct kexec_segment;
30-
31+/*
32 static inline long kexec_load(void *entry, unsigned long nr_segments,
33 struct kexec_segment *segments, unsigned long flags)
34 {
35 return (long) syscall(__NR_kexec_load, entry, nr_segments, segments, flags);
36 }
37-
38+*/
39 static inline long kexec_reboot(void)
40 {
41- return (long) syscall(__NR_reboot, LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
42+ //return (long) syscall(__NR_reboot, LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
43+ return __reboot(LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
44 }
45
46
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
new file mode 100644
index 000000000..9c35330f3
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
@@ -0,0 +1,26 @@
1# the binaries are statically linked against klibc
2require recipes-kernel/kexec/kexec-tools.inc
3SRC_URI[md5sum] = "bc401cf3262b25ff7c9a51fc76c8ab91"
4SRC_URI[sha256sum] = "549ab65c18a2229b6bf21b6875ca6bbe0e579bca08c3543ce6aaf8287a0b4188"
5
6inherit klibc
7
8FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:"
9
10SRC_URI += "file://elf.patch \
11 file://errno.patch \
12 file://string.patch \
13 file://syscall.patch \
14 file://other.patch \
15 "
16
17S = "${WORKDIR}/kexec-tools-${PV}"
18
19EXTRA_OECONF += "--without-zlib"
20
21PACKAGES =+ "kexec-klibc kdump-klibc"
22
23CFLAGS += "-I${STAGING_DIR_HOST}${base_libdir}/klibc/include -I${STAGING_DIR_HOST}${base_libdir}/klibc/include/bits32"
24
25FILES_kexec-klibc = "${sbindir}/kexec"
26FILES_kdump-klibc = "${sbindir}/kdump"
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools_2.0.2.bbappend b/meta-oe/recipes-kernel/kexec/kexec-tools_2.0.2.bbappend
new file mode 100644
index 000000000..c59c91628
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools_2.0.2.bbappend
@@ -0,0 +1,4 @@
1PACKAGES =+ "kexec kdump"
2
3FILES_kexec = "${sbindir}/kexec"
4FILES_kdump = "${sbindir}/kdump"