diff options
author | Chen Qi <Qi.Chen@windriver.com> | 2014-08-15 01:35:51 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-21 21:35:05 +0200 |
commit | 8f09c03e478d285c344177eef7090560f60e0fcc (patch) | |
tree | f2b758f224afa01c2c9ad0a7e826600dde45a623 /meta-oe | |
parent | ffe0b3cc750eaba6f8608a0ee8deca49f3d7d524 (diff) | |
download | meta-openembedded-8f09c03e478d285c344177eef7090560f60e0fcc.tar.gz |
hostapd: add systemd support
Add hostapd.service file.
The file mostly comes from Fedora20.
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service | 11 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb | 11 |
2 files changed, 19 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service new file mode 100644 index 000000000..151c0504f --- /dev/null +++ b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/hostapd.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator | ||
3 | After=network.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | PIDFile=/run/hostapd.pid | ||
8 | ExecStart=@SBINDIR@/hostapd @SYSCONFDIR@/hostapd.conf -P /run/hostapd.pid -B | ||
9 | |||
10 | [Install] | ||
11 | WantedBy=multi-user.target | ||
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb index d0d9df986..f1c6b3a80 100644 --- a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb +++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb | |||
@@ -5,9 +5,11 @@ LIC_FILES_CHKSUM = "file://README;md5=0854a4da34ac3990770794d771fac7fd" | |||
5 | DEPENDS = "libnl openssl" | 5 | DEPENDS = "libnl openssl" |
6 | SUMMARY = "User space daemon for extended IEEE 802.11 management" | 6 | SUMMARY = "User space daemon for extended IEEE 802.11 management" |
7 | 7 | ||
8 | inherit update-rc.d | 8 | inherit update-rc.d systemd |
9 | INITSCRIPT_NAME = "hostapd" | 9 | INITSCRIPT_NAME = "hostapd" |
10 | 10 | SYSTEMD_PACKAGES = "hostapd" | |
11 | SYSTEMD_SERVICE_hostapd = "hostapd.service" | ||
12 | SYSTEMD_AUTO_ENABLE_hostapd = "disable" | ||
11 | 13 | ||
12 | DEFAULT_PREFERENCE = "-1" | 14 | DEFAULT_PREFERENCE = "-1" |
13 | 15 | ||
@@ -15,6 +17,7 @@ SRC_URI = " \ | |||
15 | http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \ | 17 | http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \ |
16 | file://defconfig \ | 18 | file://defconfig \ |
17 | file://init \ | 19 | file://init \ |
20 | file://hostapd.service \ | ||
18 | " | 21 | " |
19 | 22 | ||
20 | S = "${WORKDIR}/hostapd-${PV}/hostapd" | 23 | S = "${WORKDIR}/hostapd-${PV}/hostapd" |
@@ -30,11 +33,13 @@ do_compile() { | |||
30 | } | 33 | } |
31 | 34 | ||
32 | do_install() { | 35 | do_install() { |
33 | install -d ${D}${sbindir} ${D}${sysconfdir}/init.d | 36 | install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/ |
34 | install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir} | 37 | install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir} |
35 | install -m 0755 ${S}/hostapd ${D}${sbindir} | 38 | install -m 0755 ${S}/hostapd ${D}${sbindir} |
36 | install -m 0755 ${S}/hostapd_cli ${D}${sbindir} | 39 | install -m 0755 ${S}/hostapd_cli ${D}${sbindir} |
37 | install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd | 40 | install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd |
41 | install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/ | ||
42 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service | ||
38 | } | 43 | } |
39 | 44 | ||
40 | CONFFILES_${PN} += "${sysconfdir}/hostapd.conf" | 45 | CONFFILES_${PN} += "${sysconfdir}/hostapd.conf" |