summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-19 08:32:24 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-02 10:04:54 +0200
commitea8d7d2d14e862c5e911fedcc640e2c2d70ac2f0 (patch)
treeb22fa6643ad35325552eb51af64a733a82bdb121 /meta-oe
parentc80829768eb19fc751aefb5720016738af8e14f0 (diff)
downloadmeta-openembedded-ea8d7d2d14e862c5e911fedcc640e2c2d70ac2f0.tar.gz
recipes: use allarch.bbclass instead just PACKAGE_ARCH = all
* otherwise such recipes are rebuilt or reused from sstate after every MACHINE change, because of different checksums see [YOCTO #1075] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/tzdata/tzdata.inc4
-rw-r--r--meta-oe/recipes-graphics/font-update-common/font-update-common_0.1.bb4
-rw-r--r--meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb4
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.69.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb1
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf.inc2
-rw-r--r--meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb4
-rw-r--r--meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb4
-rw-r--r--meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb2
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes.bb4
-rw-r--r--meta-oe/recipes-support/mime-support/mime-support_3.44.bb4
-rw-r--r--meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb5
20 files changed, 29 insertions, 27 deletions
diff --git a/meta-oe/recipes-extended/tzdata/tzdata.inc b/meta-oe/recipes-extended/tzdata/tzdata.inc
index 732ebb376..6739b59bb 100644
--- a/meta-oe/recipes-extended/tzdata/tzdata.inc
+++ b/meta-oe/recipes-extended/tzdata/tzdata.inc
@@ -3,7 +3,7 @@ SECTION = "base"
3PRIORITY = "optional" 3PRIORITY = "optional"
4DEPENDS = "tzcode-native" 4DEPENDS = "tzcode-native"
5 5
6INC_PR = "r9" 6INC_PR = "r10"
7 7
8DEFAULT_TIMEZONE ?= "Europe/London" 8DEFAULT_TIMEZONE ?= "Europe/London"
9 9
@@ -48,7 +48,7 @@ do_install () {
48 cp -pPR ${S}/build${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ${D}${sysconfdir}/localtime 48 cp -pPR ${S}/build${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ${D}${sysconfdir}/localtime
49} 49}
50 50
51PACKAGE_ARCH = "all" 51inherit allarch
52# Packages primarily organized by directory with a major city 52# Packages primarily organized by directory with a major city
53# in most time zones in the base package 53# in most time zones in the base package
54 54
diff --git a/meta-oe/recipes-graphics/font-update-common/font-update-common_0.1.bb b/meta-oe/recipes-graphics/font-update-common/font-update-common_0.1.bb
index d82aec5e6..1e18cad96 100644
--- a/meta-oe/recipes-graphics/font-update-common/font-update-common_0.1.bb
+++ b/meta-oe/recipes-graphics/font-update-common/font-update-common_0.1.bb
@@ -2,6 +2,8 @@ DESCRIPTION = "Scripts to be called when fonts are installed or removed \
2to make them known to the WM, whether X11 or Opie" 2to make them known to the WM, whether X11 or Opie"
3AUTHOR = "Rolf Leggewie <oe-devel@rolf.leggewie.biz" 3AUTHOR = "Rolf Leggewie <oe-devel@rolf.leggewie.biz"
4 4
5PR = "r1"
6
5LICENSE = "MIT" 7LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 8LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
7 9
@@ -13,4 +15,4 @@ do_install() {
13 install -m 0755 ${WORKDIR}/update-fonts ${D}${bindir} 15 install -m 0755 ${WORKDIR}/update-fonts ${D}${bindir}
14} 16}
15 17
16PACKAGE_ARCH = "all" 18inherit allarch
diff --git a/meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb b/meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb
index 9c2a0f9bd..112e8cbc1 100644
--- a/meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb
+++ b/meta-oe/recipes-graphics/tasks/task-fonts-truetype.bb
@@ -3,9 +3,9 @@ SECTION = "fonts"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5PV = "1.0" 5PV = "1.0"
6PR = "r0" 6PR = "r1"
7 7
8inherit task 8inherit task allarch
9 9
10PACKAGES += "\ 10PACKAGES += "\
11 ${PN}-core \ 11 ${PN}-core \
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb
index 877953f1b..10fb9225c 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-arphic-uming_20080216.bb
@@ -4,7 +4,7 @@ LICENSE = "Arphic Public License"
4LIC_FILES_CHKSUM = "file://README;md5=62be011094b7865ddc4d1a648444d31a" 4LIC_FILES_CHKSUM = "file://README;md5=62be011094b7865ddc4d1a648444d31a"
5SRC_DISTRIBUTE_LICENSES += "${PN}" 5SRC_DISTRIBUTE_LICENSES += "${PN}"
6RPROVIDES_${PN} = "virtual-chinese-font" 6RPROVIDES_${PN} = "virtual-chinese-font"
7PR = "r2" 7PR = "r3"
8 8
9SRC_URI = \ 9SRC_URI = \
10"http://archive.ubuntu.com/ubuntu/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.${PV}.1.orig.tar.gz" 10"http://archive.ubuntu.com/ubuntu/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.${PV}.1.orig.tar.gz"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb
index f852cbffd..d4ddf16b8 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb
@@ -12,7 +12,7 @@ RDEPENDS_${PN}-sans-condensed = "${PN}-common"
12RDEPENDS_${PN}-serif = "${PN}-common" 12RDEPENDS_${PN}-serif = "${PN}-common"
13RDEPENDS_${PN}-serif-condensed = "${PN}-common" 13RDEPENDS_${PN}-serif-condensed = "${PN}-common"
14RDEPENDS_${PN}-common = "" 14RDEPENDS_${PN}-common = ""
15PR = "r3" 15PR = "r4"
16 16
17SRC_URI = "${SOURCEFORGE_MIRROR}/dejavu/dejavu-fonts-ttf-${PV}.tar.bz2 \ 17SRC_URI = "${SOURCEFORGE_MIRROR}/dejavu/dejavu-fonts-ttf-${PV}.tar.bz2 \
18 file://30-dejavu-aliases.conf" 18 file://30-dejavu-aliases.conf"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb
index 3fa04abf5..a23170abd 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb
@@ -3,7 +3,7 @@ require ttf.inc
3DESCRIPTION = "Droid fonts - TTF Edition" 3DESCRIPTION = "Droid fonts - TTF Edition"
4HOMEPAGE = "http://www.droidfonts.com/" 4HOMEPAGE = "http://www.droidfonts.com/"
5LICENSE = "Apache-2.0" 5LICENSE = "Apache-2.0"
6PR = "r0" 6PR = "r1"
7# git magic below - SRCREV is an ID of /data/fonts subtree 7# git magic below - SRCREV is an ID of /data/fonts subtree
8# (so we don't need to fetch full platform/frameworks/base.git) 8# (so we don't need to fetch full platform/frameworks/base.git)
9SRCREV = "31f255e44e618ff3b923f332e8fcb83403fd39f5" 9SRCREV = "31f255e44e618ff3b923f332e8fcb83403fd39f5"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb
index 698b2edf8..b00bd75ec 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-gentium_1.02.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Gentium fonts - TTF Version"
4HOMEPAGE = "http://scripts.sil.org/gentium" 4HOMEPAGE = "http://scripts.sil.org/gentium"
5LICENSE = "SIL Open Font License" 5LICENSE = "SIL Open Font License"
6LICENSE_URL = "http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&item_id=OFL" 6LICENSE_URL = "http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&item_id=OFL"
7PR = "r3" 7PR = "r4"
8 8
9SRC_URI = "${DEBIAN_MIRROR}/main/t/ttf-gentium/ttf-gentium_${PV}.orig.tar.gz \ 9SRC_URI = "${DEBIAN_MIRROR}/main/t/ttf-gentium/ttf-gentium_${PV}.orig.tar.gz \
10 file://OFL.gz" 10 file://OFL.gz"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb
index 3984f868a..f841f1acb 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-hunkyfonts_0.3.0.bb
@@ -3,7 +3,7 @@ require ttf.inc
3DESCRIPTION = "Hunky fonts - TTF Version" 3DESCRIPTION = "Hunky fonts - TTF Version"
4HOMEPAGE = "http://sourceforge.net/projects/hunkyfonts" 4HOMEPAGE = "http://sourceforge.net/projects/hunkyfonts"
5LICENSE = "LGPL" 5LICENSE = "LGPL"
6PR = "r3" 6PR = "r4"
7 7
8SRC_URI = "${SOURCEFORGE_MIRROR}/hunkyfonts/hunkyfonts-${PV}.tar.bz2" 8SRC_URI = "${SOURCEFORGE_MIRROR}/hunkyfonts/hunkyfonts-${PV}.tar.bz2"
9 9
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb
index 5ebb25751..104915ee2 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation_0.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://License.txt;md5=5b171c5100029d884fcea21d9a2b7543 \ 7 file://License.txt;md5=5b171c5100029d884fcea21d9a2b7543 \
8" 8"
9 9
10PR = "r3" 10PR = "r4"
11 11
12SRC_URI = "http://fedorahosted.org/liberation-fonts/export/807b6dfd069b998cd9b4d3158da98817ef23c79d/F-9/liberation-fonts-ttf-3.tar.gz" 12SRC_URI = "http://fedorahosted.org/liberation-fonts/export/807b6dfd069b998cd9b4d3158da98817ef23c79d/F-9/liberation-fonts-ttf-3.tar.gz"
13S = "${WORKDIR}/liberation-fonts-${PV}" 13S = "${WORKDIR}/liberation-fonts-${PV}"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
index a6f885b8d..62acf824d 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
@@ -3,7 +3,7 @@ require ttf.inc
3DESCRIPTION = "MPlus font - TTF Edition" 3DESCRIPTION = "MPlus font - TTF Edition"
4HOMEPAGE = "http://dejavu.sourceforge.net/wiki/" 4HOMEPAGE = "http://dejavu.sourceforge.net/wiki/"
5LICENSE = "${PN}" 5LICENSE = "${PN}"
6PR = "r0" 6PR = "r1"
7 7
8SRC_URI = "http://osdn.dl.sourceforge.jp/mplus-fonts/6650/mplus-TESTFLIGHT-${PV}.tar.gz" 8SRC_URI = "http://osdn.dl.sourceforge.jp/mplus-fonts/6650/mplus-TESTFLIGHT-${PV}.tar.gz"
9S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}" 9S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb
index 1ee1c9ce4..1e84fea2c 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb
@@ -9,7 +9,7 @@ LICENSE = "Public domain"
9LIC_FILES_CHKSUM = "file://README;md5=97d739900be6e852830f55aa3c07d4a0" 9LIC_FILES_CHKSUM = "file://README;md5=97d739900be6e852830f55aa3c07d4a0"
10SRC_DISTRIBUTE_LICENSES += "${PN}" 10SRC_DISTRIBUTE_LICENSES += "${PN}"
11RPROVIDES_${PN} = "virtual-japanese-font" 11RPROVIDES_${PN} = "virtual-japanese-font"
12PR = "r5" 12PR = "r6"
13 13
14SRC_URI = "http://osdn.dl.sourceforge.jp/efont/10087/sazanami-20040629.tar.bz2" 14SRC_URI = "http://osdn.dl.sourceforge.jp/efont/10087/sazanami-20040629.tar.bz2"
15S = "${WORKDIR}/sazanami-20040629" 15S = "${WORKDIR}/sazanami-20040629"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.69.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.69.bb
index cc8d2e4cb..1c71b1b52 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.69.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-ubuntu-font-family_0.69.bb
@@ -3,7 +3,7 @@ require ttf.inc
3DESCRIPTION = "Ubuntu Font Family - TTF Version" 3DESCRIPTION = "Ubuntu Font Family - TTF Version"
4HOMEPAGE = "http://font.ubuntu.com" 4HOMEPAGE = "http://font.ubuntu.com"
5LICENSE = "UFL" 5LICENSE = "UFL"
6PR = "r0" 6PR = "r1"
7 7
8SRC_URI = "http://font.ubuntu.com/download/ubuntu-font-family-${PV}+ufl.zip" 8SRC_URI = "http://font.ubuntu.com/download/ubuntu-font-family-${PV}+ufl.zip"
9SRC_URI[md5sum] = "2c3287ea72f81ce025095f7a6d68af28" 9SRC_URI[md5sum] = "2c3287ea72f81ce025095f7a6d68af28"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb
index 2d1d23e12..06de002db 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb
@@ -4,6 +4,7 @@ DESCRIPTION = "WenQuanYi Zen Hei - A Hei-Ti Style Chinese font"
4AUTHOR = "Qianqian Fang and The WenQuanYi Project Contributors" 4AUTHOR = "Qianqian Fang and The WenQuanYi Project Contributors"
5HOMEPAGE = "http://wqy.sourceforge.net/en/" 5HOMEPAGE = "http://wqy.sourceforge.net/en/"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7PR = "r1"
7 8
8SRC_URI = "${SOURCEFORGE_MIRROR}/wqy/wqy-zenhei-${PV}-0.tar.gz" 9SRC_URI = "${SOURCEFORGE_MIRROR}/wqy/wqy-zenhei-${PV}-0.tar.gz"
9S = "${WORKDIR}/wqy-zenhei" 10S = "${WORKDIR}/wqy-zenhei"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf.inc b/meta-oe/recipes-graphics/ttf-fonts/ttf.inc
index af3f27853..978d2f45f 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf.inc
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf.inc
@@ -20,4 +20,4 @@ pkg_postrm_append() {
20 update-fonts 20 update-fonts
21} 21}
22 22
23PACKAGE_ARCH = "all" 23inherit allarch
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
index 0d59ab7da..63ab35452 100644
--- a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
+++ b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts and support files"
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4 4
5PR = "r2" 5PR = "r3"
6 6
7# we are using a gpe-style Makefile 7# we are using a gpe-style Makefile
8inherit gpe 8inherit gpe
@@ -29,7 +29,7 @@ do_install_append() {
29 sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common 29 sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
30} 30}
31 31
32PACKAGE_ARCH = "all" 32inherit allarch
33 33
34RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator" 34RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator"
35 35
diff --git a/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb b/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
index 8310bcd81..eb53a4dc3 100644
--- a/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
+++ b/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
@@ -5,14 +5,14 @@ SECTION = "x11"
5PRIORITY = "optional" 5PRIORITY = "optional"
6RDEPENDS_${PN} = "xserver-common (>= 1.30) xinit" 6RDEPENDS_${PN} = "xserver-common (>= 1.30) xinit"
7DEFAULT_PREFERENCE = "-1" 7DEFAULT_PREFERENCE = "-1"
8PR = "r4" 8PR = "r5"
9 9
10SRC_URI = "file://xserver-nodm \ 10SRC_URI = "file://xserver-nodm \
11 file://gplv2-license.patch \ 11 file://gplv2-license.patch \
12" 12"
13S = ${WORKDIR} 13S = ${WORKDIR}
14 14
15PACKAGE_ARCH = "all" 15inherit allarch
16 16
17do_install() { 17do_install() {
18 install -d ${D}/etc 18 install -d ${D}/etc
diff --git a/meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb b/meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb
index 7552c6f78..3be567ff4 100644
--- a/meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb
+++ b/meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb
@@ -30,7 +30,7 @@ do_install_append() {
30 done 30 done
31} 31}
32 32
33PACKAGE_ARCH = "all" 33inherit allarch
34PACKAGES = "${PN}" 34PACKAGES = "${PN}"
35 35
36pkg_postinst_${PN} () { 36pkg_postinst_${PN} () {
diff --git a/meta-oe/recipes-support/fbset/fbset-modes.bb b/meta-oe/recipes-support/fbset/fbset-modes.bb
index cf4089f63..03d403950 100644
--- a/meta-oe/recipes-support/fbset/fbset-modes.bb
+++ b/meta-oe/recipes-support/fbset/fbset-modes.bb
@@ -3,7 +3,7 @@ LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4 4
5PV = "0.1.0" 5PV = "0.1.0"
6PR = "r5" 6PR = "r6"
7 7
8SRC_URI = "file://fb.modes" 8SRC_URI = "file://fb.modes"
9 9
@@ -12,6 +12,6 @@ do_install() {
12 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir} 12 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
13} 13}
14 14
15PACKAGE_ARCH = "all" 15inherit allarch
16CONFFILES_${PN} = "${sysconfdir}/fb.modes" 16CONFFILES_${PN} = "${sysconfdir}/fb.modes"
17 17
diff --git a/meta-oe/recipes-support/mime-support/mime-support_3.44.bb b/meta-oe/recipes-support/mime-support/mime-support_3.44.bb
index 99c2af765..fe84a63df 100644
--- a/meta-oe/recipes-support/mime-support/mime-support_3.44.bb
+++ b/meta-oe/recipes-support/mime-support/mime-support_3.44.bb
@@ -5,13 +5,13 @@ LIC_FILES_CHKSUM = "file://debian/README;md5=36bbe2ace0a05c3fb684b73208fbf30b"
5 5
6DEPENDS = "file" 6DEPENDS = "file"
7RRECOMMENDS_${PN} = "file" 7RRECOMMENDS_${PN} = "file"
8PR = "r1" 8PR = "r2"
9 9
10SRC_URI = "${DEBIAN_MIRROR}/main/m/mime-support/mime-support_${PV}-1.tar.gz" 10SRC_URI = "${DEBIAN_MIRROR}/main/m/mime-support/mime-support_${PV}-1.tar.gz"
11S = "${WORKDIR}/${PN}" 11S = "${WORKDIR}/${PN}"
12 12
13FILES_${PN} += " ${libdir}/mime" 13FILES_${PN} += " ${libdir}/mime"
14PACKAGE_ARCH = "all" 14inherit allarch
15 15
16docdir_append = "/${PN}" 16docdir_append = "/${PN}"
17 17
diff --git a/meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb b/meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb
index e3fd54b72..c59cc733e 100644
--- a/meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4870b98343f0bbb25fa43b9d2ba59448 \
5 file://COPYING.gpl2;md5=751419260aa954499f7abaabaa882bbe \ 5 file://COPYING.gpl2;md5=751419260aa954499f7abaabaa882bbe \
6" 6"
7 7
8PR = "r1" 8PR = "r2"
9 9
10SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz" 10SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
11 11
@@ -17,8 +17,7 @@ do_install() {
17} 17}
18 18
19FILES_${PN} += "${datadir}" 19FILES_${PN} += "${datadir}"
20PACKAGE_ARCH = "all" 20inherit allarch
21
22 21
23SRC_URI[md5sum] = "6975bf8e9ea2cfb42b9ecdbcc257cf57" 22SRC_URI[md5sum] = "6975bf8e9ea2cfb42b9ecdbcc257cf57"
24SRC_URI[sha256sum] = "5caf7e10b7b0c6a4e1e753af09be52224e88bb8fbcb47794ad72b99b9e24b109" 23SRC_URI[sha256sum] = "5caf7e10b7b0c6a4e1e753af09be52224e88bb8fbcb47794ad72b99b9e24b109"