summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-14 08:44:50 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-19 09:37:29 +0200
commit136339818433b1a55de93085f77f9a48c0a94dbf (patch)
tree869a42411f13d06d15b9f893d69afabea2162512 /meta-oe
parent47a3dd25e5e28e800dc60bcabf383b9adfc99ac8 (diff)
downloadmeta-openembedded-136339818433b1a55de93085f77f9a48c0a94dbf.tar.gz
maliit-framework: fix build with glib 2.36
Upstream code has seen many structural changes and the failing test is gone. Since changing to latest sources might cause huge reworking/test-efforts this patch only fixes the build error. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework/0002-ut_maliit_glib_settings-fix-build-for-glib-2.36.patch33
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework_git.bb2
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework/0002-ut_maliit_glib_settings-fix-build-for-glib-2.36.patch b/meta-oe/recipes-support/maliit/maliit-framework/0002-ut_maliit_glib_settings-fix-build-for-glib-2.36.patch
new file mode 100644
index 000000000..df4f1794e
--- /dev/null
+++ b/meta-oe/recipes-support/maliit/maliit-framework/0002-ut_maliit_glib_settings-fix-build-for-glib-2.36.patch
@@ -0,0 +1,33 @@
1From 839e0933f09309a0374aa58cc58439c3a1f157b2 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Tue, 14 May 2013 10:24:48 +0200
4Subject: [PATCH] ut_maliit_glib_settings: fix build for glib 2.36
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [code removed upstream]
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 .../ut_maliit_glib_settings.c | 3 ++-
14 1 files changed, 2 insertions(+), 1 deletions(-)
15
16diff --git a/tests/ut_maliit_glib_settings/ut_maliit_glib_settings.c b/tests/ut_maliit_glib_settings/ut_maliit_glib_settings.c
17index 476ba33..09b6261 100644
18--- a/tests/ut_maliit_glib_settings/ut_maliit_glib_settings.c
19+++ b/tests/ut_maliit_glib_settings/ut_maliit_glib_settings.c
20@@ -188,8 +188,9 @@ test_settings_manager_emits_disconnected(void)
21 int
22 main (int argc, char **argv) {
23 g_test_init(&argc, &argv, NULL);
24+#if !GLIB_CHECK_VERSION (2, 36, 0)
25 g_type_init();
26-
27+#endif
28 g_test_add_func("/ut_maliit_glib_settings/MaliitSettingsManager/preferred_description_locale/default",
29 test_preferred_description_locale_default);
30 g_test_add_func("/ut_maliit_glib_settings/MaliitSettingsManager/preferred_description_locale/set-get-roundtrip",
31--
321.7.6.5
33
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
index 292856238..15719f4ae 100644
--- a/meta-oe/recipes-support/maliit/maliit-framework_git.bb
+++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
@@ -11,11 +11,13 @@ SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \
11 file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ 11 file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
12 file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \ 12 file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \
13 file://0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch \ 13 file://0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch \
14 file://0002-ut_maliit_glib_settings-fix-build-for-glib-2.36.patch \
14 file://maliit-server.desktop \ 15 file://maliit-server.desktop \
15" 16"
16 17
17SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc" 18SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc"
18PV = "0.92.3+git${SRCPV}" 19PV = "0.92.3+git${SRCPV}"
20PR = "r1"
19 21
20 22
21PACKAGES =+ "${PN}-gtk" 23PACKAGES =+ "${PN}-gtk"