summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-08-14 06:30:59 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:31 +0200
commit6a13d57d0da17ee36749b9d98f745e10dfe26c27 (patch)
tree09660fa05d9ca188d4dc3d5ace35aa87f478dfee /meta-oe
parent5972198b0f23ca7a248247b0c8a91e565eaa30c2 (diff)
downloadmeta-openembedded-6a13d57d0da17ee36749b9d98f745e10dfe26c27.tar.gz
owfs: move to meta-filesystems and upgrade
- Move owfs from meta-oe to meta-filesystems - Upgrade owfs to 2.9p1 [YOCTO #4178] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rwxr-xr-xmeta-oe/recipes-extended/owfs/owfs/owhttpd60
-rwxr-xr-xmeta-oe/recipes-extended/owfs/owfs/owserver59
-rw-r--r--meta-oe/recipes-extended/owfs/owfs_2.8p20.bb69
3 files changed, 0 insertions, 188 deletions
diff --git a/meta-oe/recipes-extended/owfs/owfs/owhttpd b/meta-oe/recipes-extended/owfs/owfs/owhttpd
deleted file mode 100755
index 5d74d13d9..000000000
--- a/meta-oe/recipes-extended/owfs/owfs/owhttpd
+++ /dev/null
@@ -1,60 +0,0 @@
1#!/bin/sh
2
3PATH=/sbin:/bin:/usr/bin
4
5DAEMON="owhttpd"
6
7test -f /usr/bin/${DAEMON} || exit 0
8
9if test -f /etc/default/${DAEMON} ; then
10. /etc/default/${DAEMON}
11else
12:
13fi
14
15if [ "$START_OWHTTPD" != "yes" ]
16then
17 exit 0
18fi
19
20
21startdaemon(){
22 echo -n "Starting ${DAEMON}: "
23 start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
24 echo "done"
25}
26
27stopdaemon(){
28 echo -n "Stopping ${DAEMON}: "
29 start-stop-daemon --stop -p /var/run/${DAEMON}.pid
30 echo "done"
31}
32
33
34
35case "$1" in
36 start)
37 startdaemon
38 ;;
39 stop)
40 stopdaemon
41 ;;
42 force-reload)
43 stopdaemon
44 startdaemon
45 ;;
46 restart)
47 stopdaemon
48 startdaemon
49 ;;
50 reload)
51 stopdaemon
52 startdaemon
53 ;;
54 *)
55 echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
56 exit 1
57 ;;
58esac
59
60exit 0
diff --git a/meta-oe/recipes-extended/owfs/owfs/owserver b/meta-oe/recipes-extended/owfs/owfs/owserver
deleted file mode 100755
index b69ea53e3..000000000
--- a/meta-oe/recipes-extended/owfs/owfs/owserver
+++ /dev/null
@@ -1,59 +0,0 @@
1#!/bin/sh
2
3PATH=/sbin:/bin:/usr/bin
4
5DAEMON="owserver"
6
7test -f /usr/bin/${DAEMON} || exit 0
8
9if test -f /etc/default/${DAEMON} ; then
10. /etc/default/${DAEMON}
11else
12:
13fi
14
15if [ "$START_OWSERVER" != "yes" ]
16then
17 exit 0
18fi
19
20startdaemon(){
21 echo -n "Starting ${DAEMON}: "
22 start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
23 echo "done"
24}
25
26stopdaemon(){
27 echo -n "Stopping ${DAEMON}: "
28 start-stop-daemon --stop -p /var/run/${DAEMON}.pid
29 echo "done"
30}
31
32
33
34case "$1" in
35 start)
36 startdaemon
37 ;;
38 stop)
39 stopdaemon
40 ;;
41 force-reload)
42 stopdaemon
43 startdaemon
44 ;;
45 restart)
46 stopdaemon
47 startdaemon
48 ;;
49 reload)
50 stopdaemon
51 startdaemon
52 ;;
53 *)
54 echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
55 exit 1
56 ;;
57esac
58
59exit 0
diff --git a/meta-oe/recipes-extended/owfs/owfs_2.8p20.bb b/meta-oe/recipes-extended/owfs/owfs_2.8p20.bb
deleted file mode 100644
index 36772cfee..000000000
--- a/meta-oe/recipes-extended/owfs/owfs_2.8p20.bb
+++ /dev/null
@@ -1,69 +0,0 @@
1DESCRIPTION = "1-Wire file system"
2HOMEPAGE = "http://www.owfs.org/"
3SECTION = "console/network"
4
5LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9DEPENDS = "fuse virtual/libusb0"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/owfs/owfs-${PV}.tar.gz \
12 file://owhttpd \
13 file://owserver "
14SRC_URI[md5sum] = "9aebee6c0e724553f5be6a542494eae5"
15SRC_URI[sha256sum] = "2374ce7864927a430da83691eb994382407e2dba492f9789b560d025841cc8ba"
16
17inherit autotools update-rc.d
18
19EXTRA_OECONF = " \
20 --with-fuseinclude=${STAGING_INCDIR} \
21 --with-fuselib=${STAGING_LIBDIR} \
22 --enable-owfs \
23 --enable-owhttpd \
24 --enable-cache \
25 --enable-mt \
26 --enable-w1 \
27 --disable-swig \
28 --disable-owtcl \
29 --disable-owphp \
30 --disable-owpython \
31 --disable-owperl \
32"
33
34do_install_prepend() {
35 install -d ${D}${sysconfdir}/default/
36 install -d ${D}${sysconfdir}/init.d/
37 install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
38 install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
39}
40
41PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
42
43DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
44DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
45DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
46DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
47DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
48DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
49DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
50DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
51DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
52
53FILES_owftpd = "${bindir}/owftpd"
54FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
55FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
56FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
57 ${bindir}/owdir ${bindir}/owpresent \
58 ${bindir}/owget ${bindir}/owside"
59FILES_owmon = "${bindir}/owmon"
60FILES_owtap = "${bindir}/owtap"
61FILES_libowcapi = "${libdir}/libowcapi-*"
62FILES_libow = "${libdir}/libow-*"
63FILES_libownet = "${libdir}/libownet-*"
64
65INITSCRIPT_PACKAGES = "owhttpd owserver"
66INITSCRIPT_NAME_owserver = "owserver"
67INITSCRIPT_NAME_owhttpd = "owhttpd"
68INITSCRIPT_PARAMS_owserver = "defaults 20"
69INITSCRIPT_PARAMS_owhttpd = "defaults 21"