summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-24 14:14:08 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-24 16:24:25 +0200
commitbf778b699d31358ef1794d96ee5f66f600df6086 (patch)
tree4d56bb69a86d3b749ceebb5285bcde01d4bff95f /meta-oe
parent1db927631405ec09a211c94c9746e4bdd29a4e4a (diff)
downloadmeta-openembedded-bf778b699d31358ef1794d96ee5f66f600df6086.tar.gz
udev 174: add version 174, disabled by default (see below)
This release moves various binaries from /sbin to /lib/udev, invalidating the sysvinit scripts in our metadata. To stay closer to upstream the sysvinit scripts have been removed and systemd units are used instead. Since this is a huge change (both the moving of 'udevd' and removing initscripts) this recipe has a negative DEFAULT_PREFERENCE. Patches to reinstate sysvinit support are welcomed, but will be subject to close scrutiny. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/udev/udev_174.bb89
1 files changed, 89 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/udev/udev_174.bb b/meta-oe/recipes-core/udev/udev_174.bb
new file mode 100644
index 000000000..5375e3bdd
--- /dev/null
+++ b/meta-oe/recipes-core/udev/udev_174.bb
@@ -0,0 +1,89 @@
1DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
2/dev/, handles hotplug events and loads drivers at boot time. It replaces \
3the hotplug package and requires a kernel not older than 2.6.27."
4
5DEFAULT_PREFERENCE = "-1"
6
7# udev 169 and up require kernel 2.6.36 for ARM:
8# http://git.kernel.org/?p=linux/hotplug/udev.git;a=commit;h=67a77c8bf299f6264f001677becd056316ebce2f
9
10LICENSE = "GPLv2+ & LGPLv2.1+"
11LICENSE_${PN} = "GPLv2+"
12LICENSE_libudev = "LGPLv2.1+"
13LICENSE_libgudev = "LGPLv2.1+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
15 file://libudev/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
16 file://extras/gudev/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
17
18# Needed for udev-extras
19DEPENDS = "gperf-native usbutils acl glib-2.0"
20
21# b3eccdce81d18ec36c6ea95ac161002fc33d1810 -> 174 tag
22SRCREV = "b3eccdce81d18ec36c6ea95ac161002fc33d1810"
23
24# version specific SRC_URI
25SRC_URI = "git://git.kernel.org/pub/scm/linux/hotplug/udev.git;protocol=git \
26 file://0001-rip-put-doc-generation-it-depends-on-a-working-docto.patch \
27 file://gtk-doc.make"
28
29# generic SRC_URI
30SRC_URI += " \
31 file://touchscreen.rules \
32 file://modprobe.rules \
33"
34
35S = "${WORKDIR}/git"
36
37# Machine specific udev rules should be in their own recipe that ${PN} can add to RRECOMMENDS
38
39inherit autotools
40
41EXTRA_OECONF += " \
42 --disable-introspection \
43 --with-pci-ids-path=/usr/share/misc \
44 ac_cv_file__usr_share_pci_ids=no \
45 ac_cv_file__usr_share_hwdata_pci_ids=no \
46 ac_cv_file__usr_share_misc_pci_ids=yes \
47 --sbindir=${base_sbindir} \
48 --libexecdir=${base_libdir}/udev \
49 --with-rootlibdir=${base_libdir} \
50 --disable-gtk-doc-html \
51 --with-systemdsystemunitdir=${base_libdir}/systemd/system/ \
52"
53
54do_configure_prepend() {
55 cp ${WORKDIR}/gtk-doc.make ${S}
56}
57
58PACKAGES =+ "${PN}-systemd libudev libgudev udev-utils udev-consolekit"
59
60FILES_${PN}-systemd = "${base_libdir}/systemd"
61RDEPENDS_${PN}-systemd += "udev"
62
63FILES_libudev = "${base_libdir}/libudev.so.*"
64FILES_libgudev = "${base_libdir}/libgudev*.so.*"
65
66FILES_udev-utils = "${bindir}/udevinfo ${bindir}/udevtest ${base_sbindir}/udevadm"
67
68RPROVIDES_${PN} = "hotplug"
69FILES_${PN} += "${usrbindir}/* ${usrsbindir}/udevd"
70FILES_${PN}-dbg += "${usrbindir}/.debug ${usrsbindir}/.debug"
71RDEPENDS_${PN} += "module-init-tools-depmod udev-utils"
72RRECOMMENDS_${PN} += "util-linux-blkid"
73
74# udev installs binaries under $(udev_prefix)/lib/udev, even if ${libdir}
75# is ${prefix}/lib64
76FILES_${PN} += "/lib/udev*"
77FILES_${PN}-dbg += "/lib/udev/.debug"
78
79FILES_${PN}-consolekit += "${libdir}/ConsoleKit"
80RDEPENDS_${PN}-consolekit += "consolekit"
81
82do_install () {
83 install -d ${D}${usrsbindir} \
84 ${D}${sbindir}
85 oe_runmake 'DESTDIR=${D}' INSTALL=install install
86
87 install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
88}
89