summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-09-12 13:55:00 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:42:53 +0200
commitbb1773547109be47968b0e644ca8449e50d847bb (patch)
treea41d48b1e89059b128ac9408c1e0a7ec1ad79d99 /meta-oe
parent9c7899e0df435655870798c15580b1c0967ca30c (diff)
downloadmeta-openembedded-bb1773547109be47968b0e644ca8449e50d847bb.tar.gz
ltp-ddt: keep do_make_scripts as separate task to lock correctly
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.5.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.5.bb b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.5.bb
index d0b84ad52..db62ac63a 100644
--- a/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.5.bb
+++ b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.5.bb
@@ -13,7 +13,7 @@ inherit autotools-brokensep module-base kernel-module-split
13 13
14PACKAGE_ARCH = "${MACHINE_ARCH}" 14PACKAGE_ARCH = "${MACHINE_ARCH}"
15 15
16SRCREV = "088356602220dd8b48aeb138d4976c05c0879574" 16SRCREV = "903f70a11eb77cbad62d7ecbe7dcbaf61be8ff99"
17BRANCH ?= "master" 17BRANCH ?= "master"
18 18
19SRC_URI = "git://arago-project.org/git/projects/test-automation/ltp-ddt.git;branch=${BRANCH} \ 19SRC_URI = "git://arago-project.org/git/projects/test-automation/ltp-ddt.git;branch=${BRANCH} \
@@ -67,10 +67,6 @@ do_configure() {
67 67
68kmoddir = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/ddt" 68kmoddir = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/ddt"
69 69
70do_compile_prepend () {
71 do_make_scripts
72}
73
74do_compile_append () { 70do_compile_append () {
75 oe_runmake modules 71 oe_runmake modules
76} 72}
@@ -83,3 +79,8 @@ do_install() {
83 rm -rf ${D}${LTPROOT}/share/ 79 rm -rf ${D}${LTPROOT}/share/
84 mv ${D}${LTPROOT}/testcases/bin/ddt/*.ko ${D}${kmoddir} 80 mv ${D}${LTPROOT}/testcases/bin/ddt/*.ko ${D}${kmoddir}
85} 81}
82
83# do_make_scripts should be a separate task for the lock to work
84addtask make_scripts before do_compile
85do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
86do_make_scripts[deptask] = "do_populate_sysroot"