summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 16:53:10 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-03 14:11:22 +0100
commitb2bed436b4f0e14c1df71a7edfd10b94099e93b7 (patch)
tree1a8d4468838206ef12363a8ef4d3dc61b846db38 /meta-oe
parent69de108f24567b294d81aec6aae5326ae71ee86e (diff)
downloadmeta-openembedded-b2bed436b4f0e14c1df71a7edfd10b94099e93b7.tar.gz
libc-client: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch12
-rw-r--r--meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb32
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch b/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch
new file mode 100644
index 000000000..f729ee207
--- /dev/null
+++ b/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch
@@ -0,0 +1,12 @@
1diff -urN imap-2007.orig/Makefile imap-2007/Makefile
2--- imap-2007.orig/Makefile 2007-12-20 23:11:10.000000000 +0100
3+++ imap-2007/Makefile 2008-03-19 14:08:47.000000000 +0100
4@@ -690,7 +690,7 @@
5 @$(SH) -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)'
6 @echo Rebuilding c-client for `$(CAT) OSTYPE`...
7 @$(TOUCH) SPECIALS
8- $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \
9+ $(CD) c-client;$(MAKE) all CC="`$(CAT) CCTYPE`" \
10 CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
11
12 rebuildclean:
diff --git a/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb b/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb
new file mode 100644
index 000000000..e67639ed3
--- /dev/null
+++ b/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "UW c-client library for mail protocols"
2SECTION = "devel"
3
4LICENSE = "University of Washingtons Free-Fork License"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a6a4ddbb7cd2999f6827ee143f6fcd97"
6
7DEPENDS = "openssl libpam"
8
9SRC_URI = "ftp://ftp.cac.washington.edu/imap/imap-${PV}.tar.gz \
10 file://quote_cctype.patch"
11
12SRC_URI[md5sum] = "7903800dc2604000016de070e0c55840"
13SRC_URI[sha256sum] = "4b1137b87249782496ec3eeacaf83bbf09312a7d2ae3aead262179041b55565f"
14
15S = "${WORKDIR}/imap-${PV}"
16
17EXTRA_OEMAKE = "CC='${CC}'"
18
19HEADERS = "src/c-client/*.h src/osdep/unix/*.h c-client/auths.c c-client/linkage.c c-client/linkage.h c-client/osdep.h"
20
21do_compile() {
22 echo "SSLINCLUDE=${STAGING_INCDIR} SSLLIB=${STAGING_LIBDIR}" > ${S}/SPECIALS
23 oe_runmake lnp
24}
25
26do_install() {
27 install -d ${D}${includedir}/c-client
28 install ${HEADERS} ${D}${includedir}/c-client
29 install -d ${D}${libdir}
30 install c-client/c-client.a ${D}${libdir}/libc-client.a
31}
32