summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-09-17 01:56:39 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:53 +0200
commita689cb8239360ba0c8b3e7934fe49fd8dfe449e8 (patch)
treecddda208d2e4e3e21f224dd703d540151db6f57c /meta-oe
parente99ca149a158b046ee02fcaa589df9cdca164f01 (diff)
downloadmeta-openembedded-a689cb8239360ba0c8b3e7934fe49fd8dfe449e8.tar.gz
talloc: fixes for sstate cache reuse
Fixes for sstate cache reuse between different build dirs. The ${SWIGLIBDIR##${STAGING_DIR_NATIVE}} had confused bitbake, bitbake would add the "SWIGLIBDIR##${STAGING_DIR_NATIVE}" to the deps of do_install, which caused the sstate cached can't be re-used. Use another way for SWIGLIBDIR to fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/talloc/talloc_2.0.1.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
index 9cf3e4322..7bbfbc291 100644
--- a/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
+++ b/meta-oe/recipes-support/talloc/talloc_2.0.1.bb
@@ -23,7 +23,15 @@ DEPENDS += "swig-native"
23do_install_prepend() { 23do_install_prepend() {
24 # Hack the way swig interface for talloc is installed 24 # Hack the way swig interface for talloc is installed
25 # This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch 25 # This hack is accompanied by install-swig-interface-in-SWINGLIBDIR.patch
26 type swig > /dev/null 2>&1 && SWIGLIBDIR=`swig -swiglib` && SWIGLIBDIR=`readlink -f ${SWIGLIBDIR}` && SWIGLIBDIR=${SWIGLIBDIR##${STAGING_DIR_NATIVE}} && export SWIGLIBDIR || echo "No swig found" 26 if which swig > /dev/null; then
27 SWIGLIBDIR="$(echo $(readlink -f $(swig -swiglib)) | \
28 sed -e 's#^${STAGING_DIR_NATIVE}##')"
29 fi
30 if [ -n "$SWIGLIBDIR" ]; then
31 export SWIGLIBDIR
32 else
33 echo "No swig found"
34 fi
27} 35}
28 36
29do_install_append() { 37do_install_append() {