summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorGary S. Robertson <gary.robertson@linaro.org>2014-11-24 16:59:15 -0600
committerArmin Kuster <akuster808@gmail.com>2014-12-26 17:59:07 -0800
commit8d8b0f1cc843e6df6f44d16360d712a7a44d17d7 (patch)
treead370553e9a2288217738354ba2b5c0284a165aa /meta-oe
parent2b524c31f7b1750e7976284b099f24c9c196c876 (diff)
downloadmeta-openembedded-8d8b0f1cc843e6df6f44d16360d712a7a44d17d7.tar.gz
libhugetlbfs: Fix page size & text offset for arm arches
Fixed computation of page size and text segment offset for various arm architectures - including both LE and BE variants of armv7 as well as aarch64 Upstream Status: Accepted at libhugetlbfs project Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch32
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch57
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb2
3 files changed, 58 insertions, 33 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch
deleted file mode 100644
index da60ba0ae..000000000
--- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1Subject: [PATCH] aarch64: fix page size not properly computed
2
3There's 2 issues fixed:
4* typo on MB variable (MB -> $MB)
5* some linker variants are missing (linux and big endian)
6 - aarch64elfb
7 - aarch64linux
8 - aarch64linuxb
9
10Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
11
12Upstream-Status: Submitted
13---
14 ld.hugetlbfs | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/ld.hugetlbfs b/ld.hugetlbfs
18index df446dd..6553547 100755
19--- a/ld.hugetlbfs
20+++ b/ld.hugetlbfs
21@@ -87,7 +87,7 @@ elf32ppclinux|elf64ppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;;
22 elf64lppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;;
23 elf_i386|elf_x86_64) HPAGE_SIZE=$((4*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
24 elf_s390|elf64_s390) HPAGE_SIZE=$((1*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
25-armelf_linux_eabi|aarch64elf) HPAGE_SIZE=$((2*MB)) SLICE_SIZE=$HPAGE_SIZE ;;
26+armelf_linux_eabi|aarch64elf*|aarch64linux*) HPAGE_SIZE=$((2*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
27 esac
28
29 if [ "$HTLB_ALIGN" == "slice" ]; then
30--
311.9.2
32
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch
new file mode 100644
index 000000000..4e5b7bbbb
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch
@@ -0,0 +1,57 @@
1From 1ab6f7f9b34fc745451140fc21db6763dffc5785 Mon Sep 17 00:00:00 2001
2From: "Gary S. Robertson" <gary.robertson@linaro.org>
3Date: Thu, 25 Sep 2014 14:57:06 -0500
4Subject: [PATCH] ld.hugetlbfs: arm arches - fix page size and text offset
5 setup
6
7There's 3 issues fixed:
8* typo on MB variable (MB -> $MB)
9* some linker variants are missing (linux and big endian)
10 - armelfb_linux_eabi
11 - aarch64elfb
12 - aarch64linux
13 - aarch64linuxb
14* text segment offset was not specified for armv7 BE
15
16NOTE: This patch replaces and makes obsolete the following previously
17 submitted patch:
18
19 aarch64: fix page size not properly computed
20 by: Fathi Boudra <fathi.boudra@linaro.org>
21
22Upstream Status: Accepted at libhugetlbfs project
23
24Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
25---
26 ld.hugetlbfs | 8 ++++----
27 1 file changed, 4 insertions(+), 4 deletions(-)
28
29diff --git a/ld.hugetlbfs b/ld.hugetlbfs
30index df446dd..4417442 100755
31--- a/ld.hugetlbfs
32+++ b/ld.hugetlbfs
33@@ -87,7 +87,7 @@ elf32ppclinux|elf64ppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;;
34 elf64lppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;;
35 elf_i386|elf_x86_64) HPAGE_SIZE=$((4*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
36 elf_s390|elf64_s390) HPAGE_SIZE=$((1*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
37-armelf_linux_eabi|aarch64elf) HPAGE_SIZE=$((2*MB)) SLICE_SIZE=$HPAGE_SIZE ;;
38+armelf*_linux_eabi|aarch64elf*|aarch64linux*) HPAGE_SIZE=$((2*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
39 esac
40
41 if [ "$HTLB_ALIGN" == "slice" ]; then
42@@ -96,9 +96,9 @@ if [ "$HTLB_ALIGN" == "slice" ]; then
43
44 # targeting the ARM platform one needs to explicitly set the text segment offset
45 # otherwise it will be NULL.
46- if [ "$EMU" == "armelf_linux_eabi" ]; then
47- HTLBOPTS="$HTLBOPTS -Ttext-segment=$SLICE_SIZE"
48- fi
49+ case "$EMU" in
50+ armelf*_linux_eabi) HTLBOPTS="$HTLBOPTS -Ttext-segment=$SLICE_SIZE" ;;
51+ esac
52 fi
53
54 ${LD} "${args[@]}" ${HTLBOPTS}
55--
561.7.9.5
57
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index c90621703..4ce6a1901 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -16,7 +16,7 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
16 file://tests-Makefile-install-static-4G-edge-testcases.patch \ 16 file://tests-Makefile-install-static-4G-edge-testcases.patch \
17 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ 17 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \
18 file://0001-aarch64-fix-cross-compilation.patch \ 18 file://0001-aarch64-fix-cross-compilation.patch \
19 file://0001-aarch64-fix-page-size-not-properly-computed.patch \ 19 file://0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch \
20 file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ 20 file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
21 file://0001-Extend-arm32-support-to-include-BE-variants.patch \ 21 file://0001-Extend-arm32-support-to-include-BE-variants.patch \
22 file://0001-Makefile-Recognize-all-ix86-arches.patch \ 22 file://0001-Makefile-Recognize-all-ix86-arches.patch \