summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-02-14 20:48:59 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-21 17:07:00 +0100
commit752f6ba6e40b6e7b4e0931af58e98a4c95d0bb81 (patch)
tree89176d1e85a18f51e7a2b31343321b97d639808d /meta-oe
parent0477432cce69eef73744e46855b0449bd56b3297 (diff)
downloadmeta-openembedded-752f6ba6e40b6e7b4e0931af58e98a4c95d0bb81.tar.gz
libmicrohttpd: upgrade to 0.9.33
libmicrohttpd is needed by systemd-journald-gatewayd Remove older recipes and move to recipes-support Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.4.6.bb16
-rw-r--r--meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.9.27.bb16
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb26
3 files changed, 26 insertions, 32 deletions
diff --git a/meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.4.6.bb b/meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.4.6.bb
deleted file mode 100644
index ebaa48536..000000000
--- a/meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.4.6.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "GNU libmicrohttpd is a small C library that is supposed to make it easy to run an HTTP server as part of another application."
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
4
5DEPENDS = "libgcrypt curl"
6
7# ftp://ftp.nluug.nl/pub/gnu/${PN}/ has only 0.9.* and newer now
8SRC_URI = "http://mirrors.usc.edu/pub/gnu/${PN}/${P}.tar.gz"
9SRC_URI[md5sum] = "61698da6aa04744ea076c327f66fc05a"
10SRC_URI[sha256sum] = "0cb09e26678d1531a4fd40a748abff5142bfdad3ae11cfe3bb7ad7317a99e371"
11
12inherit autotools lib_package
13
14do_compile_append() {
15 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
16}
diff --git a/meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.9.27.bb b/meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.9.27.bb
deleted file mode 100644
index 802ae4023..000000000
--- a/meta-oe/recipes-connectivity/libmicrohttpd/libmicrohttpd_0.9.27.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "GNU libmicrohttpd is a small C library that is supposed to make it easy to run an HTTP server as part of another application."
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
4
5DEPENDS = "libgcrypt curl"
6
7SRC_URI = "ftp://ftp.nluug.nl/pub/gnu/libmicrohttpd//libmicrohttpd-${PV}.tar.gz"
8SRC_URI[md5sum] = "a10496b7f1b495aaf6897584da52f51b"
9SRC_URI[sha256sum] = "d532edf64c3a9da472114c2d10fc94606e3b31f21b883ec2e796ab8478f7e9cb"
10
11
12inherit autotools lib_package
13
14do_compile_append() {
15 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
16}
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb
new file mode 100644
index 000000000..523b8dd4e
--- /dev/null
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.33.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5SECTION = "net"
6DEPENDS = "libgcrypt gnutls"
7
8SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9SRC_URI[md5sum] = "013b10f9de1cda5448b29c81305354a3"
10SRC_URI[sha256sum] = "d9587e8497548f820650cd607daf3615ea3272435779378983032c570f1cd559"
11
12inherit autotools lib_package
13
14EXTRA_OECONF += "-disable-static --enable-gnutls"
15
16PACKAGECONFIG ?= "curl"
17PACKAGECONFIG_append_class-target = "\
18 ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
19"
20PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
21PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
22
23do_compile_append() {
24 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
25}
26