summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-02-29 12:43:04 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-29 14:53:13 +0100
commit3d15d096b6cd691d9b7e7b00c44498b73e9661b5 (patch)
tree517190c436b978b75fbb57bc8cb752c06516dbe0 /meta-oe
parent59de020063c4a5130c4f7e1a997aa32db18575ee (diff)
downloadmeta-openembedded-3d15d096b6cd691d9b7e7b00c44498b73e9661b5.tar.gz
systemd: address logind problem on BE machines
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch29
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch b/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch
new file mode 100644
index 000000000..b41d5ebad
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch
@@ -0,0 +1,29 @@
1From d228134ff5af3bd0ef1087e9bee66583c1546553 Mon Sep 17 00:00:00 2001
2From: Dirk Eibach <eibach@gdsys.de>
3Date: Wed, 29 Feb 2012 12:45:46 +0100
4Subject: [PATCH] systemd-journald: fix endianess bug
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8
9Upstream-status: Submitted
10
11 src/journal/journal-file.c | 2 +-
12 1 files changed, 1 insertions(+), 1 deletions(-)
13
14diff --git a/src/journal/journal-file.c b/src/journal/journal-file.c
15index 20ca3f6..275caea 100644
16--- a/src/journal/journal-file.c
17+++ b/src/journal/journal-file.c
18@@ -238,7 +238,7 @@ static int journal_file_allocate(JournalFile *f, uint64_t offset, uint64_t size)
19 if (fstat(f->fd, &f->last_stat) < 0)
20 return -errno;
21
22- f->header->arena_size = new_size - htole64(f->header->arena_offset);
23+ f->header->arena_size = htole64(new_size - le64toh(f->header->arena_offset));
24
25 return 0;
26 }
27--
281.7.7.4
29
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 4c458bd73..62a326ee0 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
14PKGV = "v${GITPKGVTAG}" 14PKGV = "v${GITPKGVTAG}"
15 15
16PV = "git" 16PV = "git"
17PR = "r16" 17PR = "r17"
18 18
19inherit useradd pkgconfig autotools vala perlnative 19inherit useradd pkgconfig autotools vala perlnative
20 20
@@ -23,6 +23,7 @@ SRCREV = "d26e4270409506cd398875216413b651d6ee7de6"
23SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ 23SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
24 file://0001-docs-fix-build-without-xsltproc.patch \ 24 file://0001-docs-fix-build-without-xsltproc.patch \
25 file://0002-systemd-logind-don-t-kill-user-processes-on-exit.patch \ 25 file://0002-systemd-logind-don-t-kill-user-processes-on-exit.patch \
26 file://0001-systemd-journald-fix-endianess-bug.patch \
26 ${UCLIBCPATCHES} \ 27 ${UCLIBCPATCHES} \
27 " 28 "
28UCLIBCPATCHES = "" 29UCLIBCPATCHES = ""