summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2014-08-15 10:09:03 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-21 21:35:06 +0200
commit2139d9034d036e92566adf2fff75fa49cd531ab1 (patch)
tree483b2b8b9c17661b3ab64bd859727a9e2cd33851 /meta-oe
parentdb6489c2faea6d51e1dd45d627e722b978511130 (diff)
downloadmeta-openembedded-2139d9034d036e92566adf2fff75fa49cd531ab1.tar.gz
mg: fix build when host system does not have libncurses-dev
The configure script for mg checks the standard locations under /usr for the term.h header file needed to build against ncurses; however, in the OE cross-compile case, this is not valid, since the file will be under the sysroot instead. This causes the configure step to fail when the build machine does not have the libncurses-dev package installed. To fix the issue, remove the check. Since mg DEPENDS on ncurses, term.h will always be there. Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/mg/files/remove_ncurses_check.patch36
-rw-r--r--meta-oe/recipes-support/mg/mg_20110905.bb3
2 files changed, 38 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/mg/files/remove_ncurses_check.patch b/meta-oe/recipes-support/mg/files/remove_ncurses_check.patch
new file mode 100644
index 000000000..16137da2b
--- /dev/null
+++ b/meta-oe/recipes-support/mg/files/remove_ncurses_check.patch
@@ -0,0 +1,36 @@
1diff -uwr mg-20110905/configure mg-20110905-changed/configure
2--- mg-20110905/configure 2011-09-05 13:36:16.000000000 -0500
3+++ mg-20110905-changed/configure 2014-08-14 10:46:14.168715425 -0500
4@@ -163,32 +163,6 @@
5 echo 'Fails.'
6 fi
7
8-
9-if [ ! -r /usr/include/term.h ]; then
10- note 'term.h'
11- if [ -r /usr/include/ncurses/term.h ]; then
12- echo "Found in /usr/include/ncurses"
13- extraflags="$extraflags -I/usr/include/ncurses"
14- else
15- for i in pkg local; do
16- if [ -r /usr/$i/include/term.h ]; then
17- echo "Found in /usr/$i/include"
18- extralibs="$extralibs -L/usr/$i/lib"
19- extraflags="$extraflags -I/usr/$i/include"
20- break
21- else
22- false
23- fi
24- done ||
25- {
26- echo 'Not found!' >&2
27- echo 'Do you have the ncurses devel package installed?' >&2
28- echo 'If you know where term.h is, please email the author!' >&2
29- exit 1
30- }
31- fi
32-fi
33-
34 note 'base and dirname'
35 if gcc_defines "__GLIBC__" || gcc_defines "__CYGWIN__" ; then
36 echo 'Not present, adding.'
diff --git a/meta-oe/recipes-support/mg/mg_20110905.bb b/meta-oe/recipes-support/mg/mg_20110905.bb
index 33cc0384b..b9a4d3392 100644
--- a/meta-oe/recipes-support/mg/mg_20110905.bb
+++ b/meta-oe/recipes-support/mg/mg_20110905.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://version.c;md5=811e1b67a5cd60c12b218a2b7c1adbf2"
5DEPENDS = "ncurses" 5DEPENDS = "ncurses"
6SECTION = "console/editors" 6SECTION = "console/editors"
7 7
8SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz" 8SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz \
9 file://remove_ncurses_check.patch"
9 10
10SRC_URI[md5sum] = "2de35316fa8ebafe6003efaae70b723e" 11SRC_URI[md5sum] = "2de35316fa8ebafe6003efaae70b723e"
11SRC_URI[sha256sum] = "1cd37d7e6a3eecc890a5718c38b8f38495057ba93856762a756ccee2f9618229" 12SRC_URI[sha256sum] = "1cd37d7e6a3eecc890a5718c38b8f38495057ba93856762a756ccee2f9618229"