summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorImran Mehmood <Imran_Mehmood@mentor.com>2011-09-08 22:32:41 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-14 13:04:01 +0200
commite5340d912c01eb2f0b6cbe0fb174839818a8a665 (patch)
tree32475436b4afa86be46b614a6cb142064f874e01 /meta-oe
parent15832ab1f64f2bc2ee7d342e5bff0351b5e2479b (diff)
downloadmeta-openembedded-e5340d912c01eb2f0b6cbe0fb174839818a8a665.tar.gz
cramfs: Adds cvs version recipe (initial recipe)
* Imported from oe.dev commit id e0728e428367d5534d6a56e452487529c5ec4918 * Added do_compile_prepend to make symbolic link named Makefile pointing to GNUmakefile to resolve missing Makefile error. Signed-off-by: Imran Mehmood <Imran_Mehmood@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/cramfs/cramfs_cvs.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cramfs/cramfs_cvs.bb b/meta-oe/recipes-support/cramfs/cramfs_cvs.bb
new file mode 100644
index 000000000..667097c86
--- /dev/null
+++ b/meta-oe/recipes-support/cramfs/cramfs_cvs.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Builds cramfs filesystems for embedded systems"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/linux/COPYING;md5=9579385572eb40eded61dcb07e0038a4"
4DEPENDS = "zlib"
5SRCDATE = "20110110"
6PV = "1.1+cvs${SRCDATE}"
7
8SRC_URI = "cvs://anonymous@cramfs.cvs.sourceforge.net/cvsroot/cramfs;module=linux"
9S = "${WORKDIR}/linux/scripts/cramfs"
10
11EXTRA_OEMAKE = "\
12 'CC=${CC}' \
13 'CFLAGS=${CFLAGS}' \
14 'LDFLAGS=${LDFLAGS}' \
15"
16
17
18do_compile_prepend() {
19 ln -s GNUmakefile Makefile
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install mkcramfs ${D}${bindir}
25 install cramfsck ${D}${bindir}
26}
27
28BBCLASSEXTEND = "native"
29