diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2011-09-07 05:17:50 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-07 10:38:28 +0200 |
commit | 77f306cc0d06422a582b6df5d90435c48aad3561 (patch) | |
tree | 8a7dd2ad76a39d3472972c600beb679a95022f04 /meta-oe | |
parent | 5e2cdae237f2093f9b592277c9419b6f0275feb5 (diff) | |
download | meta-openembedded-77f306cc0d06422a582b6df5d90435c48aad3561.tar.gz |
klibc_1.5.24: remove nostrip patch and fix packaging of klibc-utils
* follow Debian packaging for klibc-utils
* bump PR
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/klibc/klibc-1.5.24/no_strip.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/klibc/klibc-utils.inc | 12 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/klibc/klibc-utils_1.5.24.bb | 17 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/klibc/klibc.inc | 3 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/klibc/klibc_1.5.24.bb | 7 |
5 files changed, 28 insertions, 47 deletions
diff --git a/meta-oe/recipes-devtools/klibc/klibc-1.5.24/no_strip.patch b/meta-oe/recipes-devtools/klibc/klibc-1.5.24/no_strip.patch deleted file mode 100644 index f690d9883..000000000 --- a/meta-oe/recipes-devtools/klibc/klibc-1.5.24/no_strip.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | Do not strip binaries too early. Strip is done before packaging. | ||
2 | Signed-off-by: Andrea Adami <andrea.adami@gmail.com> | ||
3 | |||
4 | --- a/scripts/Kbuild.klibc 2011-06-14 17:11:17.000000000 +0200 | ||
5 | +++ b/scripts/Kbuild.klibc 2011-07-15 01:18:58.000000000 +0200 | ||
6 | @@ -332,8 +332,7 @@ | ||
7 | $(KLIBCLIBC) \ | ||
8 | $(KLIBCLIBGCC) \ | ||
9 | --end-group ; \ | ||
10 | - cp -f $@ $@.g ; \ | ||
11 | - $(KLIBCSTRIP) $(KLIBCSTRIPFLAGS) $@ | ||
12 | + cp -f $@ $@.g | ||
13 | |||
14 | |||
15 | $(static-y): $(kprog-objs) $(lib-target) $(KLIBCCRT0) $(KLIBCLIBC) FORCE | ||
16 | @@ -348,8 +347,7 @@ | ||
17 | -R $(KLIBCLIBCSHARED) \ | ||
18 | $(KLIBCLIBGCC) \ | ||
19 | --end-group ; \ | ||
20 | - cp -f $@ $@.g ; \ | ||
21 | - $(KLIBCSTRIP) $(KLIBCSTRIPFLAGS) $@ | ||
22 | + cp -f $@ $@.g | ||
23 | |||
24 | |||
25 | $(shared-y): $(kprog-objs) $(lib-target) $(KLIBCCRTSHARED) \ | ||
26 | |||
27 | --- a/usr/klibc/Kbuild 2011-07-15 01:46:32.000000000 +0200 | ||
28 | +++ b/usr/klibc/Kbuild 2011-07-15 01:47:17.000000000 +0200 | ||
29 | @@ -147,7 +147,6 @@ | ||
30 | |||
31 | quiet_cmd_sohash = GEN $@ | ||
32 | cmd_sohash = cat $< > $@; \ | ||
33 | - $(KLIBCSTRIP) $(KLIBCSTRIPFLAGS) $@; \ | ||
34 | chmod a+x $@; \ | ||
35 | rm -f $(obj)/klibc-???????????????????????????.so; \ | ||
36 | ln -f $@ $(obj)/klibc-$(SOLIBHASH).so | ||
diff --git a/meta-oe/recipes-devtools/klibc/klibc-utils.inc b/meta-oe/recipes-devtools/klibc/klibc-utils.inc index a360c2e7f..0f195a3f3 100644 --- a/meta-oe/recipes-devtools/klibc/klibc-utils.inc +++ b/meta-oe/recipes-devtools/klibc/klibc-utils.inc | |||
@@ -9,9 +9,15 @@ do_install_append() { | |||
9 | install -d ${D}${base_bindir} | 9 | install -d ${D}${base_bindir} |
10 | install -d ${D}${base_sbindir} | 10 | install -d ${D}${base_sbindir} |
11 | 11 | ||
12 | # those 2 are always static | 12 | # debian packages kinit + kinit.shared but only sh.shared |
13 | install -m 755 usr/dash/sh ${D}${base_bindir}/sh | 13 | if [ "${KLIBC_UTILS_VARIANT}" = "shared" ]; then |
14 | install -m 755 usr/kinit/kinit ${D}${base_bindir}/kinit | 14 | install -m 755 usr/kinit/kinit ${D}${base_bindir}/kinit |
15 | install -m 755 usr/kinit/kinit.shared ${D}${base_bindir}/kinit.shared | ||
16 | install -m 755 usr/dash/sh.shared ${D}${base_bindir}/sh.shared | ||
17 | else | ||
18 | install -m 755 usr/dash/sh ${D}${base_bindir}/sh | ||
19 | install -m 755 usr/kinit/kinit ${D}${base_bindir}/kinit | ||
20 | fi | ||
15 | 21 | ||
16 | install -m 755 usr/gzip/gzip ${D}${base_bindir} | 22 | install -m 755 usr/gzip/gzip ${D}${base_bindir} |
17 | install -m 755 usr/kinit/fstype/${KLIBC_UTILS_VARIANT}/fstype ${D}${base_bindir} | 23 | install -m 755 usr/kinit/fstype/${KLIBC_UTILS_VARIANT}/fstype ${D}${base_bindir} |
diff --git a/meta-oe/recipes-devtools/klibc/klibc-utils_1.5.24.bb b/meta-oe/recipes-devtools/klibc/klibc-utils_1.5.24.bb new file mode 100644 index 000000000..b26dda400 --- /dev/null +++ b/meta-oe/recipes-devtools/klibc/klibc-utils_1.5.24.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | PR = "${INC_PR}.0" | ||
2 | |||
3 | KLIBC_UTILS_VARIANT = "shared" | ||
4 | KLIBC_UTILS_PKGNAME = "klibc-utils" | ||
5 | |||
6 | FILESPATH =. "${FILE_DIRNAME}/klibc-${PV}:" | ||
7 | |||
8 | do_install() { | ||
9 | : | ||
10 | } | ||
11 | |||
12 | PACKAGES_${PN} = "${PN}" | ||
13 | FILES_${PN} = "" | ||
14 | |||
15 | require klibc-utils.inc | ||
16 | require klibc.inc | ||
17 | require klibc-checksums_${PV}.inc | ||
diff --git a/meta-oe/recipes-devtools/klibc/klibc.inc b/meta-oe/recipes-devtools/klibc/klibc.inc index 62bf1e737..665412349 100644 --- a/meta-oe/recipes-devtools/klibc/klibc.inc +++ b/meta-oe/recipes-devtools/klibc/klibc.inc | |||
@@ -12,7 +12,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
12 | # debugsources.list: No such file or directory: | 12 | # debugsources.list: No such file or directory: |
13 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 13 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
14 | 14 | ||
15 | INC_PR = "r0" | 15 | INC_PR = "r1" |
16 | 16 | ||
17 | KLIBC_ARCH = '${TARGET_ARCH}' | 17 | KLIBC_ARCH = '${TARGET_ARCH}' |
18 | KLIBC_ARCH_armeb = 'arm' | 18 | KLIBC_ARCH_armeb = 'arm' |
@@ -33,7 +33,6 @@ SRC_URI += "file://fstype-sane-vfat-and-jffs2-for-1.5.patch \ | |||
33 | file://modprobe.patch \ | 33 | file://modprobe.patch \ |
34 | file://dash_readopt.patch \ | 34 | file://dash_readopt.patch \ |
35 | file://wc.patch \ | 35 | file://wc.patch \ |
36 | file://no_strip.patch \ | ||
37 | file://staging.patch \ | 36 | file://staging.patch \ |
38 | file://socket.h.patch \ | 37 | file://socket.h.patch \ |
39 | " | 38 | " |
diff --git a/meta-oe/recipes-devtools/klibc/klibc_1.5.24.bb b/meta-oe/recipes-devtools/klibc/klibc_1.5.24.bb index 124a416d3..a313bfd77 100644 --- a/meta-oe/recipes-devtools/klibc/klibc_1.5.24.bb +++ b/meta-oe/recipes-devtools/klibc/klibc_1.5.24.bb | |||
@@ -15,11 +15,6 @@ do_install() { | |||
15 | find ${D}${base_libdir}/klibc/include -name '.install' -delete | 15 | find ${D}${base_libdir}/klibc/include -name '.install' -delete |
16 | find ${D}${base_libdir}/klibc/include -name '..install.cmd' -delete | 16 | find ${D}${base_libdir}/klibc/include -name '..install.cmd' -delete |
17 | 17 | ||
18 | # only for sh.shared and kinit.shared | ||
19 | install -d ${D}${base_bindir} | ||
20 | install -m 755 usr/dash/sh.shared ${D}${base_bindir}/sh.shared | ||
21 | install -m 755 usr/kinit/kinit.shared ${D}${base_bindir}/kinit.shared | ||
22 | |||
23 | install -d ${D}${base_libdir} | 18 | install -d ${D}${base_libdir} |
24 | install -m 755 usr/klibc/klibc-*.so ${D}${base_libdir} | 19 | install -m 755 usr/klibc/klibc-*.so ${D}${base_libdir} |
25 | (cd ${D}${base_libdir}; ln -s klibc-*.so klibc.so) | 20 | (cd ${D}${base_libdir}; ln -s klibc-*.so klibc.so) |
@@ -35,6 +30,6 @@ FILES_libklibc-dev = "${base_libdir}/klibc.so \ | |||
35 | # see above | 30 | # see above |
36 | # do not package it in -dev | 31 | # do not package it in -dev |
37 | # ${base_bindir}/klcc \ | 32 | # ${base_bindir}/klcc \ |
38 | require klibc-utils.inc | 33 | |
39 | require klibc.inc | 34 | require klibc.inc |
40 | require klibc-checksums_${PV}.inc | 35 | require klibc-checksums_${PV}.inc |