diff options
author | Jonathan Liu <net147@gmail.com> | 2014-02-11 18:19:04 +1100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-02-21 17:06:59 +0100 |
commit | 34ff6c265a84295a487ead7aa7f858434e703346 (patch) | |
tree | a738e33e82408502bf8d3245fcec39439fdf234c /meta-oe | |
parent | 90045a49e50eb0177a8aee5cc318caf037ac603d (diff) | |
download | meta-openembedded-34ff6c265a84295a487ead7aa7f858434e703346.tar.gz |
xf86-input-tslib: fix crash with xserver 1.12 and later
Signed-off-by: Jonathan Liu <net147@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb | 1 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch new file mode 100644 index 000000000..d16b4a53c --- /dev/null +++ b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Fixes crash when a touchscreen event is received with xserver 1.12 and later: | ||
2 | X: symbol lookup error: /usr/lib/xorg/modules/input/tslib_drv.so: undefined symbol: xf86XInputSetScreen | ||
3 | |||
4 | Upstream-Status: Pending | ||
5 | |||
6 | Taken from Gentoo: | ||
7 | https://bugs.gentoo.org/show_bug.cgi?id=446432 | ||
8 | |||
9 | diff -ur xf86-input-tslib-0.0.6.orig/src/tslib.c xf86-input-tslib-0.0.6/src/tslib.c | ||
10 | --- xf86-input-tslib-0.0.6.orig/src/tslib.c 2012-12-05 01:12:16.286597071 +0100 | ||
11 | +++ xf86-input-tslib-0.0.6/src/tslib.c 2012-12-05 01:11:02.686598595 +0100 | ||
12 | @@ -75,6 +75,19 @@ | ||
13 | #define COLLECT_INPUT_OPTIONS(pInfo, options) xf86CollectInputOptions((pInfo), (options)) | ||
14 | #endif | ||
15 | |||
16 | +#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) > 13 | ||
17 | +static void | ||
18 | +xf86XInputSetScreen(InputInfoPtr pInfo, | ||
19 | + int screen_number, | ||
20 | + int x, | ||
21 | + int y) | ||
22 | +{ | ||
23 | + if (miPointerGetScreen(pInfo->dev) != | ||
24 | + screenInfo.screens[screen_number]) { | ||
25 | + miPointerSetScreen(pInfo->dev, screen_number, x, y); | ||
26 | + } | ||
27 | +} | ||
28 | +#endif | ||
29 | |||
30 | enum { TSLIB_ROTATE_NONE=0, TSLIB_ROTATE_CW=270, TSLIB_ROTATE_UD=180, TSLIB_ROTATE_CCW=90 }; | ||
31 | |||
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb index fab7fab1f..acc7528d6 100644 --- a/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb +++ b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb | |||
@@ -16,6 +16,7 @@ SRC_URI = "http://www.pengutronix.de/software/xf86-input-tslib/download/xf86-inp | |||
16 | file://xserver-174-XGetPointerControl.patch \ | 16 | file://xserver-174-XGetPointerControl.patch \ |
17 | file://99-xf86-input-tslib.rules \ | 17 | file://99-xf86-input-tslib.rules \ |
18 | file://xf86-input-tslib-port-ABI-12-r48.patch \ | 18 | file://xf86-input-tslib-port-ABI-12-r48.patch \ |
19 | file://xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch \ | ||
19 | " | 20 | " |
20 | 21 | ||
21 | SRC_URI[md5sum] = "b7a4d2f11637ee3fcf432e044b1d017f" | 22 | SRC_URI[md5sum] = "b7a4d2f11637ee3fcf432e044b1d017f" |