summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-15 07:14:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-19 19:29:37 +0200
commit1565dc6af60a671786dfb6604df4c9975cc74fb6 (patch)
treeebb98c0692ab92cde4173f8d0d023f0c4380547a /meta-oe/recipes-test
parenta3bd8e6b3d664d050fe7590869d108002973ad7a (diff)
downloadmeta-openembedded-1565dc6af60a671786dfb6604df4c9975cc74fb6.tar.gz
fwts: Bump SRCREV to latest past 17.03.00 release
Helps fixing build issues with gcc7 Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Koen Kooi <koen.kooi@linaro.org> Acked-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch37
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch48
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0002-Add-C99-defined-format-for-printing-uint64_t.patch53
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch33
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0003-Undefine-PAGE_SIZE.patch30
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch76
-rw-r--r--meta-oe/recipes-test/fwts/fwts_git.bb12
7 files changed, 287 insertions, 2 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch b/meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch
new file mode 100644
index 000000000..192e05f1c
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch
@@ -0,0 +1,37 @@
1From 232daf5fca6fb52cced5e810f2601fe1a71b96d8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 8 Jun 2017 16:49:50 -0700
4Subject: [PATCH 1/3] Add correct printf qualifier for off_t
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 src/bios/ebda_region/ebda_region.c | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11Index: git/src/bios/ebda_region/ebda_region.c
12===================================================================
13--- git.orig/src/bios/ebda_region/ebda_region.c
14+++ git/src/bios/ebda_region/ebda_region.c
15@@ -83,9 +83,9 @@ static int ebda_test1(fwts_framework *fw
16 if ((entry != NULL) &&
17 (entry->type == FWTS_MEMORY_MAP_RESERVED ||
18 entry->type == FWTS_MEMORY_MAP_ACPI)) {
19- fwts_passed(fw, "EBDA region mapped at 0x%lx and reserved as a %" PRId64
20+ fwts_passed(fw, "EBDA region mapped at 0x%jdx and reserved as a %" PRId64
21 "K region in the %s table at 0x%" PRIx64 "..0x%" PRIx64 ".",
22- ebda_addr,
23+ (intmax_t)ebda_addr,
24 (entry->end_address - entry->start_address) / 1024,
25 memory_map_name,
26 entry->start_address,
27@@ -93,8 +93,8 @@ static int ebda_test1(fwts_framework *fw
28 } else
29 fwts_failed(fw, LOG_LEVEL_MEDIUM,
30 "EBDAMappedNotReserved",
31- "EBDA region mapped at 0x%lx but not reserved in the %s table.",
32- ebda_addr, memory_map_name);
33+ "EBDA region mapped at 0x%jdx but not reserved in the %s table.",
34+ (intmax_t)ebda_addr, memory_map_name);
35
36 return FWTS_OK;
37 }
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch b/meta-oe/recipes-test/fwts/fwts/0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch
new file mode 100644
index 000000000..8ad078936
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch
@@ -0,0 +1,48 @@
1From 100a107a53d5dc9b0554252ac5dbf2c9330615e9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 6 Jun 2017 07:25:09 -0700
4Subject: [PATCH 1/3] Include poll.h instead of deprecated sys/poll.h
5
6Upstream-Status: Pending
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 src/lib/src/fwts_ipmi.c | 3 ++-
11 src/lib/src/fwts_pipeio.c | 2 +-
12 2 files changed, 3 insertions(+), 2 deletions(-)
13
14diff --git a/src/lib/src/fwts_ipmi.c b/src/lib/src/fwts_ipmi.c
15index cbb27611..70d11cfa 100644
16--- a/src/lib/src/fwts_ipmi.c
17+++ b/src/lib/src/fwts_ipmi.c
18@@ -18,10 +18,11 @@
19 *
20 */
21
22+#include <poll.h>
23+
24 #include <sys/types.h>
25 #include <sys/stat.h>
26 #include <fcntl.h>
27-#include <sys/poll.h>
28 #include <sys/ioctl.h>
29 #include <linux/ipmi.h>
30
31diff --git a/src/lib/src/fwts_pipeio.c b/src/lib/src/fwts_pipeio.c
32index fd719640..bdc5b2ea 100644
33--- a/src/lib/src/fwts_pipeio.c
34+++ b/src/lib/src/fwts_pipeio.c
35@@ -30,9 +30,9 @@
36 #include <stdlib.h>
37 #include <string.h>
38 #include <paths.h>
39+#include <poll.h>
40
41 #include <sys/param.h>
42-#include <sys/poll.h>
43 #include <sys/types.h>
44 #include <sys/wait.h>
45 #include <errno.h>
46--
472.13.0
48
diff --git a/meta-oe/recipes-test/fwts/fwts/0002-Add-C99-defined-format-for-printing-uint64_t.patch b/meta-oe/recipes-test/fwts/fwts/0002-Add-C99-defined-format-for-printing-uint64_t.patch
new file mode 100644
index 000000000..35ce883a2
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0002-Add-C99-defined-format-for-printing-uint64_t.patch
@@ -0,0 +1,53 @@
1From 25f18b9ac37960dc12a3b648a5c866bd56ef2cbe Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 8 Jun 2017 16:50:23 -0700
4Subject: [PATCH 2/3] Add C99 defined format for printing uint64_t
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 src/opal/reserv_mem.c | 8 ++++----
9 1 file changed, 4 insertions(+), 4 deletions(-)
10
11diff --git a/src/opal/reserv_mem.c b/src/opal/reserv_mem.c
12index eeec2947..f0672e05 100644
13--- a/src/opal/reserv_mem.c
14+++ b/src/opal/reserv_mem.c
15@@ -185,7 +185,7 @@ static int reserv_mem_limits_test(fwts_framework *fw)
16 regions[j].start = (uint64_t)be64toh(ranges[2 * j]);
17 regions[j].len = (uint64_t)be64toh(ranges[2 * j + 1]);
18 fwts_log_info(fw, "Region name %80s"
19- " start: 0x%08lx, len: 0x%08lx\n",
20+ " start: 0x%08" PRIx64 ", len: 0x%08" PRIx64 "\n",
21 regions[j].name, regions[j].start, regions[j].len);
22 }
23
24@@ -248,7 +248,7 @@ static int reserv_mem_limits_test(fwts_framework *fw)
25 fwts_failed(fw, LOG_LEVEL_MEDIUM,
26 "ImageSizeMismatch",
27 "Mismatch in homer-image size, "
28- "expected: 0x%lx, actual: 0x%lx",
29+ "expected: 0x%" PRIx64 ", actual: 0x%" PRIx64 "",
30 configstruct.homer, regions[j].len);
31 ok = false;
32 } else
33@@ -261,7 +261,7 @@ static int reserv_mem_limits_test(fwts_framework *fw)
34 fwts_failed(fw, LOG_LEVEL_MEDIUM,
35 "ImageSizeMismatch",
36 "Mismatch in slw-image size, "
37- "expected: 0x%lx, actual: 0x%lx",
38+ "expected: 0x%" PRIx64 ", actual: 0x%" PRIx64 "",
39 configstruct.slw, regions[j].len);
40 ok = false;
41 } else
42@@ -274,7 +274,7 @@ static int reserv_mem_limits_test(fwts_framework *fw)
43 fwts_failed(fw, LOG_LEVEL_MEDIUM,
44 "ImageSizeMismatch",
45 "Mismatch in occ-common-area size, "
46- "expected: 0x%lx, actual: 0x%lx",
47+ "expected: 0x%" PRIx64", actual: 0x%" PRIx64"",
48 configstruct.occ_common,
49 regions[j].len);
50 ok = false;
51--
522.13.1
53
diff --git a/meta-oe/recipes-test/fwts/fwts/0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch b/meta-oe/recipes-test/fwts/fwts/0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch
new file mode 100644
index 000000000..3b83ca57c
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch
@@ -0,0 +1,33 @@
1From 0e89127cd02ecd5ea4506b935cb2b59eb94107d2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 6 Jun 2017 07:37:20 -0700
4Subject: [PATCH 2/3] Define __SWORD_TYPE if not defined by libc
5
6__SWORD_TYPE is internal to glibc, therefore
7check and define it if needed e.g. on musl
8
9Upstream-Status: Pending
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/lib/src/fwts_uefi.c | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/src/lib/src/fwts_uefi.c b/src/lib/src/fwts_uefi.c
17index 1f9d31fa..2d925f8d 100644
18--- a/src/lib/src/fwts_uefi.c
19+++ b/src/lib/src/fwts_uefi.c
20@@ -59,6 +59,10 @@ typedef struct {
21 #define UEFI_IFACE_SYSFS (2) /* sysfs */
22 #define UEFI_IFACE_EFIVARS (3) /* efivar fs */
23
24+#ifndef __SWORD_TYPE
25+typedef __typeof__( ((struct statfs *)0)->f_type ) __SWORD_TYPE;
26+#endif
27+
28 /* File system magic numbers */
29 #define PSTOREFS_MAGIC ((__SWORD_TYPE)0x6165676C)
30 #define EFIVARFS_MAGIC ((__SWORD_TYPE)0xde5e81e4)
31--
322.13.0
33
diff --git a/meta-oe/recipes-test/fwts/fwts/0003-Undefine-PAGE_SIZE.patch b/meta-oe/recipes-test/fwts/fwts/0003-Undefine-PAGE_SIZE.patch
new file mode 100644
index 000000000..f84fbffd8
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0003-Undefine-PAGE_SIZE.patch
@@ -0,0 +1,30 @@
1From 0857269d5a053b5b4c31cfa01b6501526b24035f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 6 Jun 2017 07:39:28 -0700
4Subject: [PATCH 3/3] Undefine PAGE_SIZE
5
6musl defines PAGE_SIZE and build complains
7of multiple definitions
8
9Upstream-Status: Pending
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/lib/src/fwts_acpi_tables.c | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c
17index 1d4fc705..71023ad2 100644
18--- a/src/lib/src/fwts_acpi_tables.c
19+++ b/src/lib/src/fwts_acpi_tables.c
20@@ -42,6 +42,7 @@
21 #define BIOS_START (0x000e0000) /* Start of BIOS memory */
22 #define BIOS_END (0x000fffff) /* End of BIOS memory */
23 #define BIOS_LENGTH (BIOS_END - BIOS_START) /* Length of BIOS memory */
24+#undef PAGE_SIZE
25 #define PAGE_SIZE (4096)
26
27 static fwts_acpi_table_info tables[ACPI_MAX_TABLES];
28--
292.13.0
30
diff --git a/meta-oe/recipes-test/fwts/fwts/0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch b/meta-oe/recipes-test/fwts/fwts/0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch
new file mode 100644
index 000000000..3cd3fbbc1
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch
@@ -0,0 +1,76 @@
1From d0d76820efe51dd404d381fc4c46544008e757dd Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 8 Jun 2017 16:50:59 -0700
4Subject: [PATCH 3/3] use intptr_t to fix pointer-to-int-cast issues
5
6uintptr_t is guaranteed to be wide enough that
7converting a void* to uintptr_t and back again
8will yield the original pointer value
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 src/lib/src/fwts_acpi_tables.c | 4 ++--
13 src/lib/src/fwts_mmap.c | 2 +-
14 src/lib/src/fwts_smbios.c | 4 ++--
15 3 files changed, 5 insertions(+), 5 deletions(-)
16
17diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c
18index 832f8d66..d0006529 100644
19--- a/src/lib/src/fwts_acpi_tables.c
20+++ b/src/lib/src/fwts_acpi_tables.c
21@@ -150,7 +150,7 @@ static fwts_acpi_table_rsdp *fwts_acpi_get_rsdp(fwts_framework *fw, void *addr,
22 fwts_acpi_table_rsdp *rsdp = NULL;
23 *rsdp_len = 0;
24
25- if ((mem = fwts_mmap((off_t)addr, sizeof(fwts_acpi_table_rsdp))) == FWTS_MAP_FAILED)
26+ if ((mem = fwts_mmap((uintptr_t)addr, sizeof(fwts_acpi_table_rsdp))) == FWTS_MAP_FAILED)
27 return NULL;
28
29 if (fwts_safe_memread(mem, sizeof(fwts_acpi_table_rsdp)) != FWTS_OK) {
30@@ -456,7 +456,7 @@ static int fwts_acpi_load_tables_from_firmware(fwts_framework *fw)
31 if ((rsdp = fwts_acpi_get_rsdp(fw, rsdp_addr, &rsdp_len)) == NULL)
32 return FWTS_ERROR;
33
34- fwts_acpi_add_table("RSDP", rsdp, (uint64_t)(off_t)rsdp_addr, rsdp_len, FWTS_ACPI_TABLE_FROM_FIRMWARE);
35+ fwts_acpi_add_table("RSDP", rsdp, (uint64_t)(uintptr_t)rsdp_addr, rsdp_len, FWTS_ACPI_TABLE_FROM_FIRMWARE);
36
37 /* Load any tables from XSDT if it's valid */
38 if (rsdp->xsdt_address) {
39diff --git a/src/lib/src/fwts_mmap.c b/src/lib/src/fwts_mmap.c
40index a09f688e..9fe6329a 100644
41--- a/src/lib/src/fwts_mmap.c
42+++ b/src/lib/src/fwts_mmap.c
43@@ -81,7 +81,7 @@ int fwts_munmap(void *mem, const size_t size)
44 off_t offset;
45
46 page_size = fwts_page_size();
47- offset = ((off_t)(mem)) & (page_size - 1);
48+ offset = ((uintptr_t)(mem)) & (page_size - 1);
49
50 if (munmap((void *)((uint8_t *)mem - offset), size + offset) < 0)
51 return FWTS_ERROR;
52diff --git a/src/lib/src/fwts_smbios.c b/src/lib/src/fwts_smbios.c
53index 8d0ea39b..63b4bf25 100644
54--- a/src/lib/src/fwts_smbios.c
55+++ b/src/lib/src/fwts_smbios.c
56@@ -54,7 +54,7 @@ static void *fwts_smbios_find_entry_uefi(fwts_framework *fw, fwts_smbios_entry *
57 if ((addr = fwts_scan_efi_systab("SMBIOS")) != NULL) {
58 fwts_smbios_entry *mapped_entry;
59
60- if ((mapped_entry = fwts_mmap((off_t)addr, sizeof(fwts_smbios_entry))) != FWTS_MAP_FAILED) {
61+ if ((mapped_entry = fwts_mmap((uintptr_t)addr, sizeof(fwts_smbios_entry))) != FWTS_MAP_FAILED) {
62 *entry = *mapped_entry;
63 (void)fwts_munmap(mapped_entry, sizeof(fwts_smbios_entry));
64 *type = FWTS_SMBIOS;
65@@ -84,7 +84,7 @@ static void *fwts_smbios30_find_entry_uefi(fwts_framework *fw, fwts_smbios30_ent
66 if ((addr = fwts_scan_efi_systab("SMBIOS3")) != NULL) {
67 fwts_smbios30_entry *mapped_entry;
68
69- if ((mapped_entry = fwts_mmap((off_t)addr, sizeof(fwts_smbios30_entry))) != FWTS_MAP_FAILED) {
70+ if ((mapped_entry = fwts_mmap((uintptr_t)addr, sizeof(fwts_smbios30_entry))) != FWTS_MAP_FAILED) {
71 *entry = *mapped_entry;
72 (void)fwts_munmap(mapped_entry, sizeof(fwts_smbios30_entry));
73 return addr;
74--
752.13.1
76
diff --git a/meta-oe/recipes-test/fwts/fwts_git.bb b/meta-oe/recipes-test/fwts/fwts_git.bb
index 4c4ae66d6..87a23af19 100644
--- a/meta-oe/recipes-test/fwts/fwts_git.bb
+++ b/meta-oe/recipes-test/fwts/fwts_git.bb
@@ -5,11 +5,17 @@ HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
5LICENSE = "GPLv2+" 5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519" 6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
7 7
8PV = "17.03.00" 8PV = "17.03.00+git${SRCPV}"
9 9
10SRCREV = "e3e9d1442b4cc70f5b30199f584cec8e25aeaad4" 10SRCREV = "0153ea51cb648b3067a1b327eee6a075b6cfa330"
11SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \ 11SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \
12 file://0001-ignore-constant-logical-operand-warning-with-clang.patch \ 12 file://0001-ignore-constant-logical-operand-warning-with-clang.patch \
13 file://0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \
14 file://0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
15 file://0003-Undefine-PAGE_SIZE.patch \
16 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
17 file://0002-Add-C99-defined-format-for-printing-uint64_t.patch \
18 file://0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
13 " 19 "
14 20
15S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
@@ -17,10 +23,12 @@ S = "${WORKDIR}/git"
17COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux" 23COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
18 24
19DEPENDS = "libpcre json-c glib-2.0 dtc" 25DEPENDS = "libpcre json-c glib-2.0 dtc"
26DEPENDS_append_libc-musl = " libexecinfo"
20 27
21inherit autotools pkgconfig 28inherit autotools pkgconfig
22 29
23CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas" 30CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas"
31LDFLAGS_append_libc-musl = " -lexecinfo"
24 32
25FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}" 33FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
26FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la" 34FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"