summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-03 02:58:38 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:24:01 +0100
commit2b9328074d4cd8cb5032f8aadac81c3c84847c9d (patch)
tree717e55b90ad1544df7a766dda8ebe7cb59244d00 /meta-oe/recipes-test
parent53a6b833df210aff4319dbbfcf8b6516d5a4301b (diff)
downloadmeta-openembedded-2b9328074d4cd8cb5032f8aadac81c3c84847c9d.tar.gz
fwts: Update to 16.09 release
license change is just year change from 2014 to 2016 Fix build with clang while here Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch81
-rw-r--r--meta-oe/recipes-test/fwts/fwts_git.bb21
2 files changed, 95 insertions, 7 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch b/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch
new file mode 100644
index 000000000..ccfe580c1
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch
@@ -0,0 +1,81 @@
1From 953cff93c85d3cfd5cbcac56e14443dc5f6e5fbd Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 19 Oct 2016 01:57:16 +0000
4Subject: [PATCH] ignore constant-logical-operand warning with clang
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 src/uefi/uefirtauthvar/uefirtauthvar.c | 5 +++++
9 1 file changed, 5 insertions(+)
10
11Index: git/src/uefi/uefirtauthvar/uefirtauthvar.c
12===================================================================
13--- git.orig/src/uefi/uefirtauthvar/uefirtauthvar.c
14+++ git/src/uefi/uefirtauthvar/uefirtauthvar.c
15@@ -142,6 +142,9 @@ static int uefirtauthvar_deinit(fwts_fra
16 return FWTS_OK;
17 }
18
19+#pragma clang diagnostic push
20+#pragma clang diagnostic ignored "-Wconstant-logical-operand"
21+
22 static int check_fw_support(fwts_framework *fw, uint64_t status)
23 {
24 if ((status == EFI_INVALID_PARAMETER) &&
25@@ -172,6 +175,8 @@ static int check_fw_support(fwts_framewo
26 return FWTS_OK;
27 }
28
29+#pragma clang diagnostic pop
30+
31 /*
32 * Set the created authenticated variable, AuthVarCreate,
33 * and checking the data size and data.
34Index: git/src/lib/src/fwts_acpi_tables.c
35===================================================================
36--- git.orig/src/lib/src/fwts_acpi_tables.c
37+++ git/src/lib/src/fwts_acpi_tables.c
38@@ -392,10 +392,14 @@ static int fwts_acpi_handle_fadt(
39 /* Determine FACS addr and load it.
40 * Will ignore the missing FACS in the hardware-reduced mode.
41 */
42+#pragma clang diagnostic push
43+#pragma clang diagnostic ignored "-Waddress-of-packed-member"
44+
45 result = fwts_acpi_handle_fadt_tables(fw, fadt,
46 "FACS", "FIRMWARE_CTRL", "X_FIRMWARE_CTRL",
47 &fadt->firmware_control, &fadt->x_firmware_ctrl,
48 provenance);
49+
50 if (result != FWTS_OK) {
51 if ((result == FWTS_NULL_POINTER) &&
52 fwts_acpi_is_reduced_hardware(fadt)) {
53@@ -414,6 +418,7 @@ static int fwts_acpi_handle_fadt(
54 return FWTS_ERROR;
55 }
56 return FWTS_OK;
57+#pragma clang diagnostic pop
58 }
59
60 /*
61Index: git/src/dmi/dmicheck/dmicheck.c
62===================================================================
63--- git.orig/src/dmi/dmicheck/dmicheck.c
64+++ git/src/dmi/dmicheck/dmicheck.c
65@@ -209,6 +209,8 @@ static const char *uuid_patterns[] = {
66 "0A0A0A0A-0A0A-0A0A-0A0A-0A0A0A0A0A0A",
67 NULL,
68 };
69+#pragma clang diagnostic push
70+#pragma clang diagnostic ignored "-Wunneeded-internal-declaration"
71
72 static const fwts_chassis_type_map fwts_dmi_chassis_type[] = {
73 { "Invalid", FWTS_SMBIOS_CHASSIS_INVALID },
74@@ -245,6 +247,7 @@ static const fwts_chassis_type_map fwts_
75 { "Convertible", FWTS_SMBIOS_CHASSIS_CONVERTIBLE },
76 { "Detachable", FWTS_SMBIOS_CHASSIS_DETACHABLE },
77 };
78+#pragma clang diagnostic pop
79
80 /* Remapping table from buggy version numbers to correct values */
81 static const fwts_dmi_version dmi_versions[] = {
diff --git a/meta-oe/recipes-test/fwts/fwts_git.bb b/meta-oe/recipes-test/fwts/fwts_git.bb
index 197fe2034..b04be021b 100644
--- a/meta-oe/recipes-test/fwts/fwts_git.bb
+++ b/meta-oe/recipes-test/fwts/fwts_git.bb
@@ -3,22 +3,29 @@ DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts" 3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4 4
5LICENSE = "GPLv2+" 5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=deb8af5388e838d133eaa036f4d1496f" 6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
7 7
8PV = "14.12.00" 8PV = "16.09.00"
9 9
10SRCREV = "efc18d16294f492b7f72bba64344b2eed50e6a69" 10SRCREV = "15386283ad55e2a5b9366c1f43f4531ef79b01cb"
11SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git" 11SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \
12 file://0001-ignore-constant-logical-operand-warning-with-clang.patch \
13 "
12 14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16
15DEPENDS = "libpcre json-c glib-2.0" 17COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
16 18
17inherit autotools-brokensep 19DEPENDS = "libpcre json-c glib-2.0 dtc"
18 20
19CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=misleading-indentation" 21inherit autotools pkgconfig
22
23CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas"
20 24
21FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}" 25FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
22FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la" 26FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
23FILES_${PN}-staticdev += "${libdir}/fwts/lib*a" 27FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
24FILES_${PN}-dbg += "${libdir}/fwts/.debug" 28FILES_${PN}-dbg += "${libdir}/fwts/.debug"
29
30TOOLCHAIN = "gcc"
31