summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-07-24 10:53:06 +0200
committerKhem Raj <raj.khem@gmail.com>2019-07-26 14:29:17 -0700
commitaa98f9eb73f801401ef8e138017266edc60cc13e (patch)
tree9db68329af3b2058b4d3ecbdec1132788a0c4ff2 /meta-oe/recipes-test
parente018a9a95498ccae04f7b85b9ec31cb3480bb87c (diff)
downloadmeta-openembedded-aa98f9eb73f801401ef8e138017266edc60cc13e.tar.gz
bats: new package
This adds a recipe for the bats package. Bats is a TAP-compliant testing framework for Bash. The recipe is very simple - it just installs a bunch of bash scripts. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/bats/bats_1.1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/bats/bats_1.1.0.bb b/meta-oe/recipes-test/bats/bats_1.1.0.bb
new file mode 100644
index 000000000..a8179744a
--- /dev/null
+++ b/meta-oe/recipes-test/bats/bats_1.1.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4AUTHOR = "Sam Stephenson & bats-core organization"
5HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8
9SRC_URI = "git://github.com/bats-core/bats-core.git \
10 "
11# v1.1.0
12SRCREV = "c706d1470dd1376687776bbe985ac22d09780327"
13
14S = "${WORKDIR}/git"
15
16do_install() {
17 # Just a bunch of bash scripts to install
18 ${S}/install.sh ${D}${prefix}
19}
20
21RDEPENDS_bats = "bash"