summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-12 13:03:01 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-13 09:27:22 -0800
commit7b01edd129ab2eb30c53a8dd458253d2f7ff1f59 (patch)
tree8f5f70ec7651de502d5c7935c86024e0e2b7a6f5 /meta-oe/recipes-test
parente4c5c0da6bf3f0d8a171e8361e83c49760108277 (diff)
downloadmeta-openembedded-7b01edd129ab2eb30c53a8dd458253d2f7ff1f59.tar.gz
catch2: Upgrade to 2.6.1
Fix build with clang Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/catch2/catch2_2.6.1.bb (renamed from meta-oe/recipes-test/catch2/catch2_2.6.0.bb)5
-rw-r--r--meta-oe/recipes-test/catch2/files/0001-Fix-Wdefaulted-function-deleted-warning.patch35
2 files changed, 38 insertions, 2 deletions
diff --git a/meta-oe/recipes-test/catch2/catch2_2.6.0.bb b/meta-oe/recipes-test/catch2/catch2_2.6.1.bb
index 13beb9e8b..08d661640 100644
--- a/meta-oe/recipes-test/catch2/catch2_2.6.0.bb
+++ b/meta-oe/recipes-test/catch2/catch2_2.6.1.bb
@@ -6,9 +6,10 @@ LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" 6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
7 7
8SRC_URI = "git://github.com/catchorg/Catch2.git \ 8SRC_URI = "git://github.com/catchorg/Catch2.git \
9 file://0001-Fix-Wdefaulted-function-deleted-warning.patch \
9 " 10 "
10# v2.6.0 11# v2.6.1
11SRCREV = "d75e9b3c0f24fe42553131873459611ed155e297" 12SRCREV = "dbbab8727c342733f75045483048cdcb52421e32"
12 13
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
14 15
diff --git a/meta-oe/recipes-test/catch2/files/0001-Fix-Wdefaulted-function-deleted-warning.patch b/meta-oe/recipes-test/catch2/files/0001-Fix-Wdefaulted-function-deleted-warning.patch
new file mode 100644
index 000000000..555c71ad2
--- /dev/null
+++ b/meta-oe/recipes-test/catch2/files/0001-Fix-Wdefaulted-function-deleted-warning.patch
@@ -0,0 +1,35 @@
1From a39e0eaa8318335260967ffd1d16388eb5a1d6d8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 12 Feb 2019 12:57:00 -0800
4Subject: [PATCH] Fix -Wdefaulted-function-deleted warning
5
6Clang8 warns
7
8catch_interfaces_reporter.h:84:25: error: explicitly defaulted move assignment operator is implicitly deleted [-Werror,-Wdefaulted-function-deleted]
9| AssertionStats& operator = ( AssertionStats && ) = default;
10| ^
11
12Upstream-Status: Submitted [https://github.com/catchorg/Catch2/pull/1537]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 include/internal/catch_interfaces_reporter.h | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/include/internal/catch_interfaces_reporter.h b/include/internal/catch_interfaces_reporter.h
19index 9d99c981..e5fbf8bb 100644
20--- a/include/internal/catch_interfaces_reporter.h
21+++ b/include/internal/catch_interfaces_reporter.h
22@@ -80,8 +80,8 @@ namespace Catch {
23
24 AssertionStats( AssertionStats const& ) = default;
25 AssertionStats( AssertionStats && ) = default;
26- AssertionStats& operator = ( AssertionStats const& ) = default;
27- AssertionStats& operator = ( AssertionStats && ) = default;
28+ AssertionStats& operator = ( AssertionStats const& ) = delete;
29+ AssertionStats& operator = ( AssertionStats && ) = delete;
30 virtual ~AssertionStats();
31
32 AssertionResult assertionResult;
33--
342.20.1
35