diff options
author | Fathi Boudra <fathi.boudra@linaro.org> | 2016-12-22 08:19:30 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-26 08:24:56 +0100 |
commit | 7787c56382818f25a079eb9c6a8d7839424b5afc (patch) | |
tree | 8fd74485b21e9c3f988bc72ef77b44733e4fdf23 /meta-oe/recipes-test | |
parent | 31c93c34aa56bab297257f7b3fab94cc89cbc323 (diff) | |
download | meta-openembedded-7787c56382818f25a079eb9c6a8d7839424b5afc.tar.gz |
fwts: upgrade to 16.12.00 release
* update PV and SRCREV to match 16.12.00 release
* refresh 0001-ignore-constant-logical-operand-warning-with-clang.patch
Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch | 92 | ||||
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts_git.bb | 4 |
2 files changed, 49 insertions, 47 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch b/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch index ccfe580c1..a3cc1ff8e 100644 --- a/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch +++ b/meta-oe/recipes-test/fwts/fwts/0001-ignore-constant-logical-operand-warning-with-clang.patch | |||
@@ -5,37 +5,37 @@ Subject: [PATCH] ignore constant-logical-operand warning with clang | |||
5 | 5 | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
7 | --- | 7 | --- |
8 | src/dmi/dmicheck/dmicheck.c | 3 +++ | ||
9 | src/lib/src/fwts_acpi_tables.c | 5 +++++ | ||
8 | src/uefi/uefirtauthvar/uefirtauthvar.c | 5 +++++ | 10 | src/uefi/uefirtauthvar/uefirtauthvar.c | 5 +++++ |
9 | 1 file changed, 5 insertions(+) | 11 | 3 files changed, 13 insertions(+) |
10 | 12 | ||
11 | Index: git/src/uefi/uefirtauthvar/uefirtauthvar.c | 13 | diff --git a/src/dmi/dmicheck/dmicheck.c b/src/dmi/dmicheck/dmicheck.c |
12 | =================================================================== | 14 | index ecd98223..7fca4a64 100644 |
13 | --- git.orig/src/uefi/uefirtauthvar/uefirtauthvar.c | 15 | --- a/src/dmi/dmicheck/dmicheck.c |
14 | +++ git/src/uefi/uefirtauthvar/uefirtauthvar.c | 16 | +++ b/src/dmi/dmicheck/dmicheck.c |
15 | @@ -142,6 +142,9 @@ static int uefirtauthvar_deinit(fwts_fra | 17 | @@ -209,6 +209,8 @@ static const char *uuid_patterns[] = { |
16 | return FWTS_OK; | 18 | "0A0A0A0A-0A0A-0A0A-0A0A-0A0A0A0A0A0A", |
17 | } | 19 | NULL, |
18 | 20 | }; | |
19 | +#pragma clang diagnostic push | 21 | +#pragma clang diagnostic push |
20 | +#pragma clang diagnostic ignored "-Wconstant-logical-operand" | 22 | +#pragma clang diagnostic ignored "-Wunneeded-internal-declaration" |
21 | + | ||
22 | static int check_fw_support(fwts_framework *fw, uint64_t status) | ||
23 | { | ||
24 | if ((status == EFI_INVALID_PARAMETER) && | ||
25 | @@ -172,6 +175,8 @@ static int check_fw_support(fwts_framewo | ||
26 | return FWTS_OK; | ||
27 | } | ||
28 | 23 | ||
24 | static const fwts_chassis_type_map fwts_dmi_chassis_type[] = { | ||
25 | { "Invalid", FWTS_SMBIOS_CHASSIS_INVALID }, | ||
26 | @@ -245,6 +247,7 @@ static const fwts_chassis_type_map fwts_dmi_chassis_type[] = { | ||
27 | { "Convertible", FWTS_SMBIOS_CHASSIS_CONVERTIBLE }, | ||
28 | { "Detachable", FWTS_SMBIOS_CHASSIS_DETACHABLE }, | ||
29 | }; | ||
29 | +#pragma clang diagnostic pop | 30 | +#pragma clang diagnostic pop |
30 | + | 31 | |
31 | /* | 32 | /* Remapping table from buggy version numbers to correct values */ |
32 | * Set the created authenticated variable, AuthVarCreate, | 33 | static const fwts_dmi_version dmi_versions[] = { |
33 | * and checking the data size and data. | 34 | diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c |
34 | Index: git/src/lib/src/fwts_acpi_tables.c | 35 | index 30b4060e..d5339bf7 100644 |
35 | =================================================================== | 36 | --- a/src/lib/src/fwts_acpi_tables.c |
36 | --- git.orig/src/lib/src/fwts_acpi_tables.c | 37 | +++ b/src/lib/src/fwts_acpi_tables.c |
37 | +++ git/src/lib/src/fwts_acpi_tables.c | 38 | @@ -394,10 +394,14 @@ static int fwts_acpi_handle_fadt( |
38 | @@ -392,10 +392,14 @@ static int fwts_acpi_handle_fadt( | ||
39 | /* Determine FACS addr and load it. | 39 | /* Determine FACS addr and load it. |
40 | * Will ignore the missing FACS in the hardware-reduced mode. | 40 | * Will ignore the missing FACS in the hardware-reduced mode. |
41 | */ | 41 | */ |
@@ -50,7 +50,7 @@ Index: git/src/lib/src/fwts_acpi_tables.c | |||
50 | if (result != FWTS_OK) { | 50 | if (result != FWTS_OK) { |
51 | if ((result == FWTS_NULL_POINTER) && | 51 | if ((result == FWTS_NULL_POINTER) && |
52 | fwts_acpi_is_reduced_hardware(fadt)) { | 52 | fwts_acpi_is_reduced_hardware(fadt)) { |
53 | @@ -414,6 +418,7 @@ static int fwts_acpi_handle_fadt( | 53 | @@ -416,6 +420,7 @@ static int fwts_acpi_handle_fadt( |
54 | return FWTS_ERROR; | 54 | return FWTS_ERROR; |
55 | } | 55 | } |
56 | return FWTS_OK; | 56 | return FWTS_OK; |
@@ -58,24 +58,26 @@ Index: git/src/lib/src/fwts_acpi_tables.c | |||
58 | } | 58 | } |
59 | 59 | ||
60 | /* | 60 | /* |
61 | Index: git/src/dmi/dmicheck/dmicheck.c | 61 | diff --git a/src/uefi/uefirtauthvar/uefirtauthvar.c b/src/uefi/uefirtauthvar/uefirtauthvar.c |
62 | =================================================================== | 62 | index cdfd7aa3..001e8cc8 100644 |
63 | --- git.orig/src/dmi/dmicheck/dmicheck.c | 63 | --- a/src/uefi/uefirtauthvar/uefirtauthvar.c |
64 | +++ git/src/dmi/dmicheck/dmicheck.c | 64 | +++ b/src/uefi/uefirtauthvar/uefirtauthvar.c |
65 | @@ -209,6 +209,8 @@ static const char *uuid_patterns[] = { | 65 | @@ -142,6 +142,9 @@ static int uefirtauthvar_deinit(fwts_framework *fw) |
66 | "0A0A0A0A-0A0A-0A0A-0A0A-0A0A0A0A0A0A", | 66 | return FWTS_OK; |
67 | NULL, | 67 | } |
68 | }; | 68 | |
69 | +#pragma clang diagnostic push | 69 | +#pragma clang diagnostic push |
70 | +#pragma clang diagnostic ignored "-Wunneeded-internal-declaration" | 70 | +#pragma clang diagnostic ignored "-Wconstant-logical-operand" |
71 | + | ||
72 | static int check_fw_support(fwts_framework *fw, uint64_t status) | ||
73 | { | ||
74 | if ((status == EFI_INVALID_PARAMETER) && | ||
75 | @@ -172,6 +175,8 @@ static int check_fw_support(fwts_framework *fw, uint64_t status) | ||
76 | return FWTS_OK; | ||
77 | } | ||
71 | 78 | ||
72 | static const fwts_chassis_type_map fwts_dmi_chassis_type[] = { | ||
73 | { "Invalid", FWTS_SMBIOS_CHASSIS_INVALID }, | ||
74 | @@ -245,6 +247,7 @@ static const fwts_chassis_type_map fwts_ | ||
75 | { "Convertible", FWTS_SMBIOS_CHASSIS_CONVERTIBLE }, | ||
76 | { "Detachable", FWTS_SMBIOS_CHASSIS_DETACHABLE }, | ||
77 | }; | ||
78 | +#pragma clang diagnostic pop | 79 | +#pragma clang diagnostic pop |
79 | 80 | + | |
80 | /* Remapping table from buggy version numbers to correct values */ | 81 | /* |
81 | static const fwts_dmi_version dmi_versions[] = { | 82 | * Set the created authenticated variable, AuthVarCreate, |
83 | * and checking the data size and data. | ||
diff --git a/meta-oe/recipes-test/fwts/fwts_git.bb b/meta-oe/recipes-test/fwts/fwts_git.bb index b04be021b..82ed5ecf0 100644 --- a/meta-oe/recipes-test/fwts/fwts_git.bb +++ b/meta-oe/recipes-test/fwts/fwts_git.bb | |||
@@ -5,9 +5,9 @@ HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts" | |||
5 | LICENSE = "GPLv2+" | 5 | LICENSE = "GPLv2+" |
6 | LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519" | 6 | LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519" |
7 | 7 | ||
8 | PV = "16.09.00" | 8 | PV = "16.12.00" |
9 | 9 | ||
10 | SRCREV = "15386283ad55e2a5b9366c1f43f4531ef79b01cb" | 10 | SRCREV = "d38fced7db86e5483d5c2e634ee1eec98620d5b8" |
11 | SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \ | 11 | SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \ |
12 | file://0001-ignore-constant-logical-operand-warning-with-clang.patch \ | 12 | file://0001-ignore-constant-logical-operand-warning-with-clang.patch \ |
13 | " | 13 | " |