summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-30 12:07:32 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-01 11:24:26 -0800
commit64f07ba8528cda14ad552e492dfd2e7f054fbb08 (patch)
tree3f53da02b5bbacac96735e64b89212208fad63a8 /meta-oe/recipes-test
parentaa86b55286e74e5a6d779a14c526561a091cd21e (diff)
downloadmeta-openembedded-64f07ba8528cda14ad552e492dfd2e7f054fbb08.tar.gz
evtest: Fix build for 32bit arches with 64bit time_t
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch41
-rw-r--r--meta-oe/recipes-test/evtest/evtest_1.34.bb6
2 files changed, 45 insertions, 2 deletions
diff --git a/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch b/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
new file mode 100644
index 000000000..706322d56
--- /dev/null
+++ b/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
@@ -0,0 +1,41 @@
1From fa57c78c33d26084f85f1a6b4c29378631dc9395 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 30 Nov 2019 11:58:58 -0800
4Subject: [PATCH] Fix build on 32bit arches with 64bit time_t
5
6time element is deprecated on new input_event structure in kernel's
7input.h [1]
8
9[1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=152194fe9c3f
10
11Upstream-Status: Submitted [https://gitlab.freedesktop.org/libevdev/evtest/merge_requests/6]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 evtest.c | 7 ++++++-
15 1 file changed, 6 insertions(+), 1 deletion(-)
16
17diff --git a/evtest.c b/evtest.c
18index 548c203..93063cd 100644
19--- a/evtest.c
20+++ b/evtest.c
21@@ -61,6 +61,11 @@
22 #include <sys/types.h>
23 #include <unistd.h>
24
25+#ifndef input_event_sec
26+#define input_event_sec time.tv_sec
27+#define input_event_usec time.tv_usec
28+#endif
29+
30 #define BITS_PER_LONG (sizeof(long) * 8)
31 #define NBITS(x) ((((x)-1)/BITS_PER_LONG)+1)
32 #define OFF(x) ((x)%BITS_PER_LONG)
33@@ -1140,7 +1145,7 @@ static int print_events(int fd)
34 type = ev[i].type;
35 code = ev[i].code;
36
37- printf("Event: time %ld.%06ld, ", ev[i].time.tv_sec, ev[i].time.tv_usec);
38+ printf("Event: time %ld.%06ld, ", ev[i].input_event_sec, ev[i].input_event_sec);
39
40 if (type == EV_SYN) {
41 if (code == SYN_MT_REPORT)
diff --git a/meta-oe/recipes-test/evtest/evtest_1.34.bb b/meta-oe/recipes-test/evtest/evtest_1.34.bb
index 3b6dc6140..a3a23c895 100644
--- a/meta-oe/recipes-test/evtest/evtest_1.34.bb
+++ b/meta-oe/recipes-test/evtest/evtest_1.34.bb
@@ -8,8 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "libxml2" 8DEPENDS = "libxml2"
9 9
10SRCREV = "16e5104127a620686bdddc4a9ad62881134d6c69" 10SRCREV = "16e5104127a620686bdddc4a9ad62881134d6c69"
11SRC_URI = "git://anongit.freedesktop.org/evtest;protocol=git \ 11SRC_URI = "git://gitlab.freedesktop.org/libevdev/evtest.git;protocol=https \
12 file://add_missing_limits_h_include.patch" 12 file://add_missing_limits_h_include.patch \
13 file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch \
14 "
13 15
14S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
15 17