summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/googletest/googletest_git.bb
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2019-11-21 13:45:33 +0800
committerKhem Raj <raj.khem@gmail.com>2019-11-21 17:51:37 -0800
commitb4bd6f8213ba381e18819c7c3259a34c62e8c530 (patch)
tree4e94212620d7ad96775c72bc7de94f2133c741c8 /meta-oe/recipes-test/googletest/googletest_git.bb
parent9b1d0f2480d273521a28a81c665704fb34e2869e (diff)
downloadmeta-openembedded-b4bd6f8213ba381e18819c7c3259a34c62e8c530.tar.gz
googletest: move to release 1.10.0
The googletest recipe was using 1.8.1 tag, and in the recipe it was using the git revision instead of the tag release. Rename it to googletest_git.bb and use the 1.10.0 release revision to get the latest release. Signed-off-by: Lei YU <mine260309@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/googletest/googletest_git.bb')
-rw-r--r--meta-oe/recipes-test/googletest/googletest_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/googletest/googletest_git.bb b/meta-oe/recipes-test/googletest/googletest_git.bb
new file mode 100644
index 000000000..e1df9b6e2
--- /dev/null
+++ b/meta-oe/recipes-test/googletest/googletest_git.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Google's framework for writing C++ tests"
2HOMEPAGE = "https://github.com/google/googletest"
3SECTION = "libs"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
6 file://googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
7
8PROVIDES += "gmock gtest"
9
10S = "${WORKDIR}/git"
11SRCREV = "703bd9caab50b139428cea1aaff9974ebee5742e"
12SRC_URI = "git://github.com/google/googletest.git"
13
14inherit cmake
15
16ALLOW_EMPTY_${PN} = "1"
17ALLOW_EMPTY_${PN}-dbg = "1"
18
19RDEPENDS_${PN}-dev += "${PN}-staticdev"
20
21BBCLASSEXTEND = "native nativesdk"