summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-14 11:52:44 +0000
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commite0a506536545e0a97a645093c75f9570d5aa94d4 (patch)
tree133428b8995aed7fe8beca4ed4bfe282908c5f98 /meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
parent3670d61546bfce46f27ce52def370a69eb499f42 (diff)
downloadmeta-openembedded-e0a506536545e0a97a645093c75f9570d5aa94d4.tar.gz
cxxtest: move to setuptools
setup.py has always supported setuptools, so change the inherit now that distutils is deprecated. Leave S as the top of the source tree, and set SETUPUTILS_SETUP_PATH to find the setup.py. Fix the hashbang in cxxtestgen, which was still pointing at python not python3. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb')
-rw-r--r--meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
index b76069065..65b54ed54 100644
--- a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
+++ b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
@@ -2,21 +2,22 @@ DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in sp
2HOMEPAGE = "http://cxxtest.com/" 2HOMEPAGE = "http://cxxtest.com/"
3SECTION = "devel" 3SECTION = "devel"
4LICENSE = "LGPL-2.0" 4LICENSE = "LGPL-2.0"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/cxxtest-${PV}/COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
6 6
7SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/cxxtest-${PV}.tar.gz" 7SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/${BP}.tar.gz"
8SRC_URI[md5sum] = "c3cc3355e2ac64e34c215f28e44cfcec" 8SRC_URI[md5sum] = "c3cc3355e2ac64e34c215f28e44cfcec"
9SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f4895cf7d8" 9SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f4895cf7d8"
10 10
11S = "${WORKDIR}/cxxtest-${PV}/python" 11inherit setuptools3
12 12
13inherit distutils3 13SETUPTOOLS_SETUP_PATH = "${S}/python"
14 14
15do_install:append() { 15do_install:append() {
16 install -d ${D}${includedir} 16 install -d ${D}${includedir}
17 cp -a ../cxxtest ${D}${includedir} 17 cp -a ${S}/cxxtest/ ${D}${includedir}
18 # Fix the interpretter as otherwise this points to the build host python
18 sed '1c\ 19 sed '1c\
19#!/usr/bin/env python' -i ${D}${bindir}/cxxtestgen 20#!/usr/bin/env python3' -i ${D}${bindir}/cxxtestgen
20} 21}
21 22
22BBCLASSEXTEND = "native nativesdk" 23BBCLASSEXTEND = "native nativesdk"