summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/catch2
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-04 21:22:40 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-05 16:43:12 -0800
commit8f6995ddc639a46d825aa0fc294ef589547ca6d3 (patch)
tree44c112ad7cf2d3a0fddd7b8f37ddf79cb2431204 /meta-oe/recipes-test/catch2
parent3a0a0024bf0bcc1ddc6f5a67a0f646258108e6eb (diff)
downloadmeta-openembedded-8f6995ddc639a46d825aa0fc294ef589547ca6d3.tar.gz
catch2: Upgrade to 2.6.0
Drop backported patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/catch2')
-rw-r--r--meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch37
-rw-r--r--meta-oe/recipes-test/catch2/catch2_2.6.0.bb (renamed from meta-oe/recipes-test/catch2/catch2_2.5.0.bb)6
2 files changed, 2 insertions, 41 deletions
diff --git a/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch b/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch
deleted file mode 100644
index dc8a8915e..000000000
--- a/meta-oe/recipes-test/catch2/catch2/0001-Remove-redundant-move.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 7d7428fd09d1bcee281f7b678df8fb71e9365b17 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Martin=20Ho=C5=99e=C5=88ovsk=C3=BD?=
3 <martin.horenovsky@gmail.com>
4Date: Thu, 27 Dec 2018 16:08:04 +0100
5Subject: [PATCH] A different approach
6
7---
8 include/internal/catch_session.cpp | 15 ++++++++++-----
9 1 file changed, 10 insertions(+), 5 deletions(-)
10
11--- a/include/internal/catch_session.cpp
12+++ b/include/internal/catch_session.cpp
13@@ -42,14 +42,20 @@ namespace Catch {
14 return createReporter(config->getReporterName(), config);
15 }
16
17- auto multi = std::unique_ptr<ListeningReporter>(new ListeningReporter);
18+ // On older platforms, returning std::unique_ptr<ListeningReporter>
19+ // when the return type is std::unique_ptr<IStreamingReporter>
20+ // doesn't compile without a std::move call. However, this causes
21+ // a warning on newer platforms. Thus, we have to work around
22+ // it a bit and downcast the pointer manually.
23+ auto ret = std::unique_ptr<IStreamingReporter>(new ListeningReporter);
24+ auto& multi = static_cast<ListeningReporter&>(*ret);
25
26 auto const& listeners = Catch::getRegistryHub().getReporterRegistry().getListeners();
27 for (auto const& listener : listeners) {
28- multi->addListener(listener->create(Catch::ReporterConfig(config)));
29+ multi.addListener(listener->create(Catch::ReporterConfig(config)));
30 }
31- multi->addReporter(createReporter(config->getReporterName(), config));
32- return std::move(multi);
33+ multi.addReporter(createReporter(config->getReporterName(), config));
34+ return ret;
35 }
36
37
diff --git a/meta-oe/recipes-test/catch2/catch2_2.5.0.bb b/meta-oe/recipes-test/catch2/catch2_2.6.0.bb
index 26149b31e..13beb9e8b 100644
--- a/meta-oe/recipes-test/catch2/catch2_2.5.0.bb
+++ b/meta-oe/recipes-test/catch2/catch2_2.6.0.bb
@@ -6,11 +6,9 @@ LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" 6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
7 7
8SRC_URI = "git://github.com/catchorg/Catch2.git \ 8SRC_URI = "git://github.com/catchorg/Catch2.git \
9 file://0001-Remove-redundant-move.patch \
10 " 9 "
11# v2.5.0 10# v2.6.0
12#SRCREV = "6ccd467094973824d89efb16cbc553e279f79823" 11SRCREV = "d75e9b3c0f24fe42553131873459611ed155e297"
13SRCREV = "461843b1f02a4bf5c59db88ff201d2c56fabf3a4"
14 12
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14