diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 13:49:59 +0000 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-28 14:32:06 +0000 |
commit | 3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch) | |
tree | 66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-support | |
parent | d66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff) | |
download | meta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz |
Replace bb.data.* with d.*
Used sed expression given here:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html
Plus an additional expression for .expand. Full expression is:
sed \
-e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
Some minor correction in systemd.bbclass was needed for some expressions
that didn't quite match the regex in the desired way; additionally a few
instances were manually changed.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/fltk/fltk_1.1.10.bb | 4 | ||||
-rw-r--r-- | meta-oe/recipes-support/freerdp/freerdp.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/links/links.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/lzma/lzma.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/nano/nano.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_2.4.bb | 12 | ||||
-rw-r--r-- | meta-oe/recipes-support/openldap/openldap_2.4.23.bb | 16 | ||||
-rw-r--r-- | meta-oe/recipes-support/pidgin/pidgin.inc | 6 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler-fpu.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/vim/vim.inc | 4 |
10 files changed, 26 insertions, 26 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb index 2611b20650..ad8768db5a 100644 --- a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb +++ b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb | |||
@@ -27,8 +27,8 @@ do_configure() { | |||
27 | } | 27 | } |
28 | 28 | ||
29 | python populate_packages_prepend () { | 29 | python populate_packages_prepend () { |
30 | if (bb.data.getVar('DEBIAN_NAMES', d, 1)): | 30 | if (d.getVar('DEBIAN_NAMES', 1)): |
31 | bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d) | 31 | d.setVar('PKG_${PN}', 'libfltk${PV}') |
32 | } | 32 | } |
33 | 33 | ||
34 | LEAD_SONAME = "libfltk.so" | 34 | LEAD_SONAME = "libfltk.so" |
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc index 673b37240a..d898f46836 100644 --- a/meta-oe/recipes-support/freerdp/freerdp.inc +++ b/meta-oe/recipes-support/freerdp/freerdp.inc | |||
@@ -26,7 +26,7 @@ FILES_libfreerdp = "${libdir}/lib*${SOLIBS}" | |||
26 | PACKAGES_DYNAMIC += "^libfreerdp-plugin-.*" | 26 | PACKAGES_DYNAMIC += "^libfreerdp-plugin-.*" |
27 | 27 | ||
28 | python populate_packages_prepend () { | 28 | python populate_packages_prepend () { |
29 | freerdp_root = bb.data.expand('${libdir}/freerdp', d) | 29 | freerdp_root = d.expand('${libdir}/freerdp') |
30 | 30 | ||
31 | do_split_packages(d, freerdp_root, '^(audin_.*)\.so$', | 31 | do_split_packages(d, freerdp_root, '^(audin_.*)\.so$', |
32 | output_pattern='libfreerdp-plugin-%s', | 32 | output_pattern='libfreerdp-plugin-%s', |
diff --git a/meta-oe/recipes-support/links/links.inc b/meta-oe/recipes-support/links/links.inc index 9001d2a3b9..abd10f2ac7 100644 --- a/meta-oe/recipes-support/links/links.inc +++ b/meta-oe/recipes-support/links/links.inc | |||
@@ -6,7 +6,7 @@ LICENSE = "GPLv2" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b0c80473f97008e42e29a9f80fcc55ff" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b0c80473f97008e42e29a9f80fcc55ff" |
7 | DEPENDS = "jpeg libpng flex openssl zlib" | 7 | DEPENDS = "jpeg libpng flex openssl zlib" |
8 | 8 | ||
9 | LPV = "${@bb.data.getVar("PV",d,1).split("+")[1]}" | 9 | LPV = "${@d.getVar("PV",1).split("+")[1]}" |
10 | 10 | ||
11 | SRC_URI = "http://links.twibright.com/download/links-${LPV}.tar.bz2 \ | 11 | SRC_URI = "http://links.twibright.com/download/links-${LPV}.tar.bz2 \ |
12 | file://ac-prog-cxx.patch \ | 12 | file://ac-prog-cxx.patch \ |
diff --git a/meta-oe/recipes-support/lzma/lzma.inc b/meta-oe/recipes-support/lzma/lzma.inc index 457d7f4938..75e6d6780a 100644 --- a/meta-oe/recipes-support/lzma/lzma.inc +++ b/meta-oe/recipes-support/lzma/lzma.inc | |||
@@ -4,7 +4,7 @@ LICENSE = "LGPL" | |||
4 | LIC_FILES_CHKSUM = "file://lzma.txt;md5=20251cdc2e3793cceab11878d0aa11b1" | 4 | LIC_FILES_CHKSUM = "file://lzma.txt;md5=20251cdc2e3793cceab11878d0aa11b1" |
5 | INC_PR = "r7" | 5 | INC_PR = "r7" |
6 | 6 | ||
7 | SRC_URI = "http://downloads.sourceforge.net/sevenzip/lzma${@bb.data.getVar('PV',d,1).replace('.','')}.tar.bz2;subdir=${BPN}-${PV} \ | 7 | SRC_URI = "http://downloads.sourceforge.net/sevenzip/lzma${@d.getVar('PV',1).replace('.','')}.tar.bz2;subdir=${BPN}-${PV} \ |
8 | file://001-large_files.patch \ | 8 | file://001-large_files.patch \ |
9 | file://002-lzmp.patch \ | 9 | file://002-lzmp.patch \ |
10 | file://003-compile_fixes.patch \ | 10 | file://003-compile_fixes.patch \ |
diff --git a/meta-oe/recipes-support/nano/nano.inc b/meta-oe/recipes-support/nano/nano.inc index 68bcb2efb7..b73aae00fe 100644 --- a/meta-oe/recipes-support/nano/nano.inc +++ b/meta-oe/recipes-support/nano/nano.inc | |||
@@ -10,7 +10,7 @@ RDEPENDS_${PN} = "ncurses-terminfo" | |||
10 | 10 | ||
11 | INC_PR = "r3" | 11 | INC_PR = "r3" |
12 | 12 | ||
13 | PV_MAJOR = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 13 | PV_MAJOR = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
14 | 14 | ||
15 | SRC_URI = "http://www.nano-editor.org/dist/v${PV_MAJOR}/nano-${PV}.tar.gz" | 15 | SRC_URI = "http://www.nano-editor.org/dist/v${PV_MAJOR}/nano-${PV}.tar.gz" |
16 | 16 | ||
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb index 6d0121c760..28770932aa 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb | |||
@@ -40,23 +40,23 @@ TARGET_CC_ARCH += "-I${S}/include " | |||
40 | PACKAGES += "${PN}-apps python-opencv" | 40 | PACKAGES += "${PN}-apps python-opencv" |
41 | 41 | ||
42 | python populate_packages_prepend () { | 42 | python populate_packages_prepend () { |
43 | cv_libdir = bb.data.expand('${libdir}', d) | 43 | cv_libdir = d.expand('${libdir}') |
44 | cv_libdir_dbg = bb.data.expand('${libdir}/.debug', d) | 44 | cv_libdir_dbg = d.expand('${libdir}/.debug') |
45 | do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev', allow_links=True) | 45 | do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev', allow_links=True) |
46 | do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | 46 | do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') |
47 | do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | 47 | do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') |
48 | do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenCV %s library', extra_depends='', allow_links=True) | 48 | do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenCV %s library', extra_depends='', allow_links=True) |
49 | 49 | ||
50 | pn = bb.data.getVar('PN', d, 1) | 50 | pn = d.getVar('PN', 1) |
51 | metapkg = pn + '-dev' | 51 | metapkg = pn + '-dev' |
52 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) | 52 | d.setVar('ALLOW_EMPTY_' + metapkg, "1") |
53 | blacklist = [ metapkg ] | 53 | blacklist = [ metapkg ] |
54 | metapkg_rdepends = [ ] | 54 | metapkg_rdepends = [ ] |
55 | packages = bb.data.getVar('PACKAGES', d, 1).split() | 55 | packages = d.getVar('PACKAGES', 1).split() |
56 | for pkg in packages[1:]: | 56 | for pkg in packages[1:]: |
57 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): | 57 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): |
58 | metapkg_rdepends.append(pkg) | 58 | metapkg_rdepends.append(pkg) |
59 | bb.data.setVar('RRECOMMENDS_' + metapkg, ' '.join(metapkg_rdepends), d) | 59 | d.setVar('RRECOMMENDS_' + metapkg, ' '.join(metapkg_rdepends)) |
60 | } | 60 | } |
61 | 61 | ||
62 | FILES_${PN} = "" | 62 | FILES_${PN} = "" |
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb index 8d9bd6c6b6..b9441efc5e 100644 --- a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb +++ b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb | |||
@@ -11,7 +11,7 @@ LICENSE = "OpenLDAP" | |||
11 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3d82d3085f228af211a6502c7ea7c3c7" | 11 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3d82d3085f228af211a6502c7ea7c3c7" |
12 | SECTION = "libs" | 12 | SECTION = "libs" |
13 | 13 | ||
14 | LDAP_VER = "${@'.'.join(bb.data.getVar('PV',d,1).split('.')[0:2])}" | 14 | LDAP_VER = "${@'.'.join(d.getVar('PV',1).split('.')[0:2])}" |
15 | 15 | ||
16 | SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${P}.tgz" | 16 | SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${P}.tgz" |
17 | SRC_URI += "file://openldap-m4-pthread.patch" | 17 | SRC_URI += "file://openldap-m4-pthread.patch" |
@@ -252,19 +252,19 @@ pkg_prerm_${PN}-slapd () { | |||
252 | PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*" | 252 | PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*" |
253 | 253 | ||
254 | python populate_packages_prepend () { | 254 | python populate_packages_prepend () { |
255 | backend_dir = bb.data.expand('${libexecdir}/openldap', d) | 255 | backend_dir = d.expand('${libexecdir}/openldap') |
256 | do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True) | 256 | do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True) |
257 | 257 | ||
258 | metapkg = "openldap-backends" | 258 | metapkg = "openldap-backends" |
259 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) | 259 | d.setVar('ALLOW_EMPTY_' + metapkg, "1") |
260 | bb.data.setVar('FILES_' + metapkg, "", d) | 260 | d.setVar('FILES_' + metapkg, "") |
261 | metapkg_rdepends = [] | 261 | metapkg_rdepends = [] |
262 | packages = bb.data.getVar('PACKAGES', d, 1).split() | 262 | packages = d.getVar('PACKAGES', 1).split() |
263 | for pkg in packages[1:]: | 263 | for pkg in packages[1:]: |
264 | if pkg.count("openldap-backend-") and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale"): | 264 | if pkg.count("openldap-backend-") and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale"): |
265 | metapkg_rdepends.append(pkg) | 265 | metapkg_rdepends.append(pkg) |
266 | bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) | 266 | d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends)) |
267 | bb.data.setVar('DESCRIPTION_' + metapkg, 'OpenLDAP backends meta package', d) | 267 | d.setVar('DESCRIPTION_' + metapkg, 'OpenLDAP backends meta package') |
268 | packages.append(metapkg) | 268 | packages.append(metapkg) |
269 | bb.data.setVar('PACKAGES', ' '.join(packages), d) | 269 | d.setVar('PACKAGES', ' '.join(packages)) |
270 | } | 270 | } |
diff --git a/meta-oe/recipes-support/pidgin/pidgin.inc b/meta-oe/recipes-support/pidgin/pidgin.inc index cb2a59799a..340e7f2b05 100644 --- a/meta-oe/recipes-support/pidgin/pidgin.inc +++ b/meta-oe/recipes-support/pidgin/pidgin.inc | |||
@@ -59,9 +59,9 @@ FILES_${PN}-dev += "${libdir}/${PN}/*.la" | |||
59 | PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*" | 59 | PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*" |
60 | 60 | ||
61 | python populate_packages_prepend () { | 61 | python populate_packages_prepend () { |
62 | pidgroot = bb.data.expand('${libdir}/pidgin', d) | 62 | pidgroot = d.expand('${libdir}/pidgin') |
63 | purple = bb.data.expand('${libdir}/purple-2', d) | 63 | purple = d.expand('${libdir}/purple-2') |
64 | finch = bb.data.expand('${libdir}/finch', d) | 64 | finch = d.expand('${libdir}/finch') |
65 | 65 | ||
66 | do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$', | 66 | do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$', |
67 | output_pattern='pidgin-plugin-%s', | 67 | output_pattern='pidgin-plugin-%s', |
diff --git a/meta-oe/recipes-support/poppler/poppler-fpu.inc b/meta-oe/recipes-support/poppler/poppler-fpu.inc index 11df852806..67d97ca8e5 100644 --- a/meta-oe/recipes-support/poppler/poppler-fpu.inc +++ b/meta-oe/recipes-support/poppler/poppler-fpu.inc | |||
@@ -1,6 +1,6 @@ | |||
1 | 1 | ||
2 | def get_poppler_fpu_setting(bb, d): | 2 | def get_poppler_fpu_setting(bb, d): |
3 | if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]: | 3 | if d.getVar('TARGET_FPU', 1) in [ 'soft' ]: |
4 | return "--enable-fixedpoint" | 4 | return "--enable-fixedpoint" |
5 | return "" | 5 | return "" |
6 | 6 | ||
diff --git a/meta-oe/recipes-support/vim/vim.inc b/meta-oe/recipes-support/vim/vim.inc index 7b036a7c8a..16ca58d4ee 100644 --- a/meta-oe/recipes-support/vim/vim.inc +++ b/meta-oe/recipes-support/vim/vim.inc | |||
@@ -6,8 +6,8 @@ RSUGGESTS_${PN} = "diffutils" | |||
6 | LICENSE = "vim" | 6 | LICENSE = "vim" |
7 | LIC_FILES_CHKSUM = "file://README.txt;md5=72c4840d07b65659b60b3fa405c7da36" | 7 | LIC_FILES_CHKSUM = "file://README.txt;md5=72c4840d07b65659b60b3fa405c7da36" |
8 | 8 | ||
9 | PV_MAJOR = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" | 9 | PV_MAJOR = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
10 | VIMDIR = "${@bb.data.getVar('PV',d,1).split('.')[0]}${@bb.data.getVar('PV',d,1).split('.')[1]}" | 10 | VIMDIR = "${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}" |
11 | 11 | ||
12 | INC_PR = "r11" | 12 | INC_PR = "r11" |
13 | 13 | ||