summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-01-28 17:33:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-15 10:15:26 +0100
commit32ed5e4e15cd595ee41145e7247772f4e5f00b9e (patch)
tree077901c255c2f91d3a205aa4a6e2a73dca068cda /meta-oe/recipes-support
parent33965e42d2d4c941b57f8e865535d83574d16df3 (diff)
downloadmeta-openembedded-32ed5e4e15cd595ee41145e7247772f4e5f00b9e.tar.gz
start-stop-daemon: Upgrade 1.16.0.2 -> 1.17.25
Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Brad Mouring <brad.mouring@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch39
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb (renamed from meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb)20
2 files changed, 51 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch
new file mode 100644
index 000000000..e988efded
--- /dev/null
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch
@@ -0,0 +1,39 @@
1From 685645a20e39cf2ab7db8d1f5e3666a4228abca8 Mon Sep 17 00:00:00 2001
2From: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
3Date: Wed, 8 Jul 2015 09:44:57 +0300
4Subject: [PATCH 1/1] dpkg start-stop-daemon: Accept SIG prefixed signal names
5
6---
7 utils/start-stop-daemon.c | 9 +++++++++
8 1 file changed, 9 insertions(+)
9
10diff --git a/utils/start-stop-daemon.c b/utils/start-stop-daemon.c
11index 6aebe9b..e805082 100644
12--- a/utils/start-stop-daemon.c
13+++ b/utils/start-stop-daemon.c
14@@ -18,6 +18,9 @@
15 * and Andreas Schuldei <andreas@schuldei.org>
16 *
17 * Changes by Ian Jackson: added --retry (and associated rearrangements).
18+ *
19+ * Changes by Haris Okanovic <haris.okanovic@ni.com> to support 'SIG'
20+ * prefixed signal names placed in public domain as well.
21 */
22
23 #include <config.h>
24@@ -661,6 +664,12 @@ parse_signal(const char *sig_str, int *sig_num)
25 if (parse_unsigned(sig_str, 10, sig_num) == 0)
26 return 0;
27
28+ /* Skip over optional "SIG" prefix */
29+ if (strncmp(sig_str, "SIG", 3) == 0) {
30+ warning("Using deprecated signal name %s. Drop the 'SIG' prefix.\n", sig_str);
31+ sig_str += 3;
32+ }
33+
34 for (i = 0; i < array_count(siglist); i++) {
35 if (strcmp(sig_str, siglist[i].name) == 0) {
36 *sig_num = siglist[i].signal;
37--
382.1.4
39
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
index efdd6b714..5ee4472cd 100644
--- a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
@@ -1,27 +1,26 @@
1SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \ 1SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \
2package" 2package"
3LICENSE = "PD" 3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;md5=a963623e4588f70122865aaa7a370ce4" 4LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;endline=21;md5=8fbd0497a7d0b01e99820bffcb58e9ad"
5# start-stop-daemon is usually shipped by dpkg 5# start-stop-daemon is usually shipped by dpkg
6DEPENDS = "ncurses" 6DEPENDS = "ncurses"
7RCONFLICTS_${PN} = "dpkg" 7RCONFLICTS_${PN} = "dpkg"
8 8
9PNBLACKLIST[start-stop-daemon] ?= "BROKEN: fails because of gettext, partial fix is available here http://patchwork.openembedded.org/patch/89867/" 9SRC_URI = " \
10 ${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.xz \
11 file://0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch \
12"
10 13
11SRC_URI = "http://sources.openembedded.org/dpkg_${PV}.tar.bz2" 14SRC_URI[md5sum] = "e48fcfdb2162e77d72c2a83432d537ca"
12SRC_URI[md5sum] = "d211a84f38987771a49ad1c0f144334a" 15SRC_URI[sha256sum] = "07019d38ae98fb107c79dbb3690cfadff877f153b8c4970e3a30d2e59aa66baa"
13SRC_URI[sha256sum] = "2a3d4ba83c743b3f004533fdd52372cb7b22f5c1da2042d0a31bbcc2b54c0ea5"
14 16
15inherit autotools gettext pkgconfig 17inherit autotools gettext pkgconfig
16 18
17S = "${WORKDIR}/dpkg-${PV}" 19S = "${WORKDIR}/dpkg-${PV}"
18 20
19EXTRA_OECONF = " \ 21EXTRA_OECONF = " \
20 --with-start-stop-daemon \
21 --without-bz2 \ 22 --without-bz2 \
22 --without-install-info \
23 --without-selinux \ 23 --without-selinux \
24 --without-update-alternatives \
25" 24"
26 25
27do_install_append () { 26do_install_append () {
@@ -29,4 +28,9 @@ do_install_append () {
29 # is no explicit rule for only installing ssd 28 # is no explicit rule for only installing ssd
30 find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \; 29 find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \;
31 find ${D} -depth -type d -empty -exec rmdir {} \; 30 find ${D} -depth -type d -empty -exec rmdir {} \;
31
32 # support for buggy init.d scripts that refer to an alternative
33 # explicit path to start-stop-daemon
34 mkdir -p ${D}/sbin/
35 ln -sf /usr/sbin/start-stop-daemon ${D}/sbin/start-stop-daemon
32} 36}