diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2014-04-15 15:01:26 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-04-21 13:31:47 +0200 |
commit | 72b21ffad37e520da3e10fe91bf3246774da0e46 (patch) | |
tree | 4e7df642a387fce9814ea210c48333343c5f4770 /meta-oe/recipes-support | |
parent | c51deaaa366bebac0d69efe01a762fb3771fae3f (diff) | |
download | meta-openembedded-72b21ffad37e520da3e10fe91bf3246774da0e46.tar.gz |
gd: fix the subdir-objects error
Fix this error:
iautomake: warning: possible forward-incompatibility.
automake: At least a source file is in a subdirectory, but the 'subdir-objects'
automake: automake option hasn't been enabled. For now, the corresponding output
automake: object file(s) will be placed in the top-level directory. However,
automake: this behaviour will change in future Automake versions: they will
automake: unconditionally cause object files to be placed in the same subdirectory
automake: of the corresponding sources.
automake: You are advised to start using 'subdir-objects' option throughout your
automake: project, to avoid future incompatibilities.
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch | 39 | ||||
-rw-r--r-- | meta-oe/recipes-support/gd/gd_2.1.0.bb | 4 |
2 files changed, 42 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch b/meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch new file mode 100644 index 000000000..02b167067 --- /dev/null +++ b/meta-oe/recipes-support/gd/gd-2.1.0/fix-the-subdir-objects-error.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From b1ae702a48888e2c3b0ebe0772a88b45a37b84f5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Robert Yang <liezhi.yang@windriver.com> | ||
3 | Date: Fri, 17 Jan 2014 01:58:05 -0500 | ||
4 | Subject: [PATCH] configure.ac: fix the subdir-objects error | ||
5 | |||
6 | Fix this error: | ||
7 | iautomake: warning: possible forward-incompatibility. | ||
8 | automake: At least a source file is in a subdirectory, but the 'subdir-objects' | ||
9 | automake: automake option hasn't been enabled. For now, the corresponding output | ||
10 | automake: object file(s) will be placed in the top-level directory. However, | ||
11 | automake: this behaviour will change in future Automake versions: they will | ||
12 | automake: unconditionally cause object files to be placed in the same subdirectory | ||
13 | automake: of the corresponding sources. | ||
14 | automake: You are advised to start using 'subdir-objects' option throughout your | ||
15 | automake: project, to avoid future incompatibilities. | ||
16 | |||
17 | Upstream-Status: Pending | ||
18 | |||
19 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
20 | --- | ||
21 | configure.ac | 2 +- | ||
22 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/configure.ac b/configure.ac | ||
25 | index 2f9f744..438e08b 100644 | ||
26 | --- a/configure.ac | ||
27 | +++ b/configure.ac | ||
28 | @@ -45,7 +45,7 @@ AC_SUBST(GDLIB_AGE) | ||
29 | FEATURES="GD_GIF GD_GIFANIM GD_OPENPOLYGON" | ||
30 | AC_SUBST(FEATURES) | ||
31 | |||
32 | -AM_INIT_AUTOMAKE([foreign dist-bzip2 dist-xz -Wall -Werror]) | ||
33 | +AM_INIT_AUTOMAKE([foreign dist-bzip2 dist-xz -Wall -Werror subdir-objects]) | ||
34 | AC_CONFIG_HEADERS([src/config.h:src/config.hin]) | ||
35 | |||
36 | dnl newer automake wants this, but we still want to work with older | ||
37 | -- | ||
38 | 1.7.10.4 | ||
39 | |||
diff --git a/meta-oe/recipes-support/gd/gd_2.1.0.bb b/meta-oe/recipes-support/gd/gd_2.1.0.bb index 552ff90e3..a260cd67b 100644 --- a/meta-oe/recipes-support/gd/gd_2.1.0.bb +++ b/meta-oe/recipes-support/gd/gd_2.1.0.bb | |||
@@ -12,7 +12,9 @@ LICENSE = "GD" | |||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669" | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669" |
13 | DEPENDS = "freetype libpng jpeg zlib" | 13 | DEPENDS = "freetype libpng jpeg zlib" |
14 | 14 | ||
15 | SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2" | 15 | SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \ |
16 | file://fix-the-subdir-objects-error.patch \ | ||
17 | " | ||
16 | SRC_URI[md5sum] = "5a1d5bab3a4a41d9f111bcceee4ad25b" | 18 | SRC_URI[md5sum] = "5a1d5bab3a4a41d9f111bcceee4ad25b" |
17 | SRC_URI[sha256sum] = "f3e1bc472bd81ee976a739436659fe752a14727a964c64530fde68531ddeee91" | 19 | SRC_URI[sha256sum] = "f3e1bc472bd81ee976a739436659fe752a14727a964c64530fde68531ddeee91" |
18 | 20 | ||