diff options
author | Matthieu CRAPET <Matthieu.CRAPET@ingenico.com> | 2014-02-24 15:40:41 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-03-11 14:58:49 +0100 |
commit | 92e26f5f69d8918c1e37890c07e2691febed4a2b (patch) | |
tree | 4815b1ce9868990694008b0c96a85709ddcb1d86 /meta-oe/recipes-support | |
parent | fef89c60f381d52ddcbcf557b4082ed46233906c (diff) | |
download | meta-openembedded-92e26f5f69d8918c1e37890c07e2691febed4a2b.tar.gz |
xdelta3: add new recipe for version 3.0.8
Useful command line tool for handling binary diff.
Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/xdelta/files/compilation-fix.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb | 15 |
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xdelta/files/compilation-fix.patch b/meta-oe/recipes-support/xdelta/files/compilation-fix.patch new file mode 100644 index 000000000..377a0436d --- /dev/null +++ b/meta-oe/recipes-support/xdelta/files/compilation-fix.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | Upstream-Status: Pending | ||
2 | http://code.google.com/p/xdelta/issues/detail?id=174 | ||
3 | |||
4 | Compilation fix: | ||
5 | <code> | ||
6 | | testing/regtest.cc:763:3: error: no matching function for call to 'max(xoff_t, size_t&)' | ||
7 | </code> | ||
8 | |||
9 | Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> | ||
10 | --- | ||
11 | testing/regtest.cc | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/testing/regtest.cc b/testing/regtest.cc | ||
15 | index 12b712e..b63a1f9 100644 | ||
16 | --- a/testing/regtest.cc | ||
17 | +++ b/testing/regtest.cc | ||
18 | @@ -12,7 +12,7 @@ public: | ||
19 | Options() : encode_srcwin_maxsz(1<<20), | ||
20 | block_size(Constants::BLOCK_SIZE), | ||
21 | size_known(false) { } | ||
22 | - size_t encode_srcwin_maxsz; | ||
23 | + xoff_t encode_srcwin_maxsz; | ||
24 | size_t block_size; | ||
25 | bool size_known; | ||
26 | }; | ||
27 | -- | ||
28 | 1.8.5.4 | ||
29 | |||
diff --git a/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb new file mode 100644 index 000000000..16a72ee8e --- /dev/null +++ b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "Xdelta is a tool for differential compression" | ||
2 | DESCRIPTION = "Open-source binary diff, differential compression tools, \ | ||
3 | VCDIFF (RFC 3284) delta compression." | ||
4 | HOMEPAGE = "http://xdelta.org/" | ||
5 | SECTION = "console/utils" | ||
6 | |||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" | ||
9 | |||
10 | SRC_URI = "http://xdelta.googlecode.com/files/${BPN}-${PV}.tar.xz \ | ||
11 | file://compilation-fix.patch" | ||
12 | SRC_URI[md5sum] = "c3ae3286ce4193de8e03d5bcaccf3bc3" | ||
13 | SRC_URI[sha256sum] = "3a86f29c95664fb44b8a40ff22d9bcc3e87aa8c01f0ff75931a7fa78ed3d2e55" | ||
14 | |||
15 | inherit autotools | ||