diff options
author | Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> | 2016-04-01 23:36:26 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-12 11:07:46 +0200 |
commit | 3c1e8556d71c35b3b602d24f53408103ffedbd83 (patch) | |
tree | 30081724ea572de18c2fa20c6949715e5445d9b7 /meta-oe/recipes-support | |
parent | bf0f22ab9557e9bf15e269d5e721b422a53bc7d4 (diff) | |
download | meta-openembedded-3c1e8556d71c35b3b602d24f53408103ffedbd83.tar.gz |
opencv: Fix pkg-config file.
Libdir was pointing to the wrong location
also fix for QA Issue: opencv.pc failed sanity test (tmpdir) in path
Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv/fixpkgconfig.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_3.1.bb | 3 |
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/fixpkgconfig.patch b/meta-oe/recipes-support/opencv/opencv/fixpkgconfig.patch new file mode 100644 index 000000000..3aeda7d44 --- /dev/null +++ b/meta-oe/recipes-support/opencv/opencv/fixpkgconfig.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | diff --git a/cmake/OpenCVGenPkgconfig.cmake b/cmake/OpenCVGenPkgconfig.cmake | ||
2 | index b8cb8777c06b..75281ee964fd 100644 | ||
3 | --- a/cmake/OpenCVGenPkgconfig.cmake | ||
4 | +++ b/cmake/OpenCVGenPkgconfig.cmake | ||
5 | @@ -27,7 +27,7 @@ macro(fix_prefix lst isown) | ||
6 | get_filename_component(libdir "${item}" PATH) | ||
7 | get_filename_component(libname "${item}" NAME_WE) | ||
8 | string(REGEX REPLACE "^lib(.*)" "\\1" libname "${libname}") | ||
9 | - list(APPEND _lst "-L${libdir}" "-l${libname}") | ||
10 | + list(APPEND _lst "-l${libname}") | ||
11 | else() | ||
12 | list(APPEND _lst "-l${item}") | ||
13 | endif() | ||
14 | @@ -66,10 +66,14 @@ ocv_list_unique(_3rdparty) | ||
15 | |||
16 | set(OPENCV_PC_LIBS | ||
17 | "-L\${exec_prefix}/${OPENCV_LIB_INSTALL_PATH}" | ||
18 | + "-L\${exec_prefix}/${OPENCV_3P_LIB_INSTALL_PATH}" | ||
19 | "${_modules}" | ||
20 | ) | ||
21 | if (BUILD_SHARED_LIBS) | ||
22 | - set(OPENCV_PC_LIBS_PRIVATE "${_extra}") | ||
23 | + set(OPENCV_PC_LIBS_PRIVATE | ||
24 | + "-L\${exec_prefix}/${OPENCV_LIB_INSTALL_PATH}" | ||
25 | + "${_extra}" | ||
26 | + ) | ||
27 | else() | ||
28 | set(OPENCV_PC_LIBS_PRIVATE | ||
29 | "-L\${exec_prefix}/${OPENCV_3P_LIB_INSTALL_PATH}" | ||
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb index b8fb6a513..6f0c83829 100644 --- a/meta-oe/recipes-support/opencv/opencv_3.1.bb +++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb | |||
@@ -16,7 +16,8 @@ SRCREV_opencv = "92387b1ef8fad15196dd5f7fb4931444a68bc93a" | |||
16 | SRCREV_contrib = "5409d5ad560523c85c6796cc5a009347072d883c" | 16 | SRCREV_contrib = "5409d5ad560523c85c6796cc5a009347072d883c" |
17 | SRCREV_FORMAT = "opencv" | 17 | SRCREV_FORMAT = "opencv" |
18 | SRC_URI = "git://github.com/Itseez/opencv.git;name=opencv \ | 18 | SRC_URI = "git://github.com/Itseez/opencv.git;name=opencv \ |
19 | git://github.com/Itseez/opencv_contrib.git;destsuffix=contrib;name=contrib" | 19 | git://github.com/Itseez/opencv_contrib.git;destsuffix=contrib;name=contrib \ |
20 | file://fixpkgconfig.patch" | ||
20 | 21 | ||
21 | PV = "3.1+git${SRCPV}" | 22 | PV = "3.1+git${SRCPV}" |
22 | 23 | ||