diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2015-05-26 13:07:13 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-05-28 10:35:16 +0200 |
commit | 2538cf6f7b2ed384b3880fee2942b7287acfa9d4 (patch) | |
tree | 1a86eca1ec2b40c1a9f91b6d036a4d8cb4091dc4 /meta-oe/recipes-support | |
parent | bb09fdb283a913dc641247a8d25bad261d3fc71e (diff) | |
download | meta-openembedded-2538cf6f7b2ed384b3880fee2942b7287acfa9d4.tar.gz |
poppler: fix configure by pointing on moc
As discussed in [1] configure was detecting host's moc and failing in some
configurations.
To get this fixed configure gets a parameter by which the location of moc
is set.
[1] http://lists.openembedded.org/pipermail/openembedded-devel/2015-May/101641.html
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch | 91 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler_0.33.0.bb | 3 |
2 files changed, 93 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch b/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch new file mode 100644 index 000000000..560b07323 --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch | |||
@@ -0,0 +1,91 @@ | |||
1 | From 91b6275f0e91c25beb040b4ef9484053ae305d86 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Tue, 26 May 2015 12:45:47 +0200 | ||
4 | Subject: [PATCH] add manadatory options to find qt4/qt5 moc | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE specific] | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
12 | --- | ||
13 | configure.ac | 55 ++++++++----------------------------------------------- | ||
14 | 1 file changed, 8 insertions(+), 47 deletions(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 67599c0..40fa596 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -622,25 +622,10 @@ AC_SUBST(POPPLER_QT4_LIBS) | ||
21 | AC_SUBST(POPPLER_QT4_TEST_LIBS) | ||
22 | |||
23 | if test x$enable_poppler_qt4 = xyes; then | ||
24 | - AC_CHECK_TOOL(MOCQT4, moc) | ||
25 | - AC_MSG_CHECKING([for Qt4 moc]) | ||
26 | - mocversion=`$MOCQT4 -v 2>&1` | ||
27 | - mocversiongrep=`echo $mocversion | grep "Qt 4"` | ||
28 | - if test x"$mocversiongrep" != x"$mocversion"; then | ||
29 | - AC_MSG_RESULT([no]) | ||
30 | - # moc was not the qt4 one, try with moc-qt4 | ||
31 | - AC_CHECK_TOOL(MOCQT42, moc-qt4) | ||
32 | - AC_MSG_CHECKING([for Qt4 moc-qt4]) | ||
33 | - mocversion=`$MOCQT42 -v 2>&1` | ||
34 | - mocversiongrep=`echo $mocversion | grep "Qt 4"` | ||
35 | - if test x"$mocversiongrep" != x"$mocversion"; then | ||
36 | - # no valid moc found | ||
37 | - enable_poppler_qt4=no; | ||
38 | - MOCQT4="not found" | ||
39 | - else | ||
40 | - MOCQT4=$MOCQT42 | ||
41 | - fi | ||
42 | - fi | ||
43 | + AC_ARG_WITH([moc-qt4], | ||
44 | + AS_HELP_STRING([--with-moc-qt4], [Set location of qt4 moc]), | ||
45 | + [MOCQT4=$withval] | ||
46 | + ) | ||
47 | AC_SUBST(MOCQT4) | ||
48 | AC_MSG_RESULT([$MOCQT4]) | ||
49 | fi | ||
50 | @@ -679,34 +664,10 @@ AC_SUBST(POPPLER_QT5_LIBS) | ||
51 | AC_SUBST(POPPLER_QT5_TEST_LIBS) | ||
52 | |||
53 | if test x$enable_poppler_qt5 = xyes; then | ||
54 | - AC_CHECK_TOOL(MOCQT5, moc) | ||
55 | - AC_MSG_CHECKING([for Qt5 moc]) | ||
56 | - mocversion=`$MOCQT5 -v 2>&1` | ||
57 | - mocversiongrep=`echo $mocversion | grep "Qt 5\|moc 5"` | ||
58 | - if test x"$mocversiongrep" != x"$mocversion"; then | ||
59 | - AC_MSG_RESULT([no]) | ||
60 | - # moc was not the qt5 one, try with moc-qt5 | ||
61 | - AC_CHECK_TOOL(MOCQT52, moc-qt5) | ||
62 | - AC_MSG_CHECKING([for Qt5 moc-qt5]) | ||
63 | - mocversion=`$MOCQT52 -v 2>&1` | ||
64 | - mocversiongrep=`echo $mocversion | grep "Qt 5\|moc-qt5 5\|moc 5"` | ||
65 | - if test x"$mocversiongrep" != x"$mocversion"; then | ||
66 | - AC_CHECK_TOOL(QTCHOOSER, qtchooser) | ||
67 | - AC_MSG_CHECKING([for qtchooser]) | ||
68 | - qt5tooldir=`QT_SELECT=qt5 qtchooser -print-env | grep QTTOOLDIR | cut -d '=' -f 2 | cut -d \" -f 2` | ||
69 | - mocversion=`$qt5tooldir/moc -v 2>&1` | ||
70 | - mocversiongrep=`echo $mocversion | grep "Qt 5\|moc 5"` | ||
71 | - if test x"$mocversiongrep" != x"$mocversion"; then | ||
72 | - # no valid moc found | ||
73 | - enable_poppler_qt5=no; | ||
74 | - MOCQT5="not found" | ||
75 | - else | ||
76 | - MOCQT5=$qt5tooldir/moc | ||
77 | - fi | ||
78 | - else | ||
79 | - MOCQT5=$MOCQT52 | ||
80 | - fi | ||
81 | - fi | ||
82 | + AC_ARG_WITH([moc-qt5], | ||
83 | + AS_HELP_STRING([--with-moc-qt5], [Set location of qt5 moc]), | ||
84 | + [MOCQT5=$withval] | ||
85 | + ) | ||
86 | AC_SUBST(MOCQT5) | ||
87 | AC_MSG_RESULT([$MOCQT5]) | ||
88 | fi | ||
89 | -- | ||
90 | 1.9.3 | ||
91 | |||
diff --git a/meta-oe/recipes-support/poppler/poppler_0.33.0.bb b/meta-oe/recipes-support/poppler/poppler_0.33.0.bb index 6e8446b87..d5362a058 100644 --- a/meta-oe/recipes-support/poppler/poppler_0.33.0.bb +++ b/meta-oe/recipes-support/poppler/poppler_0.33.0.bb | |||
@@ -4,6 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | |||
4 | 4 | ||
5 | SRC_URI = " \ | 5 | SRC_URI = " \ |
6 | http://poppler.freedesktop.org/${BP}.tar.xz \ | 6 | http://poppler.freedesktop.org/${BP}.tar.xz \ |
7 | file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \ | ||
7 | " | 8 | " |
8 | SRC_URI[md5sum] = "69927d1614d6704021c0b0dd0ee6a852" | 9 | SRC_URI[md5sum] = "69927d1614d6704021c0b0dd0ee6a852" |
9 | SRC_URI[sha256sum] = "a5fa6d7f7dc5382b48caca82b147c54bdffda02698611af76db5326ba64995a6" | 10 | SRC_URI[sha256sum] = "a5fa6d7f7dc5382b48caca82b147c54bdffda02698611af76db5326ba64995a6" |
@@ -18,7 +19,7 @@ PACKAGECONFIG[png] = "--enable-libpng,--disable-libpng,libpng" | |||
18 | PACKAGECONFIG[tiff] = "--enable-libtiff,--disable-libtiff,tiff" | 19 | PACKAGECONFIG[tiff] = "--enable-libtiff,--disable-libtiff,tiff" |
19 | PACKAGECONFIG[curl] = "--enable-libcurl,--disable-libcurl,curl" | 20 | PACKAGECONFIG[curl] = "--enable-libcurl,--disable-libcurl,curl" |
20 | PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,openjpeg" | 21 | PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,openjpeg" |
21 | PACKAGECONFIG[qt5] = "--enable-poppler-qt5,--disable-poppler-qt5,qtbase" | 22 | PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase" |
22 | 23 | ||
23 | EXTRA_OECONF = "\ | 24 | EXTRA_OECONF = "\ |
24 | --enable-xpdf-headers \ | 25 | --enable-xpdf-headers \ |