summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-12-02 14:56:44 +0100
committerKhem Raj <raj.khem@gmail.com>2019-12-03 09:31:53 -0800
commitd1c21635ab2f30b13545392a859c7aed395743fe (patch)
tree3370d4d5822772a41092eeb8b1f9d5248f114fa3 /meta-oe/recipes-support
parent09f7732b156690fa2a2441e041733211e16ea879 (diff)
downloadmeta-openembedded-d1c21635ab2f30b13545392a859c7aed395743fe.tar.gz
xserver-xorg-cvt-native: initial add 1.20.5
upcoming mutter requires cvt to calculate source code tables of default video modes - wow Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.5.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.5.bb b/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.5.bb
new file mode 100644
index 000000000..1d75d52d2
--- /dev/null
+++ b/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.5.bb
@@ -0,0 +1,41 @@
1SUMMARY = "X.Org X cvt"
2HOMEPAGE = "https://linux.die.net/man/1/cvt"
3LICENSE = "MIT-X"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
5
6DEPENDS += "pixman-native xorgproto-native libxrandr-native"
7
8XORG_PN = "xorg-server"
9
10SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
11SRC_URI[md5sum] = "c9fc7e21e11286dbedd22c00df652130"
12SRC_URI[sha256sum] = "a81d8243f37e75a03d4f8c55f96d0bc25802be6ec45c3bfa5cb614c6d01bac9d"
13
14S = "${WORKDIR}/${XORG_PN}-${PV}"
15B = "${WORKDIR}/build"
16
17inherit native pkgconfig
18
19do_configure[noexec] = "1"
20
21do_compile() {
22 cd ${S}
23 for header in `find -name '*.h'`; do
24 path=`dirname $header`
25 if ! echo "$incpaths" | grep -q "$path" ; then
26 incpaths="$incpaths -I$path"
27 fi
28 done
29 CFLAGS="${CFLAGS} -DXORG_VERSION_CURRENT=1 $incpaths `pkg-config --cflags pixman-1`"
30 LDFLAGS="${LDFLAGS} -lm `pkg-config --libs pixman-1`"
31 ${CC} $CFLAGS -o ${B}/cvt \
32 ${S}/hw/xfree86/utils/cvt/cvt.c \
33 ${S}/hw/xfree86/modes/xf86cvt.c \
34 ${S}/os/xprintf.c \
35 $LDFLAGS
36}
37
38do_install() {
39 install -d ${D}${bindir}
40 install -m 755 ${B}/cvt ${D}${bindir}
41}