summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorPortia <stephensportia@gmail.com>2022-05-01 13:45:33 +1000
committerKhem Raj <raj.khem@gmail.com>2022-05-02 00:48:27 -0700
commitbc4448f4619b436ee0f66e2bdd37d42d65f75656 (patch)
tree1aa6f962e6ad5042f1f33f053247bde5073924cc /meta-oe/recipes-support
parent00f18248b93e0377d5e8a56fa2f7c859a39f661f (diff)
downloadmeta-openembedded-bc4448f4619b436ee0f66e2bdd37d42d65f75656.tar.gz
cpulimit: introduce support for this package
Now, cpulimit recipe is put under recipes-support. Binary will be installed by the recipe under /usr/sbin # cpulimit -h Usage: cpulimit [OPTIONS...] TARGET OPTIONS -l, --limit=N percentage of cpu allowed from 0 to 100 (required) -v, --verbose show control statistics -z, --lazy exit if there is no target process, or if it dies -i, --include-children limit also the children processes -h, --help display this help and exit TARGET must be exactly one of these: -p, --pid=N pid of the process (implies -z) -e, --exe=FILE name of the executable program file or path name COMMAND [ARGS] run this command and limit it (implies -z) Report bugs to <marlon...@hotmail.com>. Signed-off-by: Bassem Boubaker <bassem.boubaker@actia.fr> [ Changes by Portia - Fix build issue, deprecated and missing includes - Add branch to git repo in SRC_URI - Update LICENSE to GPL-2.0-or-later ] Signed-off-by: Portia <stephensportia@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/cpulimit/cpulimit/0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch41
-rw-r--r--meta-oe/recipes-support/cpulimit/cpulimit_0.2.bb22
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpulimit/cpulimit/0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch b/meta-oe/recipes-support/cpulimit/cpulimit/0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch
new file mode 100644
index 000000000..50d0342ec
--- /dev/null
+++ b/meta-oe/recipes-support/cpulimit/cpulimit/0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch
@@ -0,0 +1,41 @@
1From 41cfba0840f58555593fd4bee07db77221043e0b Mon Sep 17 00:00:00 2001
2From: Portia <stephensportia@gmail.com>
3Date: Sun, 1 May 2022 12:43:35 +1000
4Subject: [PATCH] Remove sys/sysctl.h and add missing libgen.h include
5
6- sys/sysctl.h has been deprecated and should be removed
7- Adds missing libgen.h include when calling basename()
8
9Upstream-Status: Inactive-Upstream [2015]
10Signed-off-by: Portia <stephensportia@gmail.com>
11---
12 src/cpulimit.c | 1 -
13 src/process_group.c | 1 +
14 2 files changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/cpulimit.c b/src/cpulimit.c
17index 50eabea..5b0ec49 100644
18--- a/src/cpulimit.c
19+++ b/src/cpulimit.c
20@@ -38,7 +38,6 @@
21 #include <string.h>
22 #include <sys/stat.h>
23 #include <sys/time.h>
24-#include <sys/sysctl.h>
25 #include <sys/resource.h>
26 #include <sys/types.h>
27 #include <sys/wait.h>
28diff --git a/src/process_group.c b/src/process_group.c
29index 06d73a6..d4f6fab 100644
30--- a/src/process_group.c
31+++ b/src/process_group.c
32@@ -24,6 +24,7 @@
33 #include <limits.h>
34 #include <sys/time.h>
35 #include <signal.h>
36+#include <libgen.h>
37
38 #include <assert.h>
39
40--
412.25.1
diff --git a/meta-oe/recipes-support/cpulimit/cpulimit_0.2.bb b/meta-oe/recipes-support/cpulimit/cpulimit_0.2.bb
new file mode 100644
index 000000000..3ee2b5c23
--- /dev/null
+++ b/meta-oe/recipes-support/cpulimit/cpulimit_0.2.bb
@@ -0,0 +1,22 @@
1SUMMARY = "cpulimit is a tool which limits the CPU usage of a process"
2HOMEPAGE = "http://cpulimit.sourceforge.net"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86c1c0d961a437e529db93aa3bb32dc4"
5SRCREV ?= "f4d2682804931e7aea02a869137344bb5452a3cd"
6
7SRC_URI = "git://g...@github.com/opsengine/cpulimit.git;protocol=https;branch=master \
8 file://0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch \
9 "
10
11S = "${WORKDIR}/git"
12
13do_compile() {
14 oe_runmake all
15}
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 ${B}/src/${PN} ${D}${sbindir}/
19}
20
21CFLAGS += "${LDFLAGS}"
22